RESOLVED - LCD screen not working, HDMI does
#1
EDIT: IT WORKS! - THE ONLY THING I DID DIFFERENT WAS USE NOTEPAD++ TO UNCOMMENT THE UENV.TXT FILE RATHER THAN NORMAL NOTEPAD (SORRY IF THAT WAS AN OBVIOUS MOVE? BUT IT WASN'T TO ME. Thanks to everyone for the help though

Hey

I know there are other threads out there with similar issues and people have managed to fix it, but i have tried everything that i'm aware of and can find but i cant get my LCD to work.

(I have the 2gb Pine)
  • All cables are correctly connected
  • I've disconnected the keyboard USB and camera
  • It's definitely the right image (android LCD - i have used the android 6 LCD and the android 7 DD image (64gb) ) (I used 7zip and rufus for the image writing)
  • The power light stays on when plugged into HDMI but doesn't always when plugged into the LCD (its really temperamental - sometimes it stays on sometimes it doesn't it depends what image I'm using  - v6 it stays on - v7 it didnt stay on at first now it does - but on both images the screen is blank.
  • I have plugged it into my tv using the HDMI cable and it works fine.
EDIT - I'm using the official Pine64 power supply, 64gb card sent from Pine64 -
EDIT - I managed to get the LCD to work with the earlier android 5.1.1 version (8gb image) but it crashed very quickly
EDIT - tested SDcard with Htestw and it's fine

With both images when plugged into the LCD and the power nothing happens at all no screen flash or anything its just blank. any help would be greatly appreciated.

I'm a bit late in the game in setting up my pine!

if you need any more info please let me know
Backer number #9,952 + KS Funded Jan 23, 2016 + Backerkit funded May 9, 2016

STATUS: RECEIVED,TRACKING NUMBER = PENDING, SHIPPED 27/05/16
  Reply
#2
(03-29-2017, 06:47 AM)asuras Wrote: Hey

I know there are other threads out there with similar issues and people have managed to fix it, but i have tried everything that i'm aware of and can find but i cant get my LCD to work.

All cables are correctly connected
It's definitely the right image (android LCD - i have used the android 6 LCD and the android 7 )
The power light stays on so it's not that i don't think.
I have plugged it into my tv using the HDMI cable and it works fine.

With both images when plugged into the LCD and the power nothing happens at all no screen flash or anything its just blank. any help would be greatly appreciated.

I'm a bit late in the game in setting up my pine!

if you need any more info please let me know

Strange, Android LCD should work without any tinkering. Make sure you are using one of the images denoted as: If you are using ayufan's build then you'll need to edit uEnv.txt to include the following:

Code:
pine64_lcd=on
You can find me on IRC, Discord and Twitter


  Reply
#3
(03-29-2017, 06:58 AM)Luke Wrote: Strange, Android LCD should work without any tinkering. Make sure you are using one of the images denoted as: If you are using ayufan's build then you'll need to edit uEnv.txt to include the following:

Code:
pine64_lcd=on

Yeah that's the image i tried first and it didn't work
Just tried adding that code now the power light stays on for about a minute then goes out, it's being super tempermental sometimes the light stays on and nothing happens and sometimes it goes out after like a minute or two.
Backer number #9,952 + KS Funded Jan 23, 2016 + Backerkit funded May 9, 2016

STATUS: RECEIVED,TRACKING NUMBER = PENDING, SHIPPED 27/05/16
  Reply
#4
Whats your PSU rating ? A solid 5V 3A is what you should be using ... sounds like a power issue to me. You may want to ask in the android thread
You can find me on IRC, Discord and Twitter


  Reply
#5
(03-29-2017, 12:30 PM)Luke Wrote: Whats your PSU rating ? A solid 5V 3A is what you should be using ... sounds like a power issue to me. You may want to ask in the android thread

Right i got it working but using the old android ver5.1.1 8 gb - so i don't know what the issue is with the other ones.. any idea? should i try using a smaller image maybe on the newer versions? (my sd card is the supplied 64gb)

EDIT - one thing i noticed is that when i used the older android version my sdcard labelled itself 'boot' and with the other ones it didn't would this cause an issue?

Has anyone else had issues with the newer android builds 6/7 and managed to fix it? ( I have edited the file that didn't seem to do much)

The power supply should be fine I'm using the one supplied by Pine64 I've tried other power supplies and they don't work, but the power works for HDMI and the earlier 5.1.1 android version.
power also stays on for v6 but the LCD screen is blank - and now its seems to stay on with v7 but the screen is also blank...
Backer number #9,952 + KS Funded Jan 23, 2016 + Backerkit funded May 9, 2016

STATUS: RECEIVED,TRACKING NUMBER = PENDING, SHIPPED 27/05/16
  Reply
#6
can anybody help? I've asked on the android forum to no avail Sad
Backer number #9,952 + KS Funded Jan 23, 2016 + Backerkit funded May 9, 2016

STATUS: RECEIVED,TRACKING NUMBER = PENDING, SHIPPED 27/05/16
  Reply
#7
I think it would be best if you chatted with ayufan directly.
Join the IRC in EU CET afternoon or evening and 'ping him' by using his nick.
Ask the question and wait - it may take some time for him to respond, so don't ask and leave after a few minutes. You have the shortcut to the web chat in my sig.
You can find me on IRC, Discord and Twitter


  Reply
#8
(03-31-2017, 03:33 PM)Luke Wrote: I think it would be best if you chatted with ayufan directly.
Join the IRC in EU CET afternoon or evening and 'ping him' by using his nick.
Ask the question and wait - it may take some time for him to respond, so don't ask and leave after a few minutes. You have the shortcut to the web chat in my sig.

Thank you Smile
Backer number #9,952 + KS Funded Jan 23, 2016 + Backerkit funded May 9, 2016

STATUS: RECEIVED,TRACKING NUMBER = PENDING, SHIPPED 27/05/16
  Reply
#9
Ah just saw your comment in the top post, yes normal Notepad will screw up the Unix line endings, you need some more advanced editors under Windows that preserve Unix/Windows line endings, like Notepad++
Come have a chat in the Pine A64 IRC channel >>
  Reply
#10
(04-01-2017, 05:04 PM)xalius Wrote: Ah just saw your comment in the top post, yes normal Notepad will screw up the Unix line endings, you need some more advanced editors under Windows that preserve Unix/Windows line endings, like Notepad++

Indeed. In a pinch, on Windows, Wordpad is also an almost always available 'built in' option... which thankfully does preserve line endings. Notepad just mangles the lot. Notepad++ is always handy to have on hand though Wink
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Pine HDMI -> DVI monitor Pineapple 4 149 09-10-2019, 11:28 AM
Last Post: Pineapple
  User Screen Black After Changing Power Settings 0b51Gekko 2 70 07-03-2019, 07:53 AM
Last Post: 0b51Gekko
  Input not working after a forced shutdown dic1911 1 141 12-24-2018, 07:45 PM
Last Post: tllim
  Any success working with OpenCV on the PineA64? Tonny91 0 271 10-16-2018, 09:16 PM
Last Post: Tonny91
  Here Is another mini-how-to to install Raspbian:DESKTOP/ETHERNET/HDMI speedro86 4 1,576 04-15-2018, 07:37 AM
Last Post: bunkerWHz
  Rock64 + 7" touch screen naviathan 2 1,387 09-28-2017, 09:01 AM
Last Post: naviathan
  7" Screen - Does it work with Debian abasel 1 405 07-26-2017, 05:44 AM
Last Post: pfeerick
  HDMI "Format not supported" sam452 3 1,477 06-11-2017, 10:38 AM
Last Post: Beta_Ravener
  Mini-Tutorial to get a linux Desktop GUI working on Pine64+ speedro86 15 6,842 04-05-2017, 01:45 PM
Last Post: speedro86
  HDMI and LCD hienhuynh1982 19 3,115 03-23-2017, 10:16 PM
Last Post: tllim

Forum Jump:


Users browsing this thread: 1 Guest(s)