[Solved] My phone won't boot with SD card inserted
I just got my pinephone yesterday and was very excited to test different distros. The phone can boot from SD card without any issue, but I found that after I flashed the image to eMMC and partitioned my SD card again hoping to use it as storage, my phone just won't boot Sad
The SD card is SandDisk Extreme 128GB SDXC that I bought the same day I received the phone, and I'm sure it's genuine.

The screen lights up after holding power button but it won't even show things like red led that implies something went wrong, it just straight out won't boot.
I've already tried the dd command from
Quote:Reuse SD card for data storage on system booting from eMMC
in the official guide, and I've checked with gparted that all of the spaces of my SD card is formatted as fat32. (I've also tried NTFS)

The phone will boot into the OS I flashed into eMMC if I pull out the SD card.

Any suggestions will be appreciated!
Are you sure you did everything right here:
(11-06-2021, 01:54 PM)acrux Wrote: https://wiki.pine64.org/wiki/PinePhone_I..._from_eMMC

Thanks for the reply, but I mentioned I did that already in my post Smile
(11-06-2021, 01:54 PM)acrux Wrote: Are you sure you did everything right here:

(you still have boot bits at the front of the SDcard that have to be cleared.)
  • ROCKPro64 v2.1 2GB, 16Gb eMMC for rootfs, SX8200Pro 512GB NVMe for /home, HDMI video & sound, Bluetooth keyboard & mouse. Arch (6.1 kernel, Openbox desktop) for general purpose daily PC.
  • PinePhone Pro Explorer Edition Tow-boot on SPI, Arch/SXMO on eMMC
  • PinePhone BraveHeart now v1.2b 3/32Gb, daily driver Tow-boot with Arch/SXMO on eMMC
My bad, found out that I need to use the dd command on /dev/sdb (The SD card) instead of /dev/sdb1 (the fat32 partition I created).
I thought accessing /dev/sdb and /dev/sdb1 will be the same if I create a partition using all the free spaces, but apparently I'm horribly wrong.....

Possibly Related Threads…
Thread Author Replies Views Last Post
  New Phone Opening Issues LuluFrance 5 466 03-15-2023, 05:33 AM
Last Post: anonymous
  UPDATED (June 2021): 17-distro multi-boot image for Pinephone (incl. 3GiB variant) megous 183 194,792 03-05-2023, 11:04 AM
Last Post: Eugo
  Device Unable To Read MicroSD Card _radv_ 19 1,645 02-18-2023, 02:01 PM
Last Post: _radv_
  pine phone external speaker AnAbolitionist 9 1,049 02-08-2023, 01:11 AM
Last Post: robb777
Sad New PinePhone won't boot 9/10 times - Screen is on but stays black :( dante404 8 3,086 02-03-2023, 01:27 AM
Last Post: dante404
  SIM Card Slot Terror thismarty 4 483 12-21-2022, 05:37 PM
Last Post: thismarty
  MicroSD Card Reuse _radv_ 5 549 12-12-2022, 12:26 PM
Last Post: chainingsolid
  no sdcard boot and manjaro update failed Gwen 3 425 11-27-2022, 07:56 AM
Last Post: fxc
  new to pine phone and struggling neverdimed 8 878 11-25-2022, 05:01 PM
Last Post: neverdimed
  Pine Phone Doesn't Recognize New MicroSD Card _radv_ 3 436 11-23-2022, 05:19 AM
Last Post: _radv_

Forum Jump:

Users browsing this thread: 1 Guest(s)