SD slot damaged, can't boot from SD, what to do?
I cannot boot from the SD, and apparently I need to do that to flash the eMMC. Pinephone Beta, convergence model, came with Manjaro.

The first time I tried to insert an SD card, it wouldn't go in right. I looked into the slot, and two of the contacts did not look like the others.  My son took it apart and was able see they were bent up.  He was able to bend them down, and I managed to insert an SD with Mobian and boot from it. Now I want to flash Mobian to the eMMC, so I put Jumpdrive on another SD, but now no matter how I insert either SD, it won't boot from it. 

Oddly enough the phone does recognize the SD card after booting from the eMMC! lsblk shows mmcblk0 size 59.9G when the card is inserted, but it won't boot from the SD card it can see after boot!

Two questions:

The SD slot is damaged. Is this repairable?  

The phone does see the SD card after booting, is there a way to make it boot?
Pinephone beta edition, convergence model, Mobian Bookworm with Phosh.
it is not damaged, download again the jumpdrive image and flash it, you flashed a corrupted image or it may got corrupted when you bent the contacts
moreover make sure that you have not damaged the boot sectors of the SDs and that all the pins make contact
Try this modified version of JumpDrive. It ignores the SD detect switch.

If it works you can try bypassing the switch.
Mouffa, you're right that the slot is working as well as ever. I put the same Mobian image I downloaded a while back onto the same SD card using dd, and it boots from it again, same as it ever was.

I'm still trying to sort out what happened. Nearly as I can remember I ran Mobian on the SD for a couple of weeks, then decided I liked it and so I pulled it out of the phone and stuck it into the computer and used

sudo dd bs=1M if=/dev/sdc of=~/Pinephone/20200727.img

to make a backup copy. After that, it wouldn't boot from that SD. I tried booting from the Jumpdrive image also, and that image wouldn't boot, either, so I assumed the slot was acting up again. Anyway, the image I saved is apparently broken, and somehow the Jumpdrive image I downloaded from is also broken. It's very strange that copying from the SD would mess it up, but I think that's what happened.

I want to flash Mobian to the eMMC, so I need to get a working, updated Mobian image off the SD card, and I need to get the Jumpdrive image to boot. I think I should be using the Jumpdrive image named pine64-pinephone (1).img.xz, right?
Pinephone beta edition, convergence model, Mobian Bookworm with Phosh.
this happens with jumpdrive, the image can be corrupted or a write error may happen while flashing, the boot sectors are crucial for a successful booting, I would suggest you keep a bootable OS on the SD and from there you can download and flash the eMMC though you will have to remove the SD every time you boot or keep a separate SD for this purpose, I just pull the SD and leave it in the case, it is secured between the battery and the case
It turned out that the nifty new 64G SD card I bought from Pine doesn't work.  Still don't know how I messed up the install on my old SD that does work, but it's solid for now.

The old Sandisk SD that I bought years ago when 64G was big and expensive still works great. I was able to back up my Mobian install which I had on the Sandisk, then I wrote the Jumpdrive utility to the Sandisk, then I was able to boot that and flash the Mobian install to the eMMC.  Problem solved, except that I got burned on that new SD.
Pinephone beta edition, convergence model, Mobian Bookworm with Phosh.

Possibly Related Threads…
Thread Author Replies Views Last Post
  New Pinephone is dead. eMMC, boot, hardware issues. Shane 4 273 05-10-2023, 03:31 AM
Last Post: fxc
  UPDATED (June 2021): 17-distro multi-boot image for Pinephone (incl. 3GiB variant) megous 183 203,331 03-05-2023, 11:04 AM
Last Post: Eugo
Sad New PinePhone won't boot 9/10 times - Screen is on but stays black :( dante404 8 3,544 02-03-2023, 01:27 AM
Last Post: dante404
  SIM Card Slot Terror thismarty 4 653 12-21-2022, 05:37 PM
Last Post: thismarty
  no sdcard boot and manjaro update failed Gwen 3 576 11-27-2022, 07:56 AM
Last Post: fxc
  Tow-boot on Pinephone beta edition saddamus 10 2,923 09-11-2022, 02:43 PM
Last Post: saddamus
  Boot problem: wrong screen orientation Jetpac 6 2,581 07-18-2022, 12:47 PM
Last Post: fravoi
  Tow Boot - How to Flash a New OS? arkadione 3 1,700 06-15-2022, 04:10 PM
Last Post: kmsgli
  Won't boot - Failed to read Who-Am-I register nocargo 6 4,263 04-30-2022, 06:11 PM
Last Post: TRS-80
  Boot screen stuck at 'K' because of firmware deleted. poundantisec 5 3,051 04-23-2022, 07:01 PM
Last Post: projectsfromb

Forum Jump:

Users browsing this thread: 1 Guest(s)