NVMe SSD testing methodology
#1
I want to test an NVMe SSD drive in the Pinebook Pro that isn't yet in the wiki Hardware Accessory Compatibility list. can someone please write a noob-friendly guide on how to do it? I want to find out the following:
  • whether the system can remain stable while the drive is in sustained heavy use
  • APST default setting
  • whether the power settings are saved across reboots, and if not, is there a workaround
  Reply
#2
(07-20-2021, 10:44 AM)halogen Wrote: I want to test an NVMe SSD drive in the Pinebook Pro that isn't yet in the wiki Hardware Accessory Compatibility list. can someone please write a noob-friendly guide on how to do it? I want to find out the following:
  • whether the system can remain stable while the drive is in sustained heavy use
  • APST default setting
  • whether the power settings are saved across reboots, and if not, is there a workaround
This is the guide I used:
https://eli.gladman.cc/blog/2020/06/23/p...-nvme.html

And of course the wiki:
https://wiki.pine64.org/wiki/Pinebook_Pr...Me_adapter

I found that Manjaro can boot off the NVMe SSD (both boot and / from the NVMe are mounted). However, Manjaro's U-Boot must be present on the eMMC too. Details of my learnings are in my thread here. Read the entire thread as I learn from Manjaro mod, Stritt:
https://forum.manjaro.org/t/pinebook-pro...nvme/72770

As you can see from the title of the thread, I also discovered that Linux.org broke the NVMe boot in going from 5.12.11-1  to 5.13.0-1! I've not had time to test Stritt's theory by putting "CONFIG_PCI_MSI_ARCH_FALLBACKS=y" and the associated msi_controller driver code back into the 5.13 Manjaro kernel source and rebuilding the kernel to see if that fixes it. Details are provided in the thread. I'm still running 5.12.11-1 for this reason.

I'm running the 1TB WD Blue SN550 (‎WDS100T2B0C). In my ad hoc testing, APST mode (the default) seems to work very well and I'm not motivated to try static power settings.

Oops--I forgot to include this thread too:
https://forum.manjaro.org/t/re-partition...sd/72463/2
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  NVMe drives not detected mattpenn 2 213 09-07-2021, 01:01 AM
Last Post: mattpenn
Question Battery stops charging and NVMe and other media disconnect randomly Eey0zu6O 4 587 07-09-2021, 08:45 PM
Last Post: moonwalkers
  nvme drive disappears after about an hour of uptime codebreaker 25 11,031 02-09-2021, 11:32 PM
Last Post: dsimic
  NVMe-related crashes and instability, plus a solution simonsouth 9 4,899 01-24-2021, 05:37 PM
Last Post: HitsuMaruku
  NVME SPI Update not booting SD Card WZ9V 5 2,884 10-18-2020, 08:36 PM
Last Post: wdt
  Possible to upgrade PBP with NVMe M.2 1TB SSD from Sabrent? kkdao 15 8,121 08-22-2020, 05:20 AM
Last Post: kkdao
  LTE adapter via NVMe grego 2 2,187 07-08-2020, 01:37 PM
Last Post: manawyrm
  Pro NVMe adapter Does not fit ! ? bcnaz 110 54,484 07-03-2020, 10:51 PM
Last Post: xmixahlx
  NVME problem chaoskampf 2 2,115 07-01-2020, 09:10 AM
Last Post: chaoskampf
  PBP with NVMe installed - Issues booting to SD eluno1 2 1,954 06-05-2020, 09:33 AM
Last Post: eluno1

Forum Jump:


Users browsing this thread: 1 Guest(s)