NVMe drives not detected
#1
Hi all,

I've now tried installing 3 different models of NVMe SSD in my PBP but none are detected by the OS (lspci, lsblk, dmesg).

I'm currently working with the Patriot P300 as that was something reported as working on the wiki. I'm using the latest Manjaro on SD. My eMMC is removed as it was never consistently detected at boot.

I'm now planning to order another NVMe adapter as that is an easy/cheap step to try.

If anyone has other more sophisticated troubleshooting steps to try please let me know!

Cheers,
Matt
  Reply
#2
(09-04-2021, 08:44 AM)mattpenn Wrote: Hi all,

I've now tried installing 3 different models of NVMe SSD in my PBP but none are detected by the OS (lspci, lsblk, dmesg).

I'm currently working with the Patriot P300 as that was something reported as working on the wiki. I'm using the latest Manjaro on SD. My eMMC is removed as it was never consistently detected at boot.

I'm now planning to order another NVMe adapter as that is an easy/cheap step to try.

If anyone has other more sophisticated troubleshooting steps to try please let me know!

Cheers,
Matt

Just to be sure, what is reported when you do: sudo fdisk -l
It should not matter, but which Linux distro (and version) are you using?
So I assume you are booting from a micro SD card?
  Reply
#3
(09-05-2021, 09:52 AM)jiyong Wrote:
(09-04-2021, 08:44 AM)mattpenn Wrote: Hi all,

I've now tried installing 3 different models of NVMe SSD in my PBP but none are detected by the OS (lspci, lsblk, dmesg).

I'm currently working with the Patriot P300 as that was something reported as working on the wiki. I'm using the latest Manjaro on SD. My eMMC is removed as it was never consistently detected at boot.

I'm now planning to order another NVMe adapter as that is an easy/cheap step to try.

If anyone has other more sophisticated troubleshooting steps to try please let me know!

Cheers,
Matt

Just to be sure, what is reported when you do: sudo fdisk -l
It should not matter, but which Linux distro (and version) are you using?
So I assume you are booting from a micro SD card?

Yes booting from SD. Up-to-date Majaro.

[matt@pbp ~]$ sudo fdisk -l
[sudo] password for matt:  
Disk /dev/mmcblk1: 119.08 GiB, 127865454592 bytes, 249737216 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 03F8AD0B-568A-4DD0-82BE-5A1B258958DD

Device          Start       End   Sectors   Size Type
/dev/mmcblk1p1  62500    500000    437501 213.6M Microsoft basic data
/dev/mmcblk1p2 500001 249737182 249237182 118.8G Linux filesystem


Disk /dev/zram0: 5.66 GiB, 6075244544 bytes, 1483214 sectors
Units: sectors of 1 * 4096 = 4096 bytes
Sector size (logical/physical): 4096 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
[matt@pbp ~]$ uname -a
Linux pbp 5.13.12-1-MANJARO-ARM #1 SMP Wed Aug 18 07:36:58 UTC 2021 aarch64 GNU/Linux
[matt@pbp ~]$
  Reply
#4
I got round to buying/trying another NVMe adapter. No dice Undecided

Does anyone think Pine support would be any help and do they support second hand devices?
  Reply
#5
(11-08-2021, 03:15 PM)mattpenn Wrote: I got round to buying/trying another NVMe adapter. No dice Undecided

Does anyone think Pine support would be any help and do they support second hand devices?

So...I am pretty clueless too, and my advice is limited.  Did you see my post immediately below?  What I did: fed the nvme cable into the PCB first, then put the ssd into the nvme adapter, then attached the cable to the nvme adapter, then screwed the nvme adapter in.  Doing it the other way got nothing.  lsblk then showed, and then I hand to format the drive.
  Reply
#6
Crap... just ordered the same drive...
  Reply
#7
(01-10-2022, 05:48 AM)Tazdevl Wrote: Crap... just ordered the same drive...

If I had to bet I would say that my issue is a hardware defect on my PBP rather than drive compatibility as have tried 3 different NVMe drives that should all work.

Do let me know how you go though!!
  Reply
#8
one thing worth checking is making sure that one of the case standoffs that's nearby isn't pinching the ribbon cable to the nvme board. I've had it happen a few times, and it always kept the pbp from seeing the drive. once i taped the cable down away from the standoff it stopped pinching and keeping the drive from showing to the system.
  Reply
#9
(01-10-2022, 07:44 AM)tophneal Wrote: one thing worth checking is making sure that one of the case standoffs that's nearby isn't pinching the ribbon cable to the nvme board. I've had it happen a few times, and it always kept the pbp from seeing the drive. once i taped the cable down away from the standoff it stopped pinching and keeping the drive from showing to the system.

I don't suppose you can mark up the position of your tape on the wiki photo for me? I have taped it down similar to the position in this blog now without luck:
https://eli.gladman.cc/blog/2020/06/23/p...-nvme.html
  Reply
#10
(01-20-2022, 11:38 AM)mattpenn Wrote: I don't suppose you can mark up the position of your tape on the wiki photo for me? I have taped it down similar to the position in this blog now without luck:
https://eli.gladman.cc/blog/2020/06/23/p...-nvme.html

sure, though i should note the shape of my ribbon cable is a bit different from the current ones (the nvme board originally shipped with a ribbon cable that was not the right shape/length.) my tape is set to move the ribbon cable about a ¼" toward the center.

i marked up on this picture whereabouts of my tape is in red. if i get a chance to crack my pbp open anytime soon, i'll take a pic.
https://imgur.com/a/i6A5LpH
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  New Working nVME gilwood 0 91 02-12-2024, 08:46 AM
Last Post: gilwood
  NVME problems 2022 / Intel 660p 1TB Starbug 1 1,333 04-04-2023, 12:16 PM
Last Post: globaltree
Thumbs Up NVMe adapter, Great addition dachalife 2 1,670 11-28-2022, 12:56 PM
Last Post: dachalife
  NVme intall usage? tkudog 2 2,749 03-04-2022, 01:29 AM
Last Post: Tazdevl
  Anyone selling a spare NVMe adapter in Europe? tom.tomasz 1 1,759 01-03-2022, 07:57 AM
Last Post: tom.tomasz
  NVMe-related crashes and instability, plus a solution simonsouth 13 14,176 12-10-2021, 07:47 PM
Last Post: josmo
  NVMe SSD testing methodology halogen 1 2,516 07-22-2021, 05:57 PM
Last Post: calinb
Question Battery stops charging and NVMe and other media disconnect randomly Eey0zu6O 4 4,562 07-09-2021, 08:45 PM
Last Post: moonwalkers
  nvme drive disappears after about an hour of uptime codebreaker 25 30,951 02-09-2021, 11:32 PM
Last Post: dsimic
  Speakers not detected PineHead7 1 2,748 01-07-2021, 01:50 AM
Last Post: ab1jx

Forum Jump:


Users browsing this thread: 1 Guest(s)