Unusable ROCKPRO64
#1
Hi all,

            after running well for 25 days more or less, my rockpro64 is unusable. All USB ports and ethernet port are not working. I tried with many images, Manjaro, armbian... to top it all sometimes the startup finish with a kernel panic message.

I'm pretty sure that this is a hardware failure. Has anyone a similar experience? I'm very disgusted, the rockpro64 only ran for 25 days more or less. I have had others SBC, like raspberry pi, in the same place for years without problems. 


Sad
  Reply
#2
(02-09-2021, 10:09 AM)drenedo Wrote: Hi all,

            after running well for 25 days more or less, my rockpro64 is unusable. All USB ports and ethernet port are not working. I tried with many images, Manjaro, armbian... to top it all sometimes the startup finish with a kernel panic message.

I'm pretty sure that this is a hardware failure. Has anyone a similar experience? I'm very disgusted, the rockpro64 only ran for 25 days more or less. I have had others SBC, like raspberry pi, in the same place for years without problems. 


Sad

Please make sure that your power supply rated 12V 3A or 5A. Looks like your board not getting enough power. If you are using teh Raspberry Pi power power which is 5V, then for sure is under power.
  Reply
#3
(02-13-2021, 07:06 PM)tllim Wrote:
(02-09-2021, 10:09 AM)drenedo Wrote: Hi all,

            after running well for 25 days more or less, my rockpro64 is unusable. All USB ports and ethernet port are not working. I tried with many images, Manjaro, armbian... to top it all sometimes the startup finish with a kernel panic message.

I'm pretty sure that this is a hardware failure. Has anyone a similar experience? I'm very disgusted, the rockpro64 only ran for 25 days more or less. I have had others SBC, like raspberry pi, in the same place for years without problems. 


Sad

Please make sure that your power supply rated 12V 3A or 5A. Looks like your board not getting enough power. If you are using teh Raspberry Pi power power which is 5V, then for sure is under power.

The power supply is correct. 12V 5A.
  Reply
#4
Does it boot at all?
Could you hook up a serial connection like outlined here, and see what the boot init looks like?
https://forum.pine64.org/showthread.php?tid=6387
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  rockpro64 emmc GreyLinux 8 507 11-08-2021, 01:56 PM
Last Post: GreyLinux
  ROCKPro64 sometimes doesn't Power On Pete Tandy 2 654 08-24-2021, 05:50 AM
Last Post: Pete Tandy
  Tutorial request: overclocking a rockpro64 Mentaluproar 1 579 08-15-2021, 01:35 PM
Last Post: dukla2000
  Did I brick my RockPro64 somehow? snarfel 1 766 07-20-2021, 01:40 PM
Last Post: dukla2000
  RockPro64 - EN62368 m.ekstrom 0 593 06-02-2021, 04:55 AM
Last Post: m.ekstrom
  RPI4 Vs Rockpro64 Performance help? Mangled 0 732 05-25-2021, 03:38 PM
Last Post: Mangled
  Booting my RockPro64 from NVMe drive PsySc0rpi0n 3 1,515 05-02-2021, 01:56 AM
Last Post: LMM
  ROCKPro64 (4 GB) "In stock (can be backordered)" TRS-80 3 1,088 03-19-2021, 04:53 PM
Last Post: TRS-80
  Troubleshooting ROCKPro64 alephnull 3 1,853 03-04-2021, 03:58 AM
Last Post: alephnull
  Petitboot on RockPro64? new_to_arm 0 754 03-03-2021, 05:00 PM
Last Post: new_to_arm

Forum Jump:


Users browsing this thread: 1 Guest(s)