Seemingly lost power permanently now /cry
#1
Exclamation 
Hello again Pine64 forums.
The very nice wdt helped me earlier this week on an issue with my Pinebook Pro not powering on here: https://forum.pine64.org/showthread.php?tid=12057

I had Manjaro 20.04 on the eMMC which I got working. I decided to ditro hop over to Ubuntu 18.04 (LXDE) using a microSD card. It worked fine, booted up & I was doing some fairly simple things on it. I decided to run `sudo apt upgrade` on the distro & it wouldn't reboot properly. Deciding I should leave well enough alone I tried to boot back to Manjaro & couldn't. I figured since my mirrors were out of date & I should just reflash the eMMC to Manjaro 20.10 - I did so via Etcher but I couldn't boot; just the red power light at power on. Having run into this & corrected with wdt, I thought it was a uboot issue. I wanted to follow instructions from wdt at my previous post but my microSD card with the original factory image is also not booting.

So, in short here's what I've tried to get any kind of video output:
  • Booting manjaro from microSD cards (2 diff models)
  • Booting debian from microSD cards
  • Booting from debian, manjaro, or Ubuntu 18.04 & 20.04 from microSD cards
  • After all that failed I removed the eMMC & tried booting to each of those OSes off the microSD cards.
  • I repeated the same boot tests using the eMMC after reconnecting the eMCC (I flash it via an eMMC to microSD to USB adapter, which connects to my computer), and not using any microSD cards.
  • I disconnected the battery & used only the AC adapter as well, retrying attempts to boot to each eMMC and microSD without success. The system simply sits at a black screen & red power button, or with no indication of power at all.

I also should note I removed my NVMe drive from the system just to make sure there wasn't anything on there causing a problem (it's formatted to exFAT as a simple storage drive).

Any help towards a fix or ideas for troubleshooting would be appreciated.
  Reply
#2
Because there is a battery, it can get into a non-bootable state and remember it
If you have the back off, the reset button, OR a long press of pwr button
1st, try 8-10 seconds, then regular start press, if that doesn't work, 20+seconds
The "bad" uboot MUST be gone, use something that you are SURE is bootable
And, if nothing is in, nothing will happen. There must be a "good" uboot for any led
There are lots of bad uboots out there, I have had to long press maybe 15 times by now
Do remember, the emmc uboot will be found 1st, if it is bad, must be disabled or removed or blanked
  Reply
#3
You have saved me from my own ignorance yet again, wdt. I didn't have a very good understanding of uboot before, now I think I have a better grasp on basic troubleshooting. I've got Manjaro 20.10 running on the system again. Thank you, again, for your help.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Replacement Power Cord recommendation? nathanielwheeler 3 411 01-23-2021, 06:43 PM
Last Post: KC9UDX
  power light blinking during charge when pbpro is off Idaho 0 418 01-04-2021, 10:53 AM
Last Post: Idaho
  Taming the power switch? ab1jx 4 1,122 11-30-2020, 10:57 PM
Last Post: rimaille
  Power consumption and suspend to ram robt 33 12,897 11-30-2020, 04:32 PM
Last Post: wdt
Photo Faulty power circuit hackerfantastic 1 846 08-24-2020, 01:48 PM
Last Post: Arwen
  We need more power, Scotty! mtnygard 4 1,750 07-23-2020, 11:21 AM
Last Post: mamboman777
  My PBP does not power on at all prokofiev 9 2,573 07-12-2020, 03:27 AM
Last Post: prokofiev
Exclamation [SOLVED] PBP will no longer power on s3rvant 10 3,642 07-04-2020, 01:57 PM
Last Post: prokofiev
  Battery draining with external power while under load? RndmNmbr 17 5,583 06-24-2020, 08:33 PM
Last Post: Syonyk
  Noisy power light..... rick1959 2 1,248 06-17-2020, 09:34 AM
Last Post: rick1959

Forum Jump:


Users browsing this thread: 1 Guest(s)