Powering off & won't power back on w/o battery disconnect
#1
Question 
Hello Pine64 forums.
So this is a strange one to me, but only for the frequency of occurrence - which I'll need to explain.

When using my Pinebook Pro, Manjaro 20.04 Cinnamon DE, it will seemingly power off & simply stay off when it goes to sleep/hibernate. This even occurs, eventually, when no sleep mode is enabled. That is to say: it will power off & won't power back on until I pull off the bottom cover, disconnect the battery connect from the mainboard, press the power button for 5 seconds or so, and reconnect the battery (or power cord - so long as it's getting power).

In my prior years as a desktop support tech I ran across many laptops where the mainboard's little capacitors would not regulate power to the system. Pulling the battery connector out, pressing the power button for 5 seconds or so to discharge the capacitors (I presume), and powering it back on (via battery or AC adapter) gets it working again. But I have to do this so frequently of late I'm starting to wonder if it's an OS issue. It doesn't seem to matter which governor I set via the cpupower utility (I will state I typically run it on the "performance" governor on AC power).

Has anyone got any ideas as to what's going or what else I can try to troubleshoot it?
Thanks a ton!
#2
The next time this happens, try instead to do a hard reset,,
press and HOLD pwr button 20+ seconds, then a normal start press
Actually, first try a hard power-off, hold pwr button ~8 seconds
This is probably a failure to wake from sleep, not sure where settings are in cinnamon,
and not sure just what notices wake signal. I wish I knew
If this works (and I would bet it will),, change uboots,, maybe uboot-pinebookpro-bsp
Do realize that the install actually doesn't, you still have to do the dd
Also, sometimes the install changes extlinux.conf,, the root=value,,,wrongly
So 1st of all , make a backup of it (before installing bsp uboot)
#3
(11-06-2020, 09:57 PM)wdt Wrote: The next time this happens, try instead to do a hard reset,,
press and HOLD pwr button 20+ seconds, then a normal start press
Actually, first try a hard power-off, hold pwr button ~8 seconds
This is probably a failure to wake from sleep, not sure where settings are in cinnamon,
and not sure just what notices wake signal. I wish I knew
If this works (and I would bet it will),, change uboots,, maybe uboot-pinebookpro-bsp
Do realize that  the install actually doesn't, you still have to do the dd
Also, sometimes the install changes extlinux.conf,, the root=value,,,wrongly
So 1st of all , make a backup of it (before installing bsp uboot)
Unfortunately that doesn't seem to have worked. As far as the "hard reset" goes, that is.
I didn't actually dd the image, I used Etcher because every time I try dd I somehow managed to mess it up & it doesn't boot.

I do have the original factory Debian-based image (from before they moved to Manjaro) on a microSD card. When using that the system will boot to the "Open Sesame" screen & simply reboots. Not sure how to troubleshoot from here.
#4
OK, that makes it almost certain that the uboot on emmc is somehow wrong
When booting, bootrom search order is SPI, emmc, SD
First uboot found will be one used, all others ignored
So, booting from SD, the emmc uboot will be found 1st, it (emmc uboot) will search
in uboots search order,, (SD, nvme, usb, emmc) looking for boot.scr or extlinux.conf
Again, 1st one found is the one used
You can easily test this, disable emmc with switch or remove, mrfix will almost certainly boot
If so, then and if the mrfix is updated, put that uboot on emmc
In short, do switch dance OR bind command, save emmc mbr (1st sector, 512 B),
dd 1st 16MB of SD -> emmc, restore emmc mbr
And, BTW, the long press doesn't work if "bad" uboot is still there, in this case on emmc

--edit-- this is actually fairly easy doing this way
>every time I try dd I somehow managed to mess it up & it doesn't boot.
lsblk,, there should be mmcblk1 and mmcblk2,, boot0 and boot1 are on emmc, you ONLY use /dev/mmcblkN,,, N=1 OR 2
as root, sudo
dd if=/dev/EMMC of=~/mbr.emmc count=1 (ls -l ~/mbr.emmc shows 512 byte file)
dd if=/dev/SD of=/dev/EMMC bs=1M count=16
dd if=~/mbr.emmc of=/dev/EMMC
EMMC and SD replaced by appropriate mmcblkN
#5
@wdt I have to offer major thanks to you, this got my eMMC-based Manjaro working again. Unfortunately Suspend or Hibernate just seem to power the system off, but I decided to settle for changing everything to "Lock Screen" for the power button & lid close. After a few moments the LCD powers off in this mode, which seems to use the most power so it's not an unacceptable compromise.

Since it's been so long since I updated Manjaro & it's failing, that'll be my next project to tackle... but that's for a different thread.
Thank you again so very much!
#6
>Unfortunately Suspend or Hibernate just seem to power the system off,,,, this is settings
Hibernate does not work,, you may be lucky and have lid magnet in "right " place
Lots are wrong, turns off when 1" from closed, and then, when closed, turns on
check dmesg for sleep,,, dmesg |grep suspend OR dmesg |grep s2idle,,the 1st FAR better(~7%/d)
/etc/systemd/sleep.conf,, ,, SuspendState=mem
sometimes nothing will wake it up (other distros), for me, kde, systemsettings5, pwr button ->ask
And pwr button wakes it, nearly everything else is off
BTW, kernel 5.9 locks (won't wake), I had to downgrade (5.8.14)


Possibly Related Threads…
Thread Author Replies Views Last Post
  Blinking red light for charger, no power-on bifo 11 3,949 11-30-2021, 01:37 PM
Last Post: wdt
  power on PBP if your keyboard is dead? stozi 0 80 11-29-2021, 01:55 PM
Last Post: stozi
  Alternative Power supply options gallomimia 12 8,098 11-23-2021, 07:42 AM
Last Post: niksadonis
Question UK Power Supply Feakster 12 8,839 08-26-2021, 10:03 AM
Last Post: JAGER
  Motherboard malfunction - a possible warning about power supplies mjc 8 1,573 07-28-2021, 01:04 PM
Last Post: mjc
  Battery replacement mjc 1 642 07-21-2021, 04:21 PM
Last Post: 8bit
Question Battery stops charging and NVMe and other media disconnect randomly Eey0zu6O 4 1,182 07-09-2021, 08:45 PM
Last Post: moonwalkers
  Increasing the maximum power draw dsimic 12 8,166 06-11-2021, 10:34 AM
Last Post: dsimic
  Battery doesn't charge mspohr 5 1,431 06-11-2021, 08:42 AM
Last Post: mspohr
  are you supposed to be able to remove & put back the keycaps? walterbe 2 990 05-17-2021, 09:13 AM
Last Post: walterbe

Forum Jump:


Users browsing this thread: 2 Guest(s)