Seemingly lost power permanently now /cry - Printable Version

+- PINE64 (
+-- Forum: Pinebook Pro (
+--- Forum: General Discussion on Pinebook Pro (
+--- Thread: Seemingly lost power permanently now /cry (/showthread.php?tid=12172)

Seemingly lost power permanently now /cry - jimsurvak - 11-15-2020

Hello again Pine64 forums.
The very nice wdt helped me earlier this week on an issue with my Pinebook Pro not powering on here:

I had Manjaro 20.04 on the eMMC which I got working. I decided to ditro hop over to Ubuntu 18.04 (LXDE) using a microSD card. It worked fine, booted up & I was doing some fairly simple things on it. I decided to run `sudo apt upgrade` on the distro & it wouldn't reboot properly. Deciding I should leave well enough alone I tried to boot back to Manjaro & couldn't. I figured since my mirrors were out of date & I should just reflash the eMMC to Manjaro 20.10 - I did so via Etcher but I couldn't boot; just the red power light at power on. Having run into this & corrected with wdt, I thought it was a uboot issue. I wanted to follow instructions from wdt at my previous post but my microSD card with the original factory image is also not booting.

So, in short here's what I've tried to get any kind of video output:
  • Booting manjaro from microSD cards (2 diff models)
  • Booting debian from microSD cards
  • Booting from debian, manjaro, or Ubuntu 18.04 & 20.04 from microSD cards
  • After all that failed I removed the eMMC & tried booting to each of those OSes off the microSD cards.
  • I repeated the same boot tests using the eMMC after reconnecting the eMCC (I flash it via an eMMC to microSD to USB adapter, which connects to my computer), and not using any microSD cards.
  • I disconnected the battery & used only the AC adapter as well, retrying attempts to boot to each eMMC and microSD without success. The system simply sits at a black screen & red power button, or with no indication of power at all.

I also should note I removed my NVMe drive from the system just to make sure there wasn't anything on there causing a problem (it's formatted to exFAT as a simple storage drive).

Any help towards a fix or ideas for troubleshooting would be appreciated.

RE: Seemingly lost power permanently now /cry - wdt - 11-16-2020

Because there is a battery, it can get into a non-bootable state and remember it
If you have the back off, the reset button, OR a long press of pwr button
1st, try 8-10 seconds, then regular start press, if that doesn't work, 20+seconds
The "bad" uboot MUST be gone, use something that you are SURE is bootable
And, if nothing is in, nothing will happen. There must be a "good" uboot for any led
There are lots of bad uboots out there, I have had to long press maybe 15 times by now
Do remember, the emmc uboot will be found 1st, if it is bad, must be disabled or removed or blanked

RE: Seemingly lost power permanently now /cry - jimsurvak - 11-16-2020

You have saved me from my own ignorance yet again, wdt. I didn't have a very good understanding of uboot before, now I think I have a better grasp on basic troubleshooting. I've got Manjaro 20.10 running on the system again. Thank you, again, for your help.