Pinebook Pro won´t boot either from eMMC or microSD
(10-24-2020, 03:23 AM)KC9UDX Wrote: It sounds like you don't want linux at all!  What you want is NetBSD!  In that case, use this image

But let's get this thing booting first.  What you're describing is a blank or improperly flashed micro SD card.  It does not need to be a specific one per se, but there are reports of some that don't work.  If you can, try a different one.  I use SanDisk ones (the exact type is that recommended for my GoPro camera) and Kingston (ones that came in raspberry pi bundles) and ones that I bought from Pine64.  I don't have any that don't work, but again there are reports of ones that don't. 

Having the eMMC adaptor will be helpful.  But it's not necessary.

How exactly are you flashing the SD card now?  I use NetBSD, and the method I use would work for linux too, but things will be different with other operating systems.
Hahaha, I do want Linux, but I just want to set some of the stuff up. I’ll look into NetBSD later. Thanks! 

Now, the thing is I had booted from the microSD before. I ran Kali from the microSD while having the default Manjaro on the eMMC. Then I flashed Arch on the microSD and when i finished with the partitions and the setting up I rebooted and it never rebooted. It got stuck on a black screen with the led light on orange color. And It stayed like that for hours. Then I tried booting from the eMMC with manjaro which shouldn’t have been affected, however, it didn’t boot. This is why I think the problem is with U-boot. 

Now, if I turn off the eMMC, and hold the power button to turn on, nothing happens. The light doesn’t even turn. It’s like the power is cut off. I don’t know if the microSD stopped working. It is a sandisk which is supposed to be recommended for booting with Linux. If I insert it on my windows to flash it, it gets flashed without problems.

Finally, to flash I use etcher and I just select the image and the microSD.

Thanks for all the help, I really appreciate it.

Messages In This Thread
RE: Pinebook Pro won´t boot either from eMMC or microSD - by robieguarneros - 10-24-2020, 09:01 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  3 days in, slow/stuck or no boot. lgmpbp2 4 517 07-01-2024, 09:26 PM
Last Post: wdt
  upgrading u-boot--what version? where to get it? bsammon 11 1,271 05-22-2024, 09:33 AM
Last Post: wdt
  Pinebook Pro Initial Impressions kunger 443 622,369 04-16-2024, 07:29 PM
Last Post: KC9UDX
  looking to buy one pinebook pro (mainland China) duanduan 3 2,670 03-21-2024, 07:44 PM
Last Post: wangyukunshan
  Cellular module for Pinebook Pro Lotech 1 695 03-05-2024, 05:40 AM
Last Post: KC9UDX
  Screen on pinebook stays black but can ssh into machine tuxxpine 0 521 02-23-2024, 04:22 PM
Last Post: tuxxpine
  Sale my ANSI PineBook Pro cuthbertdavies 0 509 02-14-2024, 09:12 PM
Last Post: cuthbertdavies
  Compiling with -j6 on the Pinebook Pro (Overheat) KC9UDX 0 433 02-14-2024, 09:01 AM
Last Post: KC9UDX
  Pinebook Pro in EU for Sale - €90 jan_vdk 2 1,016 02-07-2024, 02:12 AM
Last Post: 23Ro
  Pinebook Pro for sale tomekdev 2 1,117 02-01-2024, 11:35 AM
Last Post: tomekdev

Forum Jump:

Users browsing this thread: 1 Guest(s)