Pinebook Pro won't connect to wifi
#1
No matter what I do, I can't connect to wifi. I replaced the built-in Manjaro KDE Plasma with Manjaro Xfce. I'm using the wifi menu widget on the task bar to select my router, entered the correct password a million times, and it just pauses a great while trying to connect and then asks me to enter a password again. Does it every time. 

This is the only device in my house that has this problem. I've used Wifi on my Pinephone, my android, and like 4 other computers, and my family has other devices with working internet. I've tried reconnecting to internet on a few of these devices and it worked. My new Pinebook Pro is the only device that refuses to connect to internet. 

This has been happening for a full week now. I haven't even been able to use it effectively without internet. Without internet, it's extra space being used up in my house that I don't need if it won't work. (i bought a table for it)

Pretty frustrated, to be honest, because I'm pretty sure my 30 day warranty expired by now.

To top it all off, can't reinstall the operating system it came with, (or any operating system made for it, for that matter), because the micro sd card reader isn't reading my micro sd card. So unless I can fix wifi, I'm basically screwed.

Though a separate issue, it would be nice to have the micro sd card reader working again, too. Not sure if that will ever happen, either?

I'm a developer who ports my software to a lot of operating systems, including windows, mac, linux, freebsd, and I would like to get netbsd or openbsd working on my pinebook pro since my other machines are being used for other things at the moment and can't have their os replaced easily right now without being a big sacrifice.

Any help is appreciated, like you have no idea!
Samuel
#2
>I replaced the built-in Manjaro KDE Plasma with Manjaro Xfce.
I have to wonder how you did this with a dead SD card socket??
It will boot (sometimes) from usb3, I have never managed to boot from usb2
Try an alternative to networkManager? Sometimes (very occasionally) NM screws up
old school, wpa_supplicant,, wicd,, connman
usually, these apps are "jealous" ,, insist on being the 'one and only'
Have you tried a wifi dongle?
And, let me point out, for *bsd, you WILL have to use wpa_supplicant
#3
The micro sd card slot used to work. Ever since I replaced the OS I've been having that problem. The wifi issue is a more recent development.

I've edited correctly wpa_supplicant.conf before on FreeBSD so I am familiar with that but didn't know that was a thing on Linux. I guess I should've been able to figure that one. 

Also for anyone who's interested this package solves the need on FreeBSD to edit that conf file manually: http://opal.com/freebsd/ports/net-mgmt/wifimgr/ not sure how relevent that is because it might not be available for netbsd or openbsd.

I'll try editing wpa_supplicant and will share my results, thanks for the info!

Samuel
#4
You may have to disable Network Manager. I've used at least one Linux distru where Network Manager would override my manual settings.

You also might be able to set your SSID directly with ifconfig.

I would encourage you to install NetBSD, but I'll have to warn you that the inbuilt WiFi doesn't play well with NetBSD. Yes, it works, but it's incredibly frustrating. Using the wifi for random amounts of time will deadlock the whole machine. You might get 30 seconds or 10 hours of runtime, you never really know. I haven't tried an external WiFi or Ethernet adaptor yet; but I've heard that it works fine like that.
#5
As the PBP ships from the factory there are 'pre-boot' instructions on the eMMC.
If you have changed the operating systems maybe those instructions
have been over-written so your PBP will not boot from the sd card.?
I am not an expert on arm devices, but they do boot completely different than other computers.

My suggestion in this instance, I would use the Pine usb/eMMC adapter to reflash the eMMC.

I know some of the forum experts can give you other options that will work.

I have 2 pinebook Pro's and currently 3 Pine phones, with 2 more phones on order, they all operate.

But I look for solutions that fit 'my' particular 'skill level'
      LINUX = CHOICES
         **BCnAZ**
               Idea
   Donate to $upport
your favorite OS Team


Possibly Related Threads…
Thread Author Replies Views Last Post
  Pinebook PRO for sale (Poland) tonieja 1 58 Yesterday, 02:51 PM
Last Post: cypresstwist
  Selling Pinebook Pro (EU) xblack86 6 328 10-16-2021, 09:10 PM
Last Post: cypresstwist
  Looking for Pinebook Pro (UK/EU) tux90 0 47 10-16-2021, 05:20 PM
Last Post: tux90
  Up to date guide on factory reset pinebook pro? jcarty 1 139 10-12-2021, 11:02 PM
Last Post: wdt
  Looking to get a ANSI/US Pinebook Pro ajawadmahmoud 1 267 10-09-2021, 04:55 AM
Last Post: ajawadmahmoud
  Content Streaming on the Pinebook Pro! (Netflix, Spotify, Crunchyroll, YouTube!) ImmyChan 1 217 10-07-2021, 11:42 PM
Last Post: tllim
  ANSI Pinebook Pro for sale Hemogoblin 6 426 10-07-2021, 12:41 PM
Last Post: ajawadmahmoud
  Looking to buy a Pinebook Pro US Stucht13 12 1,740 10-01-2021, 07:27 AM
Last Post: Hemogoblin
  Pinebook got wet walterbe 8 554 09-25-2021, 01:12 PM
Last Post: biketool
  ISO/UK Pinebook Pro for sale mstevens 4 512 09-17-2021, 10:49 AM
Last Post: mstevens

Forum Jump:


Users browsing this thread: 1 Guest(s)