Got Vivaldi Working on Arch!
#1
I got Vivaldi to run under Arch, and probably the same trick would work for Chrome (which is under Vivaldi).

1. In the AUR there is a 64-bit Arm Vivaldi snapshot Download it
2. Unpack the archive and do an install like you would anything else from AUR
3. There were 2 or 3 things I had to add using pacman (in fact, I had to add fakeroot to get the packaging to work). Everything was there, just pacman -S xxxx
4. Do the install.

Now you will have a problem. Vivaldi is there but won't run. Here's why. GDK_BACKEND is set to wayland. It needs to be set to x11. You can edit the launcher or the Vivaldi script or from CLI:

GDK_BACKEND=x11 vivaldi-stable

Seems to mostly work. The interface is a bit clipped. Setting it to native window (restart required) helped I think. Moving the address bar to the bottom helped a lot.

Woo hoo!

Update: ALT+F10 maximizes the window which cleans up most of the issues.
  Reply
#2
It's in manjaros aur as an arm build too, works perfectly
  Reply
#3
A few notes. GDK_BACKEND is also the key to get emacs to run in the GUI.

binutils should be installed before the buildpkg step, but if you don't you just get a warning.

If you find the desktop files in /usr/share you can change

Exec=xxxx
to

Exec=env GDK_BACKEND=x11 xxxx

To make a shortcut like Vivaldi or emacs run properly.
  Reply
#4
Yeah, I am sure this trick will work out for me. Thanks for sharing the info! I think professional essay writers can write even more about this trick
  Reply
#5
(09-12-2020, 09:09 PM)wd5gnr Wrote: I got Vivaldi to run under Arch, and probably the same trick would work for Chrome (which is under Vivaldi).

1. In the AUR there is a 64-bit Arm Vivaldi snapshot Download it
2. Unpack the archive and do an install like you would anything else from AUR
3. There were 2 or 3 things I had to add using pacman (in fact, I had to add fakeroot to get the packaging to work). Everything was there, just pacman -S xxxx
4. Do the install.

Now you will have a problem. Vivaldi is there but won't run. Here's why. GDK_BACKEND is set to wayland. It needs to be set to x11. You can edit the launcher or the Vivaldi script or from CLI:

GDK_BACKEND=x11 vivaldi-stable

Seems to mostly work. The interface is a bit clipped. Setting it to native window (restart required) helped I think. Moving the address bar to the bottom helped a lot.

Woo hoo!

Update: ALT+F10 maximizes the window which cleans up most of the issues.
hi,

I am currently running arch from the SD card still but all browsers are extremely sluggish: 
epiphany is the default and I notice it uses multiple cores (since in top it gets 140%)

Installed midori, which is slightly faster.

but all load pages in 5-10 seconds or slower. 

Is that just a system thing at the moment?
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Important apps stopped working yurievitch 2 355 03-30-2021, 08:34 AM
Last Post: kimiles
  Arch Linux ARM on PineTab Danct12 22 7,065 03-30-2021, 01:44 AM
Last Post: RTP
  Anyone been able to get a working GloDroid img on SD? tophneal 20 5,335 03-11-2021, 03:04 AM
Last Post: nas
  Arch, Plasma desktop and wayland peperjohnny 48 12,411 02-02-2021, 06:14 AM
Last Post: wd5gnr
  Arch and ZRam wd5gnr 4 2,235 12-03-2020, 04:37 AM
Last Post: tomoqv
  Any way to disable wake on power connect/full charge? (Arch) quipacorn 3 1,152 10-14-2020, 10:00 AM
Last Post: quipacorn

Forum Jump:


Users browsing this thread: 1 Guest(s)