Arch and ZRam
#1
From: https://wiki.archlinux.org/index.php/Imp...m_or_zswap


Quote:
The systemd-swap package provides a systemd-swap.service unit to automatically initialize zram devices. Configuration is possible in /etc/systemd/swap.conf.
The package zramswapAUR provides an automated script for setting up a swap with a higher priority and a default size of 20% of the RAM size of your system. To do this automatically on every boot, enable zramswap.service.

I installed zramswap and found that /etc/zramswap.conf actually sets 40% (the default is 20 if you don't set it there). However, it does seem like that has been a good performance boost, especially when running Vivaldi.
  Reply
#2
Thanks for the tip. Plasma desktop got a bit faster with that.
  Reply
#3
(09-16-2020, 06:17 AM)peperjohnny Wrote: Thanks for the tip. Plasma desktop got a bit faster with that.

My current configuration seems to be OK, but not sure if it is really better or not. I have a pretty large SDcard mounted in /etc/fstab as /sdcard

The following as root:
dd if=/dev/zero of=/swapfile bs=1MiB count=1024
mkswap /swapfile
# note you will need /sdcard mounted first:
dd if=/dev/zero of=/sdcard/swapfile bs=1MiB count=4096
mkswap /sdcard/swapfile

#oops forgot these:
chmod 600 /swapfile /sdcard/swapfile

Then in /etc/fstab:
/dev/mmcblk0p1 /sdcard ext4 rw,relatime,nofail
/swapfile swap swap pri=50 0 0
/sdcard/swapfile swap swap pri=0 0 0

Combined with the ZRAM swap at priority 100, this gives you a 1G swap on the eMMC and 4G of (presumably) slower swap on the SDCard.

If you don't want to reboot, do (as root):

swapon -a
 

Verify with:

swapon -s


I have left vm.swappiness at 60 but it might do to turn it higher to make more RAM available for caching. 

sysctl -w vm.swappiness=90

Make that permanent in /etc/sysctl.conf or sysctl.d

But like I say, I've left it at 60 to see how it does for a bit.

By the way, you can't use fallocate. It leaves a sparse file which will not mount.
  Reply
#4
If you use this setup, I noticed that /usr/lib/systemd/system/tmp.mount puts /tmp as tmpfs which uses RAM and eventually you get crashes. For some reason, systemctl disable doesn't stop this, so I renamed tmp.mount to tmp.nomount and rebooted. Seems to help performance quite a bit.
  Reply
#5
(09-15-2020, 06:41 AM)wd5gnr Wrote: From: https://wiki.archlinux.org/index.php/Imp...m_or_zswap


Quote:
The systemd-swap package provides a systemd-swap.service unit to automatically initialize zram devices. Configuration is possible in /etc/systemd/swap.conf.
The package zramswapAUR provides an automated script for setting up a swap with a higher priority and a default size of 20% of the RAM size of your system. To do this automatically on every boot, enable zramswap.service.

I installed zramswap and found that /etc/zramswap.conf actually sets 40% (the default is 20 if you don't set it there). However, it does seem like that has been a good performance boost, especially when running Vivaldi.

I am using zramswap with
Code:
ZRAM_SIZE_PERCENT=100
and I believe I notice a significant performance boost. How do I make this survive a reboot? Now I have to do
Code:
systemctl start zramswap
after rebooting?
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Arch Linux ARM on PineTab Danct12 22 7,389 03-30-2021, 01:44 AM
Last Post: RTP
  Arch, Plasma desktop and wayland peperjohnny 48 12,947 02-02-2021, 06:14 AM
Last Post: wd5gnr
  Got Vivaldi Working on Arch! wd5gnr 4 1,816 11-09-2020, 12:13 PM
Last Post: hanscees
  zram guenther 0 723 10-26-2020, 05:52 AM
Last Post: guenther
  Any way to disable wake on power connect/full charge? (Arch) quipacorn 3 1,191 10-14-2020, 10:00 AM
Last Post: quipacorn

Forum Jump:


Users browsing this thread: 1 Guest(s)