MAC Spoofing failing in manjaro
(07-01-2020, 07:01 AM)Janoz Wrote:
(06-24-2020, 08:13 AM)slow_motion Wrote:
(06-19-2020, 04:23 PM)thumbsup Wrote: macchanger works fine for me (manjaro as well). No need to put wlan0 in down state. Sudo is needed.
Thank you for your message.
Mine refuses to work... i even executed it as root but still not working

I'm having the same issues. Some time ago I used the image from pine64 wiki and macspoofing was working fine (running it as a systemd unit file). Yesterday I tried the manjaro-arm-installer and wrote it to my eMMC. Everyhing works perfect (even LUKS encryption). But when creating a new systemd unit file systemctl status gives me: [ERROR] Could not change MAC: interface up or insufficient permissions: Invalid exchange.

Following archwiki I did fiddle with the config files in /etc/NetworkManager/conf.d/ but still unable to spoof my mac. I think this is firmware trouble but please correct me if I'm wrong. Any ideas?

I have the same issue after installing arch from Nadia and now i am looking for more info about that. If i am right i think i changed the mac addres with old distros, but not sure. 
Maybe the broadcom BCM43456 is FullMAC and MAC  is managed in hardware.  

Have u solved the issue?
I will try with old images for now:
- can't change wlan0 mac with kali-linux-2020.2-pinebook-pro.img.xz

Messages In This Thread
MAC Spoofing failing in manjaro - by slow_motion - 06-17-2020, 03:15 PM
RE: MAC Spoofing failing in manjaro - by thumbsup - 06-19-2020, 04:23 PM
RE: MAC Spoofing failing in manjaro - by Janoz - 07-01-2020, 07:01 AM
RE: MAC Spoofing failing in manjaro - by viel - 04-17-2021, 11:49 AM
RE: MAC Spoofing failing in manjaro - by user526 - 07-02-2021, 10:59 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Partial boot after installing Manjaro on emmc regivanx 3 44 9 hours ago
Last Post: regivanx
  Manjaro pinebookpro images with kernel 5.7.19 rfm83 11 1,505 01-22-2023, 10:05 PM
Last Post: rfm83
  No boot after Manjaro flash PBcurry 14 1,796 10-03-2022, 08:33 PM
Last Post: wdt
Big Grin EASY SOLUTION for Manjaro "Missing Keys" Update and Install Failure Zoroaster-Z 0 831 08-14-2022, 09:01 PM
Last Post: Zoroaster-Z
  Manjaro ARM new version? And hibernate/ sleep mode regretfulpineuser 0 452 06-20-2022, 02:48 PM
Last Post: regretfulpineuser
  Manjaro I3 james64 1 946 03-20-2022, 03:45 PM
Last Post: jiyong
  Updated stock Manjaro, now won't boot (brick?) pineymousepad 17 6,809 02-18-2022, 02:29 PM
Last Post: jiyong
  Manjaro i3 Edition not booting mtndew 0 1,132 08-23-2021, 06:21 PM
Last Post: mtndew
  Games compilation howto on the Pinebook-pro (Manjaro Linux and Debian native) astr0baby 200 248,591 08-01-2021, 04:30 PM
Last Post: wpeckham
  Manjaro KDE dolphin not showing usb device straightwalker 0 1,359 07-30-2021, 09:51 AM
Last Post: straightwalker

Forum Jump:

Users browsing this thread: 1 Guest(s)