Mobile Carriers in the United States
#21
Yeah, Debian/Phosh here also, everything works, except data at this time, but after talking to AT&T tech for over an hour on the phone
he concluded I needed a new sim card, so maybe data may work soon for me.

I Did connect a few times but I got a screen that said data was not included with my plan.... (But data is included in my plan)
      LINUX = CHOICES
         **BCnAZ**
               Idea
   Donate to $upport
your favorite OS Team
#22
Also on Debian/Phosh on Verizon. I've got incoming and outgoing calls working (pretty consistently), outgoing texts (incoming don't work), and data working.

I had to dial a number to get data working (either #777 or *228, I was having issues with #777 so I'm not sure which actually worked). I have the option of 4 different APNs for Verizon available, and have to choose vzwinternet to get data working (in addition to dailing). I was able to get both Web and Firefox to connect to various websites, and got hits on all repos in King's Cross.

The only thing I'm having issues with on a the connectivity front is incoming texts. If anyone has any idea, I'm all ears!

@bcnaz I know you asked about hotspotting in the other thread. I don't see how to set up a hotspot, but if you let me know where it is, I'll give it a shot!
#23
Sorry for my ignorance, but I have a regular account (not prepaid) with Verizon, is there any hope of it working with the PinePhone?
#24
(04-11-2020, 08:37 AM)laserbeamh Wrote: Also on Debian/Phosh
...
I know you asked about hotspotting in the other thread. I don't see how to set up a hotspot, but if you let me know where it is, I'll give it a shot!

Once you have mobile data running, goto Settings/WiFi and make sure WiFi is on. Then select the 3 dot settings icon at top between WiFi slider and X and select Hotspot.

(It will enable for about 30 seconds, if you are exceedingly quick you may even connect to it, then it will crash when modemmanager re-scans available WiFi networks. If so this is known issue already logged on GitLab )
  • ROCKPro64 v2.1 2GB, 16Gb eMMC for rootfs, SX8200Pro 512GB NVMe for /home, HDMI video & sound, Bluetooth keyboard & mouse. Arch (5.16 kernel, Openbox desktop) for general purpose daily PC.
  • PinePhone Pro Explorer Edittion, Tow-boot on SPI, Arch/phosh on eMMC
  • PinePhone BraveHeart now v1.2b 3/32Gb, daily driver: Tow-boot with Arch/Phosh on eMMC
#25
(04-11-2020, 04:34 PM)dukla2000 Wrote:
(04-11-2020, 08:37 AM)laserbeamh Wrote: Also on Debian/Phosh
...
I know you asked about hotspotting in the other thread. I don't see how to set up a hotspot, but if you let me know where it is, I'll give it a shot!

Once you have mobile data running, goto Settings/WiFi and make sure WiFi is on. Then select the 3 dot settings icon at top between WiFi slider and X and select Hotspot.

(It will enable for about 30 seconds, if you are exceedingly quick you may even connect to it, then it will crash when modemmanager re-scans available WiFi networks. If so this is known issue already logged on GitLab )

I found it, but it's grayed out for me. I tried while connected to a network, after having forgotten all known networks, and with wifi off and nothing worked. I restarted the ModemManger service as well, but to no avail.

@neverused I'm sorry, I should have specified. I'm using a postpaid Verizon account. I'm not sure how much of a difference (if any) there is between pre- and postpaid from a service standpoint, but postpaid is nearly functional.
#26
(04-11-2020, 08:37 AM)laserbeamh Wrote: Also on Debian/Phosh on Verizon. I've got incoming and outgoing calls working (pretty consistently), outgoing texts (incoming don't work), and data working.

I had to dial a number to get data working (either #777 or *228, I was having issues with #777 so I'm not sure which actually worked). I have the option of 4 different APNs for Verizon available, and have to choose vzwinternet to get data working (in addition to dailing). I was able to get both Web and Firefox to connect to various websites, and got hits on all repos in King's Cross.

The only thing I'm having issues with on a the connectivity front is incoming texts. If anyone has any idea, I'm all ears!

@bcnaz I know you asked about hotspotting in the other thread. I don't see how to set up a hotspot, but if you let me know where it is, I'll give it a shot!

You have Pinephone service on Verizon? Traditional 2G/3G CDMA or 4G LTE? It was my understanding Verizon would not let any new phones on their network unless they were VoLTE capable. Do you have VoLTE service?
#27
(04-12-2020, 11:27 AM)rocket2nfinity Wrote:
(04-11-2020, 08:37 AM)laserbeamh Wrote: Also on Debian/Phosh on Verizon. I've got incoming and outgoing calls working (pretty consistently), outgoing texts (incoming don't work), and data working.

I had to dial a number to get data working (either #777 or *228, I was having issues with #777 so I'm not sure which actually worked). I have the option of 4 different APNs for Verizon available, and have to choose vzwinternet to get data working (in addition to dailing). I was able to get both Web and Firefox to connect to various websites, and got hits on all repos in King's Cross.

The only thing I'm having issues with on a the connectivity front is incoming texts. If anyone has any idea, I'm all ears!

@bcnaz I know you asked about hotspotting in the other thread. I don't see how to set up a hotspot, but if you let me know where it is, I'll give it a shot!

You have Pinephone service on Verizon? Traditional 2G/3G CDMA or 4G LTE? It was my understanding Verizon would not let any new phones on their network unless they were VoLTE capable. Do you have VoLTE service?

I had it set to 2G/3G/4G, but to test your point, switched it to just 4G and had data service. I didn't check voice on just 4G, but data does work.

Is there a more accepted way to test VoLTE than making calls on 4G only that I should test or is that about it?
#28
(04-12-2020, 07:47 AM)laserbeamh Wrote: I found it, but it's grayed out for me. 
Yeah that is same for me, it it temperamental! if you exit WiFi settings, go back exit, check Bluetooth etc eventually you should find it selectable  Confused
  • ROCKPro64 v2.1 2GB, 16Gb eMMC for rootfs, SX8200Pro 512GB NVMe for /home, HDMI video & sound, Bluetooth keyboard & mouse. Arch (5.16 kernel, Openbox desktop) for general purpose daily PC.
  • PinePhone Pro Explorer Edittion, Tow-boot on SPI, Arch/phosh on eMMC
  • PinePhone BraveHeart now v1.2b 3/32Gb, daily driver: Tow-boot with Arch/Phosh on eMMC
#29
(04-12-2020, 03:06 PM)dukla2000 Wrote:
(04-12-2020, 07:47 AM)laserbeamh Wrote: I found it, but it's grayed out for me. 
Yeah that is same for me, it it temperamental! if you exit WiFi settings, go back exit, check Bluetooth etc eventually you should find it selectable  Confused

So you're right on both counts. It was grayed out, but switching into other menus eventually made it clickable. When I enabled it, it behaved exactly as you anticipated; showed up just long enough to try to connect before cutting out and searching for known networks.


@rocket2nfinity I tried a couple calls just now on 4G only and they work both in and out (with audio). Under Modem Details it reads:

Modem Status
    Carrier                  Verizon
    Network Type       lte
    Signal Strength
    Network Status    Registered

So it seems promising! If there's anything else I can test, let me know!
#30
(04-12-2020, 03:32 PM)laserbeamh Wrote:
(04-12-2020, 03:06 PM)dukla2000 Wrote:
(04-12-2020, 07:47 AM)laserbeamh Wrote: I found it, but it's grayed out for me. 
Yeah that is same for me, it it temperamental! if you exit WiFi settings, go back exit, check Bluetooth etc eventually you should find it selectable  Confused

So you're right on both counts. It was grayed out, but switching into other menus eventually made it clickable. When I enabled it, it behaved exactly as you anticipated; showed up just long enough to try to connect before cutting out and searching for known networks.


@rocket2nfinity I tried a couple calls just now on 4G only and they work both in and out (with audio). Under Modem Details it reads:

Modem Status
    Carrier                   Verizon
    Network Type       lte
    Signal Strength
    Network Status    Registered

So it seems promising! If there's anything else I can test, let me know!

Yes. Please type the following in terminal and tell me the output of the section under org.ofono.radiosettings and org.ofono.connection manager. I'm specifically looking for connection bearer info cs-preferred or ps-preferred and what bearer says under radio settings.

I want to caution you to scrub the IMEI, phone number, serial number and personal identifying info if you post the whole output here. Here is the command:

/usr/share/ofono/scripts/list-modems


Possibly Related Threads…
Thread Author Replies Views Last Post
  compatible carriers the7thpoint 2 126 06-17-2022, 08:24 AM
Last Post: mikehenson
Lightbulb pinephone mobile dock jasmin763 2 272 06-06-2022, 09:06 AM
Last Post: 98cwitr
Question Mobile data suddenly gone epiii2 1 186 05-23-2022, 04:57 PM
Last Post: epiii2
  UK Carriers Zweitaktmotor 4 643 03-27-2022, 07:05 AM
Last Post: Dog House Dave
  Mobile case wanted - with wireless charging! thorensjubilee 4 683 03-19-2022, 10:29 AM
Last Post: vap0rtranz
  Sim cards and carriers, discussion bcnaz 129 58,531 03-09-2022, 11:15 PM
Last Post: bungorogers
  mobile data jimbusch1 5 900 02-24-2022, 02:41 PM
Last Post: amindfv
  Carriers do not support PinePhone? rey70 22 3,768 02-07-2022, 09:06 PM
Last Post: bcnaz
Sad LTE data does not work on T-Mobile US with latest postmarketOS 21.06 SP3 PacificSinewave 1 350 11-07-2021, 10:15 AM
Last Post: beta-user
Question Mobile Carriers 67comet 29 15,202 07-14-2021, 11:47 PM
Last Post: rocket2nfinity

Forum Jump:


Users browsing this thread: 1 Guest(s)