Armbian - Xenial Desktop (Pinebook)
#71
(12-14-2018, 05:12 AM)ImmortanJoe Wrote:
(12-14-2018, 04:24 AM)igorp Wrote: Both versions must/should work.

I didn't test eMMC for this latest build for 1080p with legacy kernel 3.10.y and which is a bit pointless to invest into. Others were tested many times and install is super easy. It is possible that eMMC which is in your Pinebook is not supported in the kernel. It is rare but possible.

Isn't Legacy using the same BSP kernel as the shipped KDE Neon?

You are right though. I don't see the eMMC listed with fdisk -l
Although that appears to be the issue, I don't see why that would make the whole installation section of armbian-config go missing.

I kind of wanted to dump the legacy Ambian onto the eMMC to replace KDE Neon which is useless to me, and continue to run Armbian mainline from MicroSD. This is solely because the legacy release supports BT and appears to support suspend. Besides that it's a pain because it doesn't support the newer version of ext4.

I confirm, the eMMC drive is not recognized by the legacy kernel. For the moment I'll still use the mainline on the eMMC and the legacy on the SD card.
  Reply
#72
Anyone know of a fix for the jumpy trackpad on xenial? I love armbian, but the trackpad on my 1080p pinebook is nearly unusable for me.
  Reply
#73
How can I control the screen brightness? Seems like xbrightness does not work.
I'm using Stretch with mainline
  Reply
#74
(01-07-2019, 09:31 AM)fitter Wrote: How can I control the screen brightness? Seems like xbrightness does not work.
I'm using Stretch with mainline

If xbrightness does not work with Armbian, and it does not work with Archlinux/Manjaro neither there was this discussion with some scripts.
I have not tried them though..

https://forum.pine64.org/showthread.php?tid=5062
  Reply
#75
If you are using the Armbian with kernel 3.10 you need to format the eMMC as ext2 in order to boot from eMMC, it won't boot with ext4.

On mine I can't get the 4.19 kernel version to boot at all.
  Reply
#76
I see that armbian stretch has moved from unsupported to supported, finally.

However, I'm still stuck on 5.60 and dev branch. I wonder, if there's any way to upgrade to supported next branch and 5.69 version?

Update: I've looked everywhere through armbian-config, but can't seem to find a switch between dev <-> next branches. I can switch to nightly, but this takes me to the 5.68-dev, that still has no sound and has backlight problems.
  Reply
#77
So it isn't just me. I guess there is no obvious way to shift branches. That's unfortunate.

I've mostly been using the original preview of Armbian. It works well, besides the lack of support for some of the hardware.

The last week I've mostly been using the smelly version from MicroSD because all I've been doing is scripting and web browsing in short bursts.

Odd. I didn't have any issue with using the brightness control that's a part of the battery applet. Just remember CLICK AND DRAG. If you just click on the bar to lower brightness it'll jump straight to zero.

Slow window resizing on both versions of Armbian can be worked around by disabling compositing, with the aveat that dragging becomes slower.

Overlay scrollbar bugs seem to be he cause of the lack of scrollbar in terminal windows. I think they can be disabled. I just installed lxterminal and set it to default instead.

For whatever reason, Firefox is way faster than Chromium too if it's bothering anyone.


(01-08-2019, 08:07 PM)WZ9V Wrote: If you are using the Armbian with kernel 3.10 you need to format the eMMC as ext2 in order to boot from eMMC, it won't boot with ext4.

the eMMC isn't even visible as a device with the legacy kernel.
  Reply
#78
I've ended up going with re-imaging way.

I've backed up my /home for data and settings, then exported a list of installed packages from dpkg (to quickly restore package set to previous state).
  Reply
#79
I've been having trouble taking advantage of any of the Mali gpu (OpenGL ES/OpenCL/Vdpau/etc..). I see the lima driver being loaded in the kernel (lima 1c4000.gpu)...
Any suggestions? Is there a non-free deb package I should download?
Thanks
  Reply
#80
(03-02-2019, 03:59 PM)tequilasunrise Wrote: I've been having trouble taking advantage of any of the Mali gpu (OpenGL ES/OpenCL/Vdpau/etc..). I see the lima driver being loaded in the kernel (lima 1c4000.gpu)...
Any suggestions? Is there a non-free deb package I should download?
Thanks

Still a bit early to use LIMA, may be mid of this year is a good time. Currently PinePhone development still progress with MALI and will replace to LIMA when ready to do so.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Pinebook Pro (i3 WM): Confirm Shutdown on Power Button etothepii 3 562 08-14-2020, 06:03 AM
Last Post: loblik
  Manjaro sway profile for pinebook e-minguez 3 344 07-21-2020, 03:25 PM
Last Post: jezek
  Reset User or Factory Reset PineBook Linux 11.6" pittman64 1 390 07-07-2020, 11:26 PM
Last Post: tllim
  Pinebook is going the way of Betamax? trigger 9 1,618 06-21-2020, 03:08 PM
Last Post: secristr
  Slarm64 on Pinebook [Slackware Arm - 64 bit] KRT 10 2,288 06-04-2020, 11:31 PM
Last Post: KRT
Information Manjaro ARM for Pinebook erchache2000 75 13,434 05-10-2020, 02:06 PM
Last Post: telle
  pinebook black screen when booting with "different power mode than last used" penzoiders 12 2,443 04-27-2020, 06:27 AM
Last Post: tophneal
  Kali Linux for the Pinebook Luke 1 751 03-03-2020, 05:01 AM
Last Post: e-minguez
  Anyway to run Teamviewer for ARM/Pinebook? Ekkaia 8 4,415 01-16-2020, 08:51 PM
Last Post: dhosh
  Pinebook Wlan Driver does not work properly matze79 2 504 12-15-2019, 02:50 AM
Last Post: matze79

Forum Jump:


Users browsing this thread: 1 Guest(s)