No boot at all
#1
Hi everyone 

This is my first post on this forum. I am a brand new user of the ROCK64 4GB SBC. 

Few days ago I have received my order.
MMC card I have from Odroid but also I have created some SD cards to try different boot methods. 

Unfortunately none of the boot methods works. 
After applying power all  three LEDs lit solid light. Nothing else happens. 
Power adapter I use is 4A one for Lenovo. 

I do not have serial console. Or shall I say do not use, as I have not tried USB one. Will it work?

I have working tinker board from Asus, raspberry pi first gen and odroid xu4. 
I haven’t imagined that will have such a basic problem with ROCK64  

Also I can not find any kind of documentation. Like  meaning of white and red LED, usage of recovery button, etc. 

Can someone help he, guide me or point source of information?
  Reply
#2
Hi, couple of questions. Which exact image did you try and how did you create the card? What is your power supply? For more debugging/troubleshooting please use a serial console adapter like for the RPi and post the logs if there are any. Any USB serial adapter is fine as long as the board side uses 3.3V logic levels. Connections are the same as for RPi....
Come have a chat in the Pine IRC channel >>
  Reply
#3
Thanks for interest!
In meantime, from support I got advice to use modified etcher tool. Tried that to burn Debian minimal iso and after few sec the normal kernel booting screen appeared over hdmi. Thus board is working. Yuppie!

So the solution was to wait several seconds using proper iso, previously I have used original etcher with image taken directly from wiki page.

Rest of the question remains. What is purpose of white led and the recovery button?
  Reply
#4
(11-30-2017, 04:13 PM)Arkadiusz Wrote: Thanks for interest!
In meantime, from support I got advice to use modified etcher tool. Tried that to burn Debian minimal iso and after few sec the normal kernel booting screen appeared over hdmi. Thus board is working. Yuppie!

So the solution was to wait several seconds using proper iso, previously I have used original etcher with image taken directly from wiki page.

Rest of the question remains. What is purpose of white led and the recovery button?


Hey, could you tell me which modified etcher tool did you use? Im having a similar problem and that may fix it.

Thanks in advance!
  Reply
#5
(04-18-2018, 12:24 PM)ace_baws Wrote: Hey, could you tell me which modified etcher tool did you use? Im having a similar problem and that may fix it.

Most likely it's the pine64 installer - it's based on etcher, but also serves up a curated list of images you can download and write to SD/eMMC (with adapter). 

A lot of issues come down to fake/faulty (micro)SD cards, so it's good to use a tool like Etcher which also verifies the write afterwards.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  boot hdd usb3 philipe 1 409 01-27-2021, 02:12 PM
Last Post: tllim
  Libreelec Rock64 - 4GB no boot spiker15 3 1,279 11-02-2020, 12:36 AM
Last Post: wilsonYan
  Rock64 - boot helpmerock 2 1,075 10-08-2020, 01:29 PM
Last Post: helpmerock
  No boot up after power on Whoopsadaisy 4 1,971 09-26-2020, 05:14 PM
Last Post: simonsouth
Bug u-boot (forks) status mcerveny 14 6,595 08-27-2020, 01:44 PM
Last Post: globaltree
Sad No boot, garbage console text and blinking red light ... jean_bruder 2 1,281 07-19-2020, 08:37 AM
Last Post: jean_bruder
  Graphical boot manager john3voltas 0 626 03-25-2020, 02:27 PM
Last Post: john3voltas
  doesn't boot, no video cjyar 7 2,440 11-15-2019, 03:45 PM
Last Post: ab1jx
  Unable to boot from SPI stevefan1999 4 2,259 05-01-2019, 04:47 PM
Last Post: rhens1
  No Boot, Red Green and White flash at 1 sec intervals wesleykonrad 2 1,504 01-28-2019, 11:54 PM
Last Post: wesleykonrad

Forum Jump:


Users browsing this thread: 1 Guest(s)