Play Store stops running every time
#1
If there's already a thread on this specific issue, my apologies. I've read through the play store authentication issues thread, and tried my luck with the forum's Search feature but haven't seen this problem solved.

The OS is the 5 May version of Android 5.1.1 on a Sandisk 32 Gig SD (the same as recommended throughout the forum); hardware is a Pine64+ 1Gig with Bluetooth and wifi board. The clock is correct.

There are several things to complain about with this build but for me the most problematic is that Google Play Store stops working soon after it's brought up. Once in a great while right after boot I can download an app but usually Play Store stops running--no reason given--while I'm looking at offerings or after I've chosen an app but before it can download. This isn't apparently an authentication problem, as I get no message about that. Rebooting doesn't solve it except to allow Play Store to fool me again.

I've tried the solutions suggested under the authentication issues thread on the theory that it can't hurt. I also re-downloaded the image and reburned it. No joy. Has anyone else had this problem and solved it?
EDIT: After a better search I found other posts about this problem but no solutions.
  Reply
#2
same here. Cannot barely download apps from google play store.
  Reply
#3
(07-04-2016, 05:58 PM)DarksoulsPI Wrote: same here. Cannot barely download apps from google play store.
Frustrating as heck, I'd say. Add in that the Google Play Movies app can't play its own movies--just a black screen and no sound--and the OS is close to useless for what I want. I backed the Pine64 specifically because it was (said to be) able to run Android. (Smirk)
The Debian OS isn't much better. No sound on music playback and a couple of other problems any competent OS would be ashamed of.
  Reply
#4
I created a second Google account so I could log in and out back and forth when that happens. Sort of silly that I should have to do that, but a big part of the issue is poor OS design by Android.
  Reply
#5
(07-05-2016, 06:00 AM)mesaxi Wrote: I created a second Google account so I could log in and out back and forth when that happens. Sort of silly that I should have to do that, but a big part of the issue is poor OS design by Android.

I have another Google account, but just to be sure I understand--does switching from one to the other actually prevent Google Play Store from stopping/crashing? Or is that a way to get around the authentication issue (which I think isn't the problem with my unit)? I hope it's the former and not the latter because it'd be fine by me if I only have to switch back and forth. Thanks for the tip.
And you're right: it's the OS, not the Pine, that's the problem. Didn't mean to sound like I was zapping the board.
  Reply
#6
I've had the same issue. My only workaround has been to go to play.google.com using Chrome and download whatever app I need from there.
  Reply
#7
(07-05-2016, 10:25 AM)scdbeebe Wrote: I've had the same issue. My only workaround has been to go to play.google.com using Chrome and download whatever app I need from there.

Hi. I have same problem on Pine64 2G board. I solved this problem by removing the updates from Google Play service. If need i can add screenshot where.
  Reply
#8
Have you tried what Danja suggested in this thread ?  

For your convenience I will quote here "For the hell of it I tried to add my account again with the old one still there to see if it wasn't registering properly and would duplicate, it gave me the error as it should that it was already added and then I re-tried the play store and it worked."
You can find me on IRC, Discord and Twitter


  Reply
#9
(07-06-2016, 04:30 AM)Luke Wrote: Have you tried what Danja suggested in this thread ?  

For your convenience I will quote here "For the hell of it I tried to add my account again with the old one still there to see if it wasn't registering properly and would duplicate, it gave me the error as it should that it was already added and then I re-tried the play store and it worked."

That was one of the first things I tried even though it was for the authentication issue rather than the crash situation (unless they're just different manifestations of the same thing, IDK). It didn't help, tho. It may be that using Firefox to access the play store will be the way to go--I've been able to DL a couple of apps that way, though even that route isn't a guarantee of success. Somewhere along the DL/install process, play store is apparently called to finish the job and that's where it sometimes works, sometimes not.
My ultimate goal is to get Google Play Movies to play its own videos. I have 4 that I own and none of them play on the Pine with Android (nor Debian, for that matter). This is a different issue, I know, but it's therapeutic to blow off.
Thanks for quoting that thread for me. It was very thoughtful!
Lee

(07-05-2016, 10:00 PM)Artyom Wrote:
(07-05-2016, 10:25 AM)scdbeebe Wrote: I've had the same issue. My only workaround has been to go to play.google.com using Chrome and download whatever app I need from there.

Hi. I have same problem on Pine64 2G board. I solved this problem by removing the updates from Google Play service. If need i can add screenshot where.

I'll try that. I go into Settings/Apps to do that, yes?
  Reply
#10
Yes. You must delete update for Google play service.
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Issues with SD Card and Running Android Twistedx 0 250 02-26-2019, 11:58 AM
Last Post: Twistedx
  GPIO access running Android rddragon888 20 5,934 11-06-2017, 07:18 AM
Last Post: Anvesh Reddy
Question Running VPN Punkyclown 2 560 06-12-2017, 03:25 AM
Last Post: nicosaturno
  Pine A64 running Android 7.1 kernel panic leon 1 959 05-12-2017, 04:53 PM
Last Post: ayufan
  How to Make a Pine with Android 7.0 Stay on All the Time? Bob123456789 3 993 04-05-2017, 01:12 PM
Last Post: Bob123456789
Thumbs Up Kids love to Play Super Why App Erica Edwards 3 458 01-09-2017, 07:35 PM
Last Post: tllim
  Play music won't play anything mikey0000 12 1,218 10-21-2016, 01:24 PM
Last Post: gezora
  ssh into Pine64 running Android scarabus 5 2,129 10-03-2016, 09:02 AM
Last Post: lovenemesis
  play store auth issue chrwei 29 3,854 09-09-2016, 11:02 AM
Last Post: eldaria
  Can't download apps off Google Play! Bacon Strips 6 1,124 08-31-2016, 12:26 PM
Last Post: DonFL

Forum Jump:


Users browsing this thread: 1 Guest(s)