Fried eMMC?
#1
I have a Pinebook Pro. I did the following:
  • I flashed the Manjaro image on the eMMC from Debian running on from the SD card. That rendered it unbootable, it only lit up both LEDs if I tried to power it on.
  • I concluded that it must have a corrupt bootloader or u-boot on the eMMC, so I removed it. It then booted fine from the SD card.
  • I did the trick where I reinstalled the eMMC and then switched on the eMMC switch just after the machine started booting. It booted from the SD card and recognized the eMMC.
  • I then zeroed out the first few MBs of the eMMC in order to nuke the defunct bootloader or u-boot. After a few seconds the machine hung, I though it was because it filled its RAM with IO cache, no big deal.
  • Since it must have gone past the bootloader already, I reset the machine - and after that it never showed the eMMC drive again. It doesn't show up in /dev, it isn't shown in gparted. Dmesg only shows one line containing mmc1, it's about clock speed being set. I misplaced my USB eMMC reader, so I can't test it using that. I tried using rkflashtool, it shows this:
Code:
rkflashtool: info: rkflashtool v5.2
rkflashtool: info: Detected RK3399...
rkflashtool: info: interface claimed
rkflashtool: info: MASK ROM MODE
rkflashtool: info: Flash ID: 00 00 00 00 00
rkflashtool: info: Flash Info:
       Manufacturer: Samsung (0)
       Flash Size: 0MB
       Block Size: 0KB
       Page Size: 0KB
       ECC Bits: 0
       Access Time: 0
       Flash CS:
but it shows the same even if I remove the eMMC. (I had to patch rkflashtool and add the pid of rk3399 because it wouldn't find the pbp) Did I fry the module somehow? How to test it further before ordering (and waiting for) another eMMC reader? (I want to order a new eMMC too if this one is really fried and I don't want to pay for shipping twice)
  Reply


Messages In This Thread
Fried eMMC? - by matega - 01-15-2020, 03:25 PM
RE: Fried eMMC? - by belfastraven - 01-15-2020, 06:48 PM
RE: Fried eMMC? - by matega - 01-16-2020, 12:59 AM
RE: Fried eMMC? - by belfastraven - 01-16-2020, 01:59 PM
RE: Fried eMMC? - by matega - 01-17-2020, 08:03 AM
RE: Fried eMMC? - by belfastraven - 01-18-2020, 04:33 PM
RE: Fried eMMC? - by matega - 01-28-2020, 06:47 AM
RE: Fried eMMC? - by matega - 01-28-2020, 07:53 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  U-Boot with direct NVMe boot support for eMMC/SPI Flash pcm720 117 85,556 Yesterday, 11:44 AM
Last Post: tophneal
  Wiped EMMC, forgot do write new image, won't recognize EMMC zeno 4 140 05-11-2021, 01:53 PM
Last Post: wdt
  Need Advice for Wiping eMMC on Dead LCD Pinebook Pro calinb 9 191 05-10-2021, 12:49 PM
Last Post: calinb
  eMMC not gets detected by initramfs? overlisted 6 1,198 05-09-2021, 09:08 PM
Last Post: djhnsn
  Happy eMMC and SDcard OS usage for Pinebook Pro Newbies... Paulie420 40 16,884 02-27-2021, 11:01 AM
Last Post: wdt
  Pinebook Pro 128GB EMMC for sale **sold** dgkPBP 7 1,469 01-15-2021, 08:48 AM
Last Post: dgkPBP
  Booting to sdcard stopped working after emmc flash techiedog 3 982 12-31-2020, 06:30 PM
Last Post: Anarethos
  Flash non-bootable eMMC? midnightcheese 2 555 12-24-2020, 08:01 AM
Last Post: midnightcheese
  Pinebook Pro refuses to boot from eMMC pivic 23 4,423 12-14-2020, 05:08 PM
Last Post: KC9UDX
  Pinebook Pro won´t boot either from eMMC or microSD robieguarneros 40 9,307 11-16-2020, 10:48 AM
Last Post: axel

Forum Jump:


Users browsing this thread: 1 Guest(s)