NVMe power issue?
#1
Hi all,

I've just experienced what appears to be a power issue with the VCC3V3_SSD and probably also the VCC3V3_SYS rail. When my battery is below 40 % communication with the NVMe SSD fails on bootup. This manifests itself in either kernel warnings on bootup and a kernel panic as soon as i enter lspci or a kernel panic immediately on bootup.

My current theory is that during probing of partitions on the NVMe SSD the SSD enters a high power mode and U3 can't keep VCC3V3_SYS at 3.3 V.
The SSD I'm using is a Corsair MP510. Its supported power states are

Code:
St Op     Max   Active     Idle   RL RT WL WT  Ent_Lat  Ex_Lat
0 +     6.80W       -        -    0  0  0  0        0       0
1 +     5.74W       -        -    1  1  1  1        0       0
2 +     5.21W       -        -    2  2  2  2        0       0
3 -   0.0490W       -        -    3  3  3  3     2000    2000
4 -   0.0018W       -        -    4  4  4  4    25000   25000

I'm in general somewhat puzzled about how the Pinebook Pro is supposed to stay operational when the battery is low. The discharge cutoff voltage of the battery is specified as 2.75 V. However U3 is just a step-down regulator. Thus it won't be able to maintain VCC3V3_SYS at 3.3 V once the battery discharges below 3.3 V.

Has anybody else experienced anything similar yet?
Manjaro ARM

Kernel dev
Buy me a coffee


Messages In This Thread
NVMe power issue? - by tsys - 11-21-2019, 07:49 PM
RE: NVMe power issue? - by hmuller - 11-22-2019, 11:50 AM
RE: NVMe power issue? - by belfastraven - 12-24-2019, 01:27 PM
RE: NVMe power issue? - by tsys - 11-24-2019, 01:37 PM
RE: NVMe power issue? - by hmuller - 11-27-2019, 08:23 AM
RE: NVMe power issue? - by tsys - 11-27-2019, 08:32 AM
RE: NVMe power issue? - by hmuller - 12-07-2019, 01:42 PM
RE: NVMe power issue? - by Arwen - 12-07-2019, 02:01 PM
RE: NVMe power issue? - by tsys - 12-07-2019, 02:15 PM
RE: NVMe power issue? - by hmuller - 12-07-2019, 02:56 PM
RE: NVMe power issue? - by hmuller - 12-18-2019, 04:01 PM
RE: NVMe power issue? - by tsys - 12-19-2019, 08:22 AM
RE: NVMe power issue? - by Arwen - 12-19-2019, 05:38 PM
RE: NVMe power issue? - by hmuller - 12-25-2019, 08:04 PM
RE: NVMe power issue? - by zaius - 12-26-2019, 01:34 PM
RE: NVMe power issue? - by tophneal - 12-26-2019, 01:38 PM
RE: NVMe power issue? - by as400 - 12-26-2019, 09:41 AM
RE: NVMe power issue? - by belfastraven - 12-26-2019, 12:51 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Pinebook Pro on Debian 12 Power Issue u974615 1 578 03-13-2024, 10:46 AM
Last Post: u974615
  New Working nVME gilwood 0 401 02-12-2024, 08:46 AM
Last Post: gilwood
  Pine Dock Networking Issue trillobite 1 440 02-10-2024, 12:03 AM
Last Post: trillobite
  NVME problems 2022 / Intel 660p 1TB Starbug 1 1,796 04-04-2023, 12:16 PM
Last Post: globaltree
  PineBook Pro revision 2.2: Wishlist for the hardware issue fixes dsimic 115 145,861 11-30-2022, 04:28 PM
Last Post: KC9UDX
Thumbs Up NVMe adapter, Great addition dachalife 2 2,041 11-28-2022, 12:56 PM
Last Post: dachalife
  Increasing the maximum power draw dsimic 15 20,662 11-21-2022, 03:36 AM
Last Post: bircoph
  Alternative Power supply options gallomimia 13 18,742 11-13-2022, 06:10 PM
Last Post: pineymousepad
  PBP booting but stops at flashing power led jonasd 13 6,236 09-26-2022, 12:17 AM
Last Post: jonasd
  NVMe drives not detected mattpenn 12 11,295 03-05-2022, 04:53 AM
Last Post: mattpenn

Forum Jump:


Users browsing this thread: 1 Guest(s)