WiFi issues Pinebook Pro
#1
Hi Pine64 Community!


Just received my Pinebook Pro, and I am very excited. I just looked at the thread saying that the privacy switch for WiFi left the factory engaged, however, after disabling it and rebooting Manjaro is still not able to sniff out any available WiFi around my home. How do I address this problem?

Thank you for your help!
#2
(05-28-2020, 01:14 PM)sunnystormy Wrote: Hi Pine64 Community!


Just received my Pinebook Pro, and I am very excited. I just looked at the thread saying that the privacy switch for WiFi left the factory engaged, however, after disabling it and rebooting Manjaro is still not able to sniff out any available WiFi around my home. How do I address this problem?

Thank you for your help!

Update:

I've reinstalled Manjaro Linux ARM, which is referenced inside of the Pine64 wiki, but the WiFi issue persists. Am I missing something? Please let me know!
#3
Can you see the wlan0 card? If not, that just means that you haven't managed to disable the privacy switch.
How did you disable the privacy switch exactly?
You can find me on IRC, Discord and Twitter


#4
(05-28-2020, 03:54 PM)Luke Wrote: Can you see the wlan0 card? If not, that just means that you haven't managed to disable the privacy switch.
How did you disable the privacy switch exactly?

I got it to work. I misread the Wiki, and mistook the 2 blinks for enabling the privacy switch, instead of enabling WiFi. Everything works now.

*phew*

Glad to move past that! Smile Now I can begin enjoying my laptop. Thank you for your help!
#5
Thats fine. Now that you're reinstalled, you'll want to enable HW acceleration (not on in default build IRRC). Go to compositor settings, check openGL 2.0 and make sure to set it so it runs on boot (there is a tick-box). Have fun.
You can find me on IRC, Discord and Twitter


#6
Hi Luke!


Thank you for your help! I've got the compositor working, but I can't seem to get blender, or anything opengl-related to run properly? Am I missing a package? I can open a new thread, if you think it's necessary.

Thank you!
#7
(05-28-2020, 05:21 PM)sunnystormy Wrote: Hi Luke!


Thank you for your help! I've got the compositor working, but I can't seem to get blender, or anything opengl-related to run properly? Am I missing a package? I can open a new thread, if you think it's necessary.

Thank you!

Now THAT is something you need to go chase developers about.
Suggest you either open a new thread on here or on their forum .... that said, you should be able to run most of these apps with hw acceleration just fine. Flags missing? (most likely).
You can find me on IRC, Discord and Twitter




Possibly Related Threads…
Thread Author Replies Views Last Post
  Multiple issues with new phone GlockG20 7 635 06-20-2021, 10:26 AM
Last Post: Aberts10
  First time user experiencing weird keyboard issues kendew 5 1,284 06-19-2021, 08:14 AM
Last Post: rotwang
  Use SD to install new OS over pinebook debian Rudy558 2 646 06-11-2021, 12:35 AM
Last Post: TfromTexas
  Java on Manjaro ARM Pinebook Pro gulagpyromaniac 3 223 05-25-2021, 11:05 AM
Last Post: tophneal
  Setup My Pinebook 64 and Lost Password jersdayoff 5 569 05-01-2021, 10:29 PM
Last Post: wdt
  No WIFI network discovery in any manjaro installation (but works on fedora) pineitup 1 667 02-02-2021, 12:13 AM
Last Post: PineSupporter
  How to boot from SD card on pinebook pro linux123 3 1,204 12-02-2020, 10:29 AM
Last Post: linux123
  Changing locale on Pinebook Pro Perl6_user 5 2,288 09-16-2020, 05:13 PM
Last Post: guava
  Cannot charge and NO Wifi? jiapei100 3 2,155 06-27-2020, 02:11 PM
Last Post: jiapei100
Big Grin New to Pinebook Pro SanjevR 5 3,134 06-07-2020, 07:35 AM
Last Post: spikerguy

Forum Jump:


Users browsing this thread: 2 Guest(s)