RockPro64 ethernet issues: DMA engine initialization failed
#1
Hi friends, 
I'm totally new to pine, and trying to bring up my RockPro64 for the first time. 
I managed to concatenate and burn the Debian net install images and boot from MicroSD.

However, early in the install process, network configuration through DHCP fails. 
I played around with manual settings with no progress. 
Then I checked dmsg and found this fairly ominous DMA error:

eth0: PHY [stmmac-0:00] driver [RTL8211F Gigabit Ethernet] (irq=POLL) 
Failed to reset the dma 
eth0: stmmac_hw_setuo: DMA engine initialization failed 
eth0: stmmac_open: Hw setup failed.


anyone have any ideas on how I might progress? I do have the wireless adaptor, so in theory I could also try that (or remove that?)
  Reply
#2
I'm marking this issue as resolved.  
While I haven't yet resolved this specific issue, I'm simply going to work around it. 

I wanted to try a different distro, to test the hardware. 
First I tried Armbian_21.02.3_Rockpro64_buster_current_5.10.21.img, and found I couldn't progress past the uboot stage. 
Finally I tried Armbian_21.02.3_Rockpro64_buster_legacy_4.4.213.img, and everything is working so great.  For now I'm going to stick with this install. 

Thanks everyone for the help.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  failed to read Who-am-I register hdbreak 3 904 06-06-2021, 12:26 AM
Last Post: kqlnut
  ethernet lan speed problem android fulltone 0 1,342 04-23-2018, 01:47 AM
Last Post: fulltone

Forum Jump:


Users browsing this thread: 1 Guest(s)