Unusable ROCKPRO64
#1
Hi all,

            after running well for 25 days more or less, my rockpro64 is unusable. All USB ports and ethernet port are not working. I tried with many images, Manjaro, armbian... to top it all sometimes the startup finish with a kernel panic message.

I'm pretty sure that this is a hardware failure. Has anyone a similar experience? I'm very disgusted, the rockpro64 only ran for 25 days more or less. I have had others SBC, like raspberry pi, in the same place for years without problems. 


Sad
  Reply
#2
(02-09-2021, 10:09 AM)drenedo Wrote: Hi all,

            after running well for 25 days more or less, my rockpro64 is unusable. All USB ports and ethernet port are not working. I tried with many images, Manjaro, armbian... to top it all sometimes the startup finish with a kernel panic message.

I'm pretty sure that this is a hardware failure. Has anyone a similar experience? I'm very disgusted, the rockpro64 only ran for 25 days more or less. I have had others SBC, like raspberry pi, in the same place for years without problems. 


Sad

Please make sure that your power supply rated 12V 3A or 5A. Looks like your board not getting enough power. If you are using teh Raspberry Pi power power which is 5V, then for sure is under power.
  Reply
#3
(02-13-2021, 07:06 PM)tllim Wrote:
(02-09-2021, 10:09 AM)drenedo Wrote: Hi all,

            after running well for 25 days more or less, my rockpro64 is unusable. All USB ports and ethernet port are not working. I tried with many images, Manjaro, armbian... to top it all sometimes the startup finish with a kernel panic message.

I'm pretty sure that this is a hardware failure. Has anyone a similar experience? I'm very disgusted, the rockpro64 only ran for 25 days more or less. I have had others SBC, like raspberry pi, in the same place for years without problems. 


Sad

Please make sure that your power supply rated 12V 3A or 5A. Looks like your board not getting enough power. If you are using teh Raspberry Pi power power which is 5V, then for sure is under power.

The power supply is correct. 12V 5A.
  Reply
#4
Does it boot at all?
Could you hook up a serial connection like outlined here, and see what the boot init looks like?
https://forum.pine64.org/showthread.php?tid=6387
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  NAS Optimizations for RockPro64 MNtinkerer 5 819 07-01-2022, 03:06 PM
Last Post: enorbet2
  How to run Raspberry Pi software on RockPro64? pk245 0 120 06-24-2022, 08:20 AM
Last Post: pk245
  OPNsense for RockPro64 one8three 1 158 06-18-2022, 08:48 AM
Last Post: dkebler
  ROCKPRO64 PCI SSD SD-boot Install pspgarret 0 88 06-09-2022, 10:56 AM
Last Post: pspgarret
  RockPro64 has no white led, nor will it boot past... AnjinMeili 2 150 05-31-2022, 09:19 AM
Last Post: Rocklobster
  RockPro64 Debian xrdb -- problem connecting emarsh 0 131 05-19-2022, 09:55 AM
Last Post: emarsh
  Booting my RockPro64 from NVMe drive PsySc0rpi0n 4 2,808 05-11-2022, 02:35 PM
Last Post: PsySc0rpi0n
  rockpro64 emmc GreyLinux 8 2,654 11-08-2021, 01:56 PM
Last Post: GreyLinux
  ROCKPro64 sometimes doesn't Power On Pete Tandy 2 1,722 08-24-2021, 05:50 AM
Last Post: Pete Tandy
  Tutorial request: overclocking a rockpro64 Mentaluproar 1 1,323 08-15-2021, 01:35 PM
Last Post: dukla2000

Forum Jump:


Users browsing this thread: 1 Guest(s)