Can't boot up Manjaro 20.04 eMMc image from SD card...
#1
Hello,
I'm trying to replace the original Debian OS with Manjaro 20.04. I use the latest image (eMMC version) installed to the SD card with Etcher. It starts Manjaro but I never get past the splash screen. I can flash the SD with a non-eMMC image and boot to Manjaro and run off the SD no problem. But trying to get the Manjaro image (eMMC version) to allow me to install on the PBP...Won't go....

Can someone point me to a "how to" so I can get this right? Many Thanks!! :-)
#2
Try hitting any key at the splash screen. Maybe it will advance.
#3
(06-10-2020, 09:12 PM)Samurai_Crow Wrote: Try hitting any key at the splash screen.  Maybe it will advance.
Thanks for the suggestion, but it doesn't seem to work. Very odd. 
I'm sure there must be something I'm missing..

This is one of the first hundred  PBP. Wondering if there's something different about this one that is causing an issue?
#4
(06-11-2020, 06:59 AM)rick1959 Wrote: Thanks for the suggestion, but it doesn't seem to work. Very odd. 
I'm sure there must be something I'm missing..

This is one of the first hundred  PBP. Wondering if there's something different about this one that is causing an issue?

There has been at least one reported instance where the user couldn't get past the splash screen for ~20-30m. During that time ESC did nothing or cancelled the installer running in the background. After that time elapsed, hitting ESC allowed them to complete installation.

Which eMMC installer are you using, for KDE or XFCE? You might try using the other one.

If you can boot Manjaro from SD without an issue, you could use that same .img and write it directly to the eMMC, also.

There shouldn't be any major differences in the older/newer PBPs, aside from some cosmetics, like the strength/brittleness of the plastics. I have a PBP from the first and second public batches, and neither shows any difference in how they run OSes.
#5
(06-11-2020, 07:12 AM)tophneal Wrote:
(06-11-2020, 06:59 AM)rick1959 Wrote: Thanks for the suggestion, but it doesn't seem to work. Very odd. 
I'm sure there must be something I'm missing..

This is one of the first hundred  PBP. Wondering if there's something different about this one that is causing an issue?

There has been at least one reported instance where the user couldn't get past the splash screen for ~20-30m. During that time ESC did nothing or cancelled the installer running in the background. After that time elapsed, hitting ESC allowed them to complete installation.

Which eMMC installer are you using, for KDE or XFCE? You might try using the other one.

If you can boot Manjaro from SD without an issue, you could use that same .img and write it directly to the eMMC, also.

There shouldn't be any major differences in the older/newer PBPs, aside from some cosmetics, like the strength/brittleness of the plastics. I have a PBP from the first and second public batches, and neither shows any difference in how they run OSes.
Thanks for that info Top!!
KDE....I like Manjaro for many computer uses. So if KDE works, it'll be a big boost for me.
 I'm going to work on my patience and let it take its time.
Will report back later...Many Thanks again!! :-)
#6
(06-11-2020, 07:12 AM)tophneal Wrote:
(06-11-2020, 06:59 AM)rick1959 Wrote: Thanks for the suggestion, but it doesn't seem to work. Very odd. 
I'm sure there must be something I'm missing..

This is one of the first hundred  PBP. Wondering if there's something different about this one that is causing an issue?

There has been at least one reported instance where the user couldn't get past the splash screen for ~20-30m. During that time ESC did nothing or cancelled the installer running in the background. After that time elapsed, hitting ESC allowed them to complete installation.

Which eMMC installer are you using, for KDE or XFCE? You might try using the other one.

If you can boot Manjaro from SD without an issue, you could use that same .img and write it directly to the eMMC, also.

There shouldn't be any major differences in the older/newer PBPs, aside from some cosmetics, like the strength/brittleness of the plastics. I have a PBP from the first and second public batches, and neither shows any difference in how they run OSes.
P.S. which partition would you install the img file to on the PBP eMMC? Thanks! :-)
#7
(06-11-2020, 09:26 AM)rick1959 Wrote: P.S. which partition would you install the img file to on the PBP eMMC? Thanks! :-)

The image contains all the partitions needed, so do not write it to any partition, but the drive itself. ie mmcblk0 not mmcblk0p1
#8
[attachment=1893 Wrote:
.png   Screenshot at 2020-06-11 11-53-46.png (Size: 101.15 KB / Downloads: 270)
.png   Screenshot at 2020-06-11 11-53-46.png (Size: 101.15 KB / Downloads: 270)
.png   Screenshot at 2020-06-11 11-53-46.png (Size: 101.15 KB / Downloads: 270) tophneal pid='68136' dateline='1591881173']
(06-11-2020, 06:59 AM)rick1959 Wrote: Thanks for the suggestion, but it doesn't seem to work. Very odd. 
I'm sure there must be something I'm missing..

This is one of the first hundred  PBP. Wondering if there's something different about this one that is causing an issue?

There has been at least one reported instance where the user couldn't get past the splash screen for ~20-30m. During that time ESC did nothing or cancelled the installer running in the background. After that time elapsed, hitting ESC allowed them to complete installation.

Which eMMC installer are you using, for KDE or XFCE? You might try using the other one.

If you can boot Manjaro from SD without an issue, you could use that same .img and write it directly to the eMMC, also.

There shouldn't be any major differences in the older/newer PBPs, aside from some cosmetics, like the strength/brittleness of the plastics. I have a PBP from the first and second public batches, and neither shows any difference in how they run OSes.
Perfect!! It works!!! :-)
Now, which partition does it get written to? Is it the last one? I included a screenshot....Many Thanks!! :-)
.png   Screenshot at 2020-06-11 11-53-46.png (Size: 101.15 KB / Downloads: 270)

(06-11-2020, 09:28 AM)tophneal Wrote:
(06-11-2020, 09:26 AM)rick1959 Wrote: P.S. which partition would you install the img file to on the PBP eMMC? Thanks! :-)

The image contains all the partitions needed, so do not write it to any partition, but the drive itself. ie mmcblk0 not mmcblk0p1
Sorry I missed this...Many Thanks!! :-)
#9
(06-11-2020, 09:28 AM)tophneal Wrote:
(06-11-2020, 09:26 AM)rick1959 Wrote: P.S. which partition would you install the img file to on the PBP eMMC? Thanks! :-)

The image contains all the partitions needed, so do not write it to any partition, but the drive itself. ie mmcblk0 not mmcblk0p1
Interesting...
There is no mmcblk0....There is mmcblk1 and mmcblk2, one of which is the SD card. And then there are also the choice's for the mmcblk0p1 and mmcblk0p2, which are the wrong choices.
But even if I select the non-SD card choice and hit enter, it takes me to the next page which says "no image available" and a command line prompt......
Maybe I should try XFCE version...?
I'm concerned about bricking the computer....Many Thanks for your time...:-)
#10
(06-11-2020, 11:00 AM)rick1959 Wrote: Interesting...
There is no mmcblk0....There is mmcblk1 and mmcblk2, one of which is the SD card. And then there are also the choice's for the mmcblk0p1 and mmcblk0p2, which are the wrong choices.
But even if I select the non-SD card choice and hit enter, it takes me to the next page which says "no image available" and a command line prompt......
Maybe I should try XFCE version...?
I'm concerned about bricking the computer....Many Thanks for your time...:-)

mmcblk0 was just an example. the numbering of emmc and sd aren't universal across different OSes for the PBP. One OS could show it as mmcblk1, and another will show it as mmcblk0. determine which mmcblk is the drive you want to write to, and then write your downloaded .img to it. If you're writing to your emmc, be sure to download and use a live .img (you wouldn't want to write manjaro's emmc flash img to you emmc.)


Possibly Related Threads…
Thread Author Replies Views Last Post
  Yubikey 5C on manjaro zeb11 0 32 Yesterday, 08:37 AM
Last Post: zeb11
  Is the same DD command appropriate for writing EMMC and SD cards wpeckham 4 147 09-23-2021, 09:19 PM
Last Post: KC9UDX
  postmarketOS/Alpine edge image for the Pinebook Pro MartijnBraam 72 52,877 09-18-2021, 03:58 PM
Last Post: stozi
  Manjaro - Internet connection sharing requires dnsmasq (but the dep isn't declared) Dendrocalamus64 0 124 09-11-2021, 05:25 PM
Last Post: Dendrocalamus64
  Pinebook pro nearly unusable after using manjaro-arm-installer TheCounselor 2 755 09-07-2021, 08:34 PM
Last Post: TRS-80
Question Can't boot any operating system other than Fedora after following the nullr0ute guide TDC_PBP 0 231 08-01-2021, 03:44 PM
Last Post: TDC_PBP
  Working suspend on Manjaro brzegorz 2 539 07-30-2021, 06:21 AM
Last Post: vssz
  Manjaro and Arch repository with privacy oriented software as400 78 48,573 07-28-2021, 05:24 AM
Last Post: llsf
  Manjaro [ARM Stable Update] 2021-07-23 issues Bocanila 0 296 07-24-2021, 09:09 AM
Last Post: Bocanila
  Sound stuttering on Manjaro gnome after latest kernel upgrade? pjsf 0 315 07-13-2021, 10:37 PM
Last Post: pjsf

Forum Jump:


Users browsing this thread: 1 Guest(s)