PBP won’t boot from eMMC after Debian update / Tow-Boot installer won’t boot from SD
I decided to cut my losses and do a fresh install.

I downloaded 'partition.img,gz' and 'firmware.pinebook-pro-rk3399.img.gz' from http://http.us.debian.org/debian/dists/bullseye/main/installer-arm64/current/images/netboot/SD-card-images/ and combined them with

zcat ~/firmware.pinebook-pro-rk3399.img.gz ~/partition.img.gz > ~/complete_image.img

I used Disk Image Writer to write the resulting image to SD.

The PBP/Tow-Boot boots the installer and I get to select Location, Language, Locale and Keyboard. The installer then probes the hardware and reports:

Quote:[!] Detect network hardware

Some of your hardware needs non-free firmware files to operate. The firmware can be loaded from removable media such as a USB stick or floppy. The missing firmware files are:


If you have such media available now, insert it, and continue.
Load missing firmware from removable media? [Yes/No]

Figuring I did something wrong I created a new installation SD but that didn,t solve the issue.

I searched online but couldn't find these files. On my no longer booting SD card with Debian 11 I found 2 brcm directories with the following files:


Notably there is no 'brcmfmac43456-sdio.pine64,pinebook-pro.bin' but there is a .txt file with the same name. I copied all these files to a USB thumb drive (EXT4). Running the installer again and answering 'Yes' to the 'Load missing firmware from removable media? , question only results in the installer repeating the question.

Does anyone have an idea what I might be doing wrong? Huh

Trying to install Armbian 22.02 Focal XFCE from https://www.armbian.com/pinebook-pro/ ended with:

Quote:Support status: no support (unsupported userspace)

I tried 2 older versions from the archive but those ended in a black screen and green power LED similar to my earlier boot issues.

I've depleted my PP battery twice today downloading and extracting images and writing them to SD cards (without using the keyboard battery).   I'm more comfortable with Debian but to see if I can get anything running again on my PBP I will try Manjaro once the battery level is sufficient again..
I have successfully installed Manjaro without any problems and am running it from eMMC now.

I'll mark this issue as solved: Disabling the eMMC allowed Tow-Boot to install from SD. With the right operating system I was then able to boot from both SD and eMMC again.

I will open another thread for my problem installing Debian. Although I really like Manjaro, I am more comfortable with Debian/Ubuntu and because I spend more time travelling than at home I really need full disk encryption. Losing my iPad last week really drove that point home..

Thanks tophneal and wdt for your help!

Possibly Related Threads…
Thread Author Replies Views Last Post
  Manjaro PBP stable update 2022-06-19 bricked wpeckham 2 169 06-30-2022, 10:03 PM
Last Post: wangyukunshan
  install debian on pbp jsch 0 116 06-19-2022, 02:29 AM
Last Post: jsch
  Unable to install Debian Bullseye because of missing wifi firmware Pino64 2 404 05-27-2022, 11:00 PM
Last Post: Pino64
  Broken eMMC boot annahellrothsparent 3 337 04-28-2022, 07:31 AM
Last Post: tophneal
  Fresh Manjaro does not boot from eMMC pentamassiv 6 879 03-27-2022, 11:01 AM
Last Post: xNix
  Dual boot Manjaro and Debian? dieselnutjob 3 510 03-26-2022, 07:17 AM
Last Post: dieselnutjob
  Unsuccessful using danielt's unofficial Debian installer on the PBP joeDoe 1 549 03-25-2022, 08:15 AM
Last Post: danielt
  Installing debian on pinebook pro (deb installer/emmc) ljones 14 3,285 02-08-2022, 02:47 AM
Last Post: Humid Stylus
  [Manjaro] u-boot won't boot from eMMC with (unbootable) SD card present zackw 0 521 01-10-2022, 03:58 PM
Last Post: zackw
  Debian GPU Support Atton 5 3,031 12-02-2021, 05:37 PM
Last Post: cobratbq

Forum Jump:

Users browsing this thread: 1 Guest(s)