Can't find Wifi network
#1
So I'm not really sure what the issue is, but using for example Manjaro seems to work just fine with my Wifi router, although once the regular Debian has been installed (Thompson installer) I can no longer find my network. Its not a problem that the network doesn't work, as I see other networks in the list, its also not an issue of weak signal as I'm fairly close to the router and get high % of signal where I'm at. Does anyone have any clue what the source of the problem could be?
#2
i've been using unofficial debian sid arm64 for quite some time without any wireless issues.

are you switching between two currently active installs and debian doesn't work while manjaro does work? (there shouldn't be any impact between installs)

if this is a confirmed issue then i'd suspect that this is another debian testing package transition issue.

for any wireless issues jump into a tty and try without the gui and see if that changes the experience. "nmcli connect wifi <BSSID> -a"

i'll continue to recommend debian sid arm64 or armhf depending on your use case.
#3
I tried out Manjaro before, but have not got it running anymore. When I had it installed I was using my wifi without problems.

I'm not using the MrFixit Debian (I guess that is the one you are referring to with unofficial?) version but I do recall wifi working with it. I currently have Debian installed via Thompson installer. Had to install it to get FDE working.

Running the command simply gives me:
Error: arugment wifi not understood. Try passing --help instead.

I see nothing about "wifi" under --help
#4
May be a dumb question to ask
but, did you possibly (accidentally) click 'forget this connection' ?
      LINUX = CHOICES
         **BCnAZ**
               Idea
   Donate to $upport
your favorite OS Team
#5
No I have not. Have re-installed debian several times when getting cinnamon to work, and it never showed up :/
#6
OK,
When troubleshooting, I start with the simplest and go from there.
      LINUX = CHOICES
         **BCnAZ**
               Idea
   Donate to $upport
your favorite OS Team
#7
ifconfig,, but probably you haven't installed net-tools,, so
ip a ,, and rfkill list
Maybe the reason for wifi - unrecognized command is the wifi not existing
--edit--
And, for troubleshooting ,, dmesg, and to avoid searching thru 200 lines,
dmesg | grep wlan ,, dmesg |grep -i firm ,, or any other search terms
#8
ip a shows all m devices, lo, enx00e04c360050 and wlan0

dmesg | grep wlan give me no results

gives me:
[ 0.000000] psci: PSCIv1.0 detected in firmware.
[ 4.203171] cdn-dp fec00000.dp: Direct firmware load for rockchip/dptx.bin failed with error -2
[ 4.914993] platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
[ 5.280270] cdn-dp fec00000.dp: Direct firmware load for rockchip/dptx.bin failed with error -2
[ 7.360447] cdn-dp fec00000.dp: Direct firmware load for rockchip/dptx.bin failed with error -2
[ 11.440484] cdn-dp fec00000.dp: Direct firmware load for rockchip/dptx.bin failed with error -2
[ 15.510790] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4345/9 wl0: Jun 16 2017 12:38:26 version 7.45.96.2 (66c4e21@sh-git) ® FWID 01-1813af84
[ 15.732759] r8152 2-1.1:1.0: skip request firmware
[ 16.531441] ARM_SMCCC_ARCH_WORKAROUND_1 missing from firmware
[ 270.183438] r8152 2-1.1:1.0: skip request firmware
[ 271.533573] r8152 2-1.1:1.0: skip request firmware

I installed wavemon, and walked around with the PBP in my house. Pickup about 5-7 different networks from nearby buildings (but still not my own).

My phone is connected to the Wifi router and it currently has where I'm at with the PBP, full coverage. Walked around with it inside the house, and there is nowhere I get less than 2 bars coverage from my wifi router with the phone.
#9
Perhaps the metal case of the PBP is blocking the rf signal. ?
Wonder if it would make any difference if you turned the screen in the direction facing the router ?

Just asking... ?
      LINUX = CHOICES
         **BCnAZ**
               Idea
   Donate to $upport
your favorite OS Team
#10
sudo iwlist scan |grep ESSID (|grep your-ssid)


Possibly Related Threads…
Thread Author Replies Views Last Post
  Wifi Troubles IDEFK 17 1,257 05-24-2021, 05:03 AM
Last Post: walterbe
  Pinebook pro poor performance on 5Ghz WiFi Iolaum 10 4,159 05-23-2021, 04:35 AM
Last Post: Ralim
  Network connection question??? davehetfield 1 395 03-11-2021, 07:31 AM
Last Post: tkudog
  No WIFI network discovery in any manjaro installation (but works on fedora) pineitup 1 509 02-05-2021, 09:10 AM
Last Post: BlueJayLinux
  Wifi very slow on PBP Manjaro? WeaseleyRon 2 575 01-21-2021, 10:21 AM
Last Post: moonwalkers
  is it possible to get wifi monitor mode on the pbp? BananaPekan 0 385 01-17-2021, 01:50 PM
Last Post: BananaPekan
  Wifi stopped working after updates pineitup 10 2,997 11-07-2020, 02:59 AM
Last Post: wdt
  Wifi very slow on PBP Manjaro motezart 3 1,202 10-13-2020, 07:30 PM
Last Post: wdt
  Trouble connecting to my home wifi bastafari 10 2,873 09-27-2020, 06:37 PM
Last Post: bastafari
  Pinebook Pro won't connect to wifi Samuel Venable 4 1,573 09-22-2020, 12:26 AM
Last Post: bcnaz

Forum Jump:


Users browsing this thread: 1 Guest(s)