Kali Linux for Pinebook Pro
#21
Think they mixed up some stuff.

Kali 2020.1a has a bug fix for x11. PBP version seems to be 2020.1 without the patch. After updates mine broke with the same x11 bug. As WDT suggested it's still using the older user/pass.
Im re-writing my SD at the moment. When it's done I'm looking into this: https://bugs.kali.org/view.php?id=6053

[Edit] Just installed "xserver-xorg-input-all" but kali-menu seems to be broken? Il'l try apt-get upgrade and reboot Smile
  Reply
#22
@Tazdevl
>but kali-menu seems to be broken
Yes indeed,, complains about a missing directory, which does not exist
So, 1st thing, install something simple*, notice error msg,,, mkdir /usr/share/........
I don't know if this is good enough, but at least shuts up error msg
(*like perhaps "ne", will not install anything else)
--edit--
All the fs errors were from resize2fs, nothing to do with kali
purge kali-undercover,, an update locks computer, repeatedly
Had to remove from status to finish update
  Reply
#23
Did the folder fix but no real progress here, updates don't work. It hangs on kali-undercover

[edit] slow on waking up... I'll try removing undercover
[edit1 ]sudo dpkg --remove --force-remove-reinstreq kali-undercover helps a lot. But ffs, how many times can you write dpkg wrong?
  Reply
#24
Looks like 2020.2 version is available. I am still waiting for my pro machine. Can someone report how it works and if any issues?

https://www.offensive-security.com/kali-...rm-images/

https://www.kali.org/news/kali-linux-2020-2-release/
  Reply
#25
I have it running on a micro SD.
Now you have to login with kali/kali.
Audio is working (didn't work with root in the previous version).

First time it still booted Manjaro from the eMMC, but after a restart it booted up.
  Reply
#26
(05-13-2020, 05:22 AM)jiyong Wrote: I have it running on a micro SD.
Now you have to login with kali/kali.
Audio is working (didn't work with root in the previous version).

First time it still booted Manjaro from the eMMC, but after a restart it booted up.

Hi all,

I have it running on a micro SD and I have tried to write the image on the emmc but it looks like I have done something wrong. Should I try with the dd command with unmounted emmc? I send you a screenshot showing fdisk -l info.
I an a newbie with Kali Linux but I am trying to learn.

Thanks, happy and healthy hacking!
Ricardo


Attached Files
.png   Screenshot_2020-05-15_13-47-31.png (Size: 67.7 KB / Downloads: 148)
  Reply
#27
(05-15-2020, 07:50 AM)ricardo1934 Wrote:
(05-13-2020, 05:22 AM)jiyong Wrote: I have it running on a micro SD.
Now you have to login with kali/kali.
Audio is working (didn't work with root in the previous version).

First time it still booted Manjaro from the eMMC, but after a restart it booted up.

Hi all,

I have it running on a micro SD and I have tried to write the image on the emmc but it looks like I have done something wrong. Should I try with the dd command with unmounted emmc? I send you a screenshot showing fdisk -l info.
I an a newbie with Kali Linux but I am trying to learn.

Thanks, happy and healthy hacking!
Ricardo
You need to edit the /etc/default/u-boot and /boot/extlinux.conf to match the emmc.
My recommendation is to use UUIDs instead device names.

Enviado desde mi ONEPLUS A5010 mediante Tapatalk
  Reply
#28
(05-15-2020, 10:30 AM)e-minguez Wrote:
(05-15-2020, 07:50 AM)ricardo1934 Wrote:
(05-13-2020, 05:22 AM)jiyong Wrote: I have it running on a micro SD.
Now you have to login with kali/kali.
Audio is working (didn't work with root in the previous version).

First time it still booted Manjaro from the eMMC, but after a restart it booted up.

Hi all,

I have it running on a micro SD and I have tried to write the image on the emmc but it looks like I have done something wrong. Should I try with the dd command with unmounted emmc? I send you a screenshot showing fdisk -l info.
I an a newbie with Kali Linux but I am trying to learn.

Thanks, happy and healthy hacking!
Ricardo
You need to edit the /etc/default/u-boot and /boot/extlinux.conf to match the emmc.
My recommendation is to use UUIDs instead device names.

Enviado desde mi ONEPLUS A5010 mediante Tapatalk

Hi Miguel,

thanks for the information. I will try to find the way to make this changes.

Happy and healthy hacking!
PS: Miguel, parece que tu tambien eres castellanoparlante. Un saludo desde Alemania!

Ricardo
  Reply
#29
(05-15-2020, 11:58 AM)ricardo1934 Wrote:
(05-15-2020, 10:30 AM)e-minguez Wrote:
(05-15-2020, 07:50 AM)ricardo1934 Wrote:
(05-13-2020, 05:22 AM)jiyong Wrote: I have it running on a micro SD.
Now you have to login with kali/kali.
Audio is working (didn't work with root in the previous version).

First time it still booted Manjaro from the eMMC, but after a restart it booted up.

Hi all,

I have it running on a micro SD and I have tried to write the image on the emmc but it looks like I have done something wrong. Should I try with the dd command with unmounted emmc? I send you a screenshot showing fdisk -l info.
I an a newbie with Kali Linux but I am trying to learn.

Thanks, happy and healthy hacking!
Ricardo
You need to edit the /etc/default/u-boot and /boot/extlinux.conf to match the emmc.
My recommendation is to use UUIDs instead device names.

Enviado desde mi ONEPLUS A5010 mediante Tapatalk

Hi Miguel,

thanks for the information. I will try to find the way to make this changes.

Happy and healthy hacking!
PS: Miguel, parece que tu tambien eres castellanoparlante. Un saludo desde Alemania!

Ricardo

https://gitlab.com/kalilinux/build-scrip...issues/180

Basically read that issue for instructions.

(En realidad me llamo Edu! Saludos desde España Big Grin)

Enviado desde mi ONEPLUS A5010 mediante Tapatalk
  Reply
#30
Hi again,

I will give it a try.

Los pseudonimos son una buena idea en la red!

Acabo de ver que no es un pseudonimo, sino que las prisas me hicieron convertir tu apellido en nombre y ademas leerlo mal :-P

Hi again,

I have tried this but i have no output from command blkid/dev/mmcbl2p2

I will continue searching. I have forgotten to tell that I was able to boot from the emmc but then I had no network a was not able to activate it.

Best regards
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  An unofficial Debian Installer for Pinebook Pro danielt 422 150,239 02-23-2021, 09:23 AM
Last Post: Tharadash
  postmarketOS/Alpine edge image for the Pinebook Pro MartijnBraam 62 30,841 02-14-2021, 12:25 PM
Last Post: pmjohann
  OpenMandriva to release ARM builds for PineBook Pro and Pi ludix 6 698 02-13-2021, 04:03 PM
Last Post: ludix
  Kali Linux password fail Wawe 4 239 02-09-2021, 01:38 PM
Last Post: barray
  Pinebook Pro wifi not working seyo-iv 1 176 02-01-2021, 11:00 AM
Last Post: seyo-iv
  slarm64 (unofficial slackware) Pinebook Pro RK3399 (aarch64) mara 25 3,466 01-30-2021, 11:03 AM
Last Post: mara
  FLOSS pinebook pro linux set-up misha64 3 1,079 01-14-2021, 04:05 PM
Last Post: kuleszdl
  My Debian journey on the Pinebook Pro schwarzwieweiss 32 3,754 01-07-2021, 09:35 AM
Last Post: schwarzwieweiss
  Armbian for the Pinebook Pro [WIP] Luke 41 13,923 01-06-2021, 06:14 PM
Last Post: Idaho
  Gentoo on Pinebook Pro RELEASE jannik2099 48 28,188 01-03-2021, 06:21 AM
Last Post: wdt

Forum Jump:


Users browsing this thread: 2 Guest(s)