Bionic image boot from SD
#1
I flashed Bionic onto the eMMC and now SD boot is no longer working.  I think the uboot is the issue, but I do not know how to go about fixing it.  Ideas?
  Reply
#2
(01-16-2020, 02:45 AM)mamboman777 Wrote: I flashed Bionic onto the eMMC and now SD boot is no longer working.  I think the uboot is the issue, but I do not know how to go about fixing it.  Ideas?

Hey assuming you're folowing this guide: https://forum.pine64.org/showthread.php?tid=8119

Sounds like you needed step 6..



6. Now you have Ubuntu installed on eMMC and you can also boot from SD card, but only the same operating system. If we need also to boot other operating systems, we need to apply uboot fix. So download all the files from here https://github.com/mrfixit2001/updates_r...filesystem and run the mrfixit_update.sh script while running from eMMC. From now on you should be able to boot also other OS from SD like before.

----

Download those files and run the script and then it starts working.e
  Reply
#3
(01-16-2020, 06:34 AM)pete Wrote:
(01-16-2020, 02:45 AM)mamboman777 Wrote: I flashed Bionic onto the eMMC and now SD boot is no longer working.  I think the uboot is the issue, but I do not know how to go about fixing it.  Ideas?

Hey assuming you're folowing this guide: https://forum.pine64.org/showthread.php?tid=8119

Sounds like you needed step 6..



6. Now you have Ubuntu installed on eMMC and you can also boot from SD card, but only the same operating system. If we need also to boot other operating systems, we need to apply uboot fix. So download all the files from here https://github.com/mrfixit2001/updates_r...filesystem and run the mrfixit_update.sh script while running from eMMC. From now on you should be able to boot also other OS from SD like before.

----

Download those files and run the script and then it starts working.e

I did try that, but not from the director /usr/bin  I remember reading somewhere that I need to run it from /usr/bin, so I'll give that a shot and let you know.

Ok....I must be doing something wrong with the mr fixit update. I had the same result. any other ideas to try?
  Reply
#4
You shouldn't have to run that script from any particular location. You only need to download it to your drive, along with the 3 u-boot .img files in that repo folder, to the same folder. Then, go to that folder in terminal/tty, and run the script.
  Reply
#5
It looks like the script is running. I'm getting:
Identified /dev/mmcblk1 as device to flash uboot to...
upgrading idbloader.img...
upgrading uboot.img...
upgrading trust.img...

That being said for some reason it looks like I have 5 partitions before the boot partition on my eMMC. Maybe I should try deleting those partitions?

I'm afraid to brick it since I can't boot from the SD. I've got an eMMC -> USB adapter in the mail. If I completely remove the eMMC would the SD boot function again?
  Reply
#6
Does it go back to normal prompt after "upgrading trust.img..."? If so, you should now be able to reboot into an SD. I had similar issues/confusion when I first used a modified version of that script to run on Chromium. It wouldn't indicate it finished with success, but it did.
  Reply
#7
I do not know what I did differently this time, but it seems to have worked! Thanks for your help! :-)
  Reply
#8
Awesome! Now go boot those SDs! ;P
  Reply
#9
(01-16-2020, 08:25 AM)tophneal Wrote: Awesome! Now go boot those SDs! ;P

Now I'm waiting on my Intel 660p NVMe to arrive.  When it comes in I'll be trying to put /root/ on the NVME, but it's good to know that I now have a back up plan if things do not go as planned.  :-)
  Reply
#10
Nice Wink Glad it's working again!
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Unable to boot: blinking red light houki 3 129 Yesterday, 04:45 AM
Last Post: houki
  Flashing image to EMMC Styles 12 380 01-17-2020, 08:48 AM
Last Post: tophneal
  Changed the bootsplash image - Kernel messages still showing Twix166 7 281 01-16-2020, 05:51 PM
Last Post: Arwen
  U-Boot with direct NVMe boot support for eMMC/SPI Flash pcm720 55 4,991 01-14-2020, 07:36 AM
Last Post: Arwen
  Can I boot system from nvme SSD? plumlis 6 503 01-12-2020, 04:47 PM
Last Post: bcnaz
  U-Boot on SPI flash - discussion Arwen 19 859 01-07-2020, 04:28 AM
Last Post: aaspectre
  Command line flashing script with media verification, xz image support Arglebargle 2 465 12-19-2019, 09:25 PM
Last Post: Arglebargle
  PIneBook Pro - Boot from SD mcdomx 9 1,076 12-19-2019, 12:43 PM
Last Post: tophneal
  Cannot boot up after hours off tsago 5 332 12-12-2019, 01:35 PM
Last Post: Solra Bizna
  Help - PineBook Pro won't boot! ThisGeekTweets 5 422 11-20-2019, 05:50 PM
Last Post: zaius

Forum Jump:


Users browsing this thread: 1 Guest(s)