Installing Printer
#1
Hi. Received my new Pine64 Pro a few days ago and very happy with it buuuuuuut!

I installed Brother 2130 Laser Printer drivers from the Brother website after installing CUPS.

Nothing prints to the printer and only rubbish via PDF, it all looks good except the results.
http://localhost:631/printers/HL2130  shows everything OK.

Any help please?
I'm a bit of a newbie so if via terminal I details please. Sad
TIA
  Reply
#2
I also tried to install my printer (Canon) but was unsuccessful because it requires drivers that are meant (compiled?) for arm architecture. The drivers on the Brother website are probably not meant for arm architecture. Did you download drivers specifically for arm architecture?
  Reply
#3
If you dig down to the bottom, after 3 layers of scripts, you will find i386-elf (filter driver)
This, of course, will never work on arm (and there are NO arm filter drivers, unless you compile)
Read my post,,, CUPS, 50%,, about 2 weeks ago
In short, using stretch, mtfixit, cups is too old for airprint, don't waste your time, you will not succeed
--edit--
Not strictly true, when airprint is successfully setup, there are scads of aarch64 binaries in /lib/cups/....
Ordinarily, from the brother website, it will be assumed x86, the deb or rpm will install to /opt/brother/....
There are NO aarch64 drivers on their website, all aarch64 come with a airprint-driverless install*
Even works (airprint) with a rk3328 TV box, prints OK, if 3 requirements are met
(printer not too old, cups 2.2.4 or newer, networked,, the last can be worked around)
*I am guessing, from what "file" tells me, that they are "sucked" off the printer by avahi
Search,,,,, debian airprint AND debian driverless
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Installing Brother printer drivers on Manjaro dhosh 4 97 02-24-2020, 09:47 AM
Last Post: wdt
  Running into problems while installing RStudio from sources FingO 0 54 02-01-2020, 07:05 AM
Last Post: FingO
  Bootloop after installing an ARM 32-bit program Soul_Hacker 0 62 01-23-2020, 10:54 AM
Last Post: Soul_Hacker
  No POWER after installing Manjaro on microsd cocozozo 1 196 12-14-2019, 02:21 AM
Last Post: cocozozo

Forum Jump:


Users browsing this thread: 1 Guest(s)