An unofficial Debian Installer for Pinebook Pro
Thank you all for volunteering your time and effort to make this experience.  Recently my PBP ANSI arrived and I wanted to report on my experience using this installer.  I look forward to using this as my daily driver, though before that happens I am interested in helping test or develop.  Reading over the thread the list of actionables seems a bit scattered right now.

All installs were made after running the update script in the stock image.  Additionally I've applied the recent keyboard firmware upgrade from https://forum.pine64.org/announcements.php?aid=23 .  I am not attempting to connect any keyboard, monitor or other peripherals, it is just the PBP with power plugged into the wall.

I believe the installer version used in all cases is git sha f77e28744525cd0f7063ecac06eda4d6cdd526f3

My first attempt was installing to a 8GB U1 microSD I had laying around.  No LUKS, though I intended to later use this install to set LUKS up in a second install on the internal storage.  In tasksel I opted for the gnome 3 desktop, ssh server and laptop options (105 keyboard, the three en_US locales, default locale en_US UTF).  debootstrap ran successfully, but the produced image would not boot.  Instead I saw something that sounds like #85: a blank black screen with a simple cursor sporadically appearing in the upper left hand corner.  I attempted to reach other gettys with F1-F6 and various modifier keys but never could.

My next attempts used a different 16GB U1 microSD that I believe came out of a beaglebone black.  This worked.  There were a few iterations here in which I initially started with what I thought would be a bare/conservative configuration and progressively stepped back towards the one used in attempt #1.  All of them worked, and eventually I was looking at a live gnome 3.  After confirming the ram footprint I did one more cycle and switched to MATE.

Attempting to run firefox ESR revealed the "illegal instruction" error that others have described.  I attempted to switch to epiphany, but could never get it to render a page.  Firefox in buster backports had the same illegal instruction issue.  Finally (in a new, clean install) I enabled armhf and used it to install FF, similar to #3 :

Code:
$ sudo apt remove firefox-esr
$ sudo dpkg --add-architecture armhf
$ sudo apt update
$ sudo apt install firefox-esr:armhf

Since I didn't keep epiphany as in #3, these commands indeed turned over a lot of packages, but seemingly without harm.  This firefox runs and seems snappy, I am typing this post on it now.  Installing armhf firefox in this way did not require any changes to the installer or the ARCH variable.

At this point my experience was similar to #39 in a few ways.  The screen brightness up/down buttons did not work for me, but I was able to reproduce the solution there with
 a small twist.  My udev file looks like this:

Code:
$ cat /etc/udev/hwdb.d/10-usb-kbd.hwdb
evdev:input:b0003v258Ap001E*
KEYBOARD_KEY_700a5=brightnessdown
KEYBOARD_KEY_700a6=brightnessup

# KEYBOARD_KEY_70066=sleep
$ sudo udevadm hwdb --update

For those unfamiliar with the file format, there are leading spaces before the KEYBOARD_KEY lines that are important, which the code block here is suppressing.  I also alerted udev to the changes with the udevadm command mentioned above.  It seems that something (MATE?) already has something at the "sleep" keybinding, and so it is omitted here.  If it is included then both handlers (sleeping, and presenting a shutdown dialog that turns the machine off after 60 seconds) are run.

I have also had some trouble resuming from sleep, with the machine instead simply rebooting and losing my session.  So far it has happened perhaps three times.  In all cases the machine was plugged into the wall, and the lid was closed for 10 minutes or more.  When opening the lid, the power LED is green but the screen is blank; only after holding power until the LED dimmed and turning it on again was I able to get normal functionality.

I did not test plugging anything in to the 3.5'' audio jack.  Finally when starting up, I hear two small pops from the speakers (as if power was abruptly cut and applied), perhaps 5 seconds apart.  Perhaps this is the mentioned "annoying quiet noise".

At this point I have not yet tried pointing the installer at the internal storage (since it seems I'm going to leave gnome 3 behind and am now shopping around for DMs.)

The trackpad seems a bit sensitive, and will move my cursor if accidentally brushed even while quickly typing.

I have not yet tried any bluetooth functionality.

I have not yet tried any video acceleration functionality.

I see "Direct firmware load for rockchip/dptx.bin failed with error -2" lines in my dmesg; I have not attempted any of the described fixes.


Messages In This Thread
RE: An unofficial Debian Installer for Pinebook Pro - by phs - 01-20-2020, 04:05 PM
First boot - by JaredT66 - 05-19-2020, 09:49 AM
RE: First boot - by carletes - 05-19-2020, 01:35 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Official Debian support moonwalkers 64 56,459 07-08-2024, 01:40 PM
Last Post: Humid Stylus
  [Pinebook Pro/Mobian/XFCE4] can fix touch or screen in greeter not both SynthGal 0 178 05-31-2024, 09:42 AM
Last Post: SynthGal
  Debian on Pinebook Pro u974615 7 1,981 03-31-2024, 10:11 AM
Last Post: u974615
  Pinebook Pro upgrading from the factory image yamsoup 12 2,752 02-22-2024, 04:02 PM
Last Post: tllim
  Help installing Manjaro on eMMC of Pinebook Pro pine4546464 4 2,625 12-13-2023, 07:22 PM
Last Post: trillobite
  Need Help Recovering Manjaro /boot Contents on Pinebook Pro calinb 6 2,805 12-11-2023, 03:47 AM
Last Post: calinb
  Gentoo on Pinebook Pro RELEASE jannik2099 54 94,384 12-08-2023, 11:25 PM
Last Post: tllim
  Boot Order in Pinebook Pro food 8 1,908 11-23-2023, 07:37 AM
Last Post: KC9UDX
  install debian on pbp jsch 7 4,578 11-22-2023, 04:22 PM
Last Post: TRS-80
  How to mainline kernel on daniel thompson's debian installer? hellojack 14 8,411 09-07-2023, 09:38 PM
Last Post: Der Geist der Maschine

Forum Jump:


Users browsing this thread: 1 Guest(s)