PIneBook Pro - Boot from SD
#1
I have a new PineBook Pro, and simply want to boot from an SD image.   I've carefully followed the instructions to create a Bionic LXDE Community Build using Etcher on my Mac.  From what I have been able to understand, all I need to do is insert the formatted card into the PineBook and power on in order to boot to the SD, but it won't.  Instead, the PineBook always boots to the default OS that was delivered with the device.  

I am totally stuck.  I've looked through the forums and tried various images with the same result.

I've reviewed the common issues posted by 'Ghost' and none apply to my environment.  

Is there some kind of boot sequence key combination that I need to press to boot using the image on the SD card? 

Any guidance is appreciated.  Thank you!  

  Reply
#2
Have you fully updated the default OS, yet?
  Reply
#3
(11-10-2019, 06:23 PM)tophneal Wrote: Have you fully updated the default OS, yet?

Nope. I’ll look into it and try. Thank you!
  Reply
#4
To be more explicit -- there's an update button in the tray next to the clock on the default debian desktop. Click/run that, it calls a separate script that'll pull down updates not included in packages.
  Reply
#5
Thanks for the tips.  I updated via the command line because I don't have an 'update' icon in my tray.  (sudo apt update; sudo apt upgrade).  Still not booting from MicroSD.  The SD card is mounting with  "boot" and "linux-root" drives, so I know the card is seen and recognized.  It just doesn't seem to be selected as the boot source.  I am out of ideas on how to resolve this.

Again, thank you for your replies!
  Reply
#6
(11-12-2019, 09:07 AM)mcdomx Wrote: Thanks for the tips.  I updated via the command line because I don't have an 'update' icon in my tray.  (sudo apt update; sudo apt upgrade).  Still not booting from MicroSD.  The SD card is mounting with  "boot" and "linux-root" drives, so I know the card is seen and recognized.  It just doesn't seem to be selected as the boot source.  I am out of ideas on how to resolve this.

Again, thank you for your replies!

You might need to manually update your uboot. I'll see if I can dig up on of the links/posts already up.

Per Wizzard:


Quote:If we need also to boot other operating systems, we need to apply uboot fix. So download all the files from here https://github.com/mrfixit2001/updates_r...filesystem and run the mrfixit_update.sh script while running from eMMC.
  Reply
#7
Hello,

I had this boot issue last weekend as well. PBP was always booting from the eMMC.
This changed with running the fixit script from /usr/bin/. Please try this at first.

Next problem was that I didn't know, how to write a new image to eMMC. From the
Pinebook I know hat there were special sd card images which do this when booting from sd card.
Finally I booted from sd card and wrote the new image via dd to eMMC. This works fine for me.

Regards, Ansgar
  Reply
#8
Thank you all for your input! Using the MrFix it script worked! I am up-and-running! For anyone stumbling on this post with the same issue, the solution is to update the image you're received. I did this by cloning the git repo:

https://github.com/mrfixit2001/updates_repo/tree/v1.1

and running the "mrfixit_update.sh" script.

After that, everything worked as I expected and I was able to boot from the sdcard.
  Reply
#9
(11-13-2019, 04:44 AM)mcdomx Wrote: Thank you all for your input!  Using the MrFix it script worked!  I am up-and-running!  For anyone stumbling on this post with the same issue, the solution is to update the image you're received.  I did this by cloning the git repo:

https://github.com/mrfixit2001/updates_repo/tree/v1.1

and running the "mrfixit_update.sh" script.

After that, everything worked as I expected and I was able to boot from the sdcard.

which image did you pick? any of these: https://wiki.pine64.org/index.php/Pinebo..._Downloads

or would I expect the images for the original pinebook to work on the pro as well from here:
https://wiki.pine64.org/index.php/Pinebo...re_Release
  Reply
#10
(12-19-2019, 12:34 PM)zeusz Wrote:
(11-13-2019, 04:44 AM)mcdomx Wrote: Thank you all for your input!  Using the MrFix it script worked!  I am up-and-running!  For anyone stumbling on this post with the same issue, the solution is to update the image you're received.  I did this by cloning the git repo:

https://github.com/mrfixit2001/updates_repo/tree/v1.1

and running the "mrfixit_update.sh" script.

After that, everything worked as I expected and I was able to boot from the sdcard.

which image did you pick? any of these: https://wiki.pine64.org/index.php/Pinebo..._Downloads

or would I expect the images for the original pinebook to work on the pro as well from here:
https://wiki.pine64.org/index.php/Pinebo...re_Release

The images for the original Pinebook will not work for the Pinebook Pro. You may have luck with some images for the RockPro64, though, since it shares the same "guts" as the PBP.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
Question High Pitch Noise Coming From Pinebook Pro Feakster 45 6,099 3 hours ago
Last Post: ratel
  U-Boot with direct NVMe boot support for eMMC/SPI Flash pcm720 107 18,858 6 hours ago
Last Post: as400
Rainbow What did you name your Pinebook Pro? diodelass 35 1,928 Yesterday, 08:46 PM
Last Post: MtnSk8
  Games compilation howto on the Pinebook-pro (Manjaro Linux and Debian native) astr0baby 161 24,587 Yesterday, 12:57 PM
Last Post: Opvolger
  PineBook Pro new model? zxorg 11 889 Yesterday, 10:24 AM
Last Post: zxorg
  OBS Studio or alternative on Pinebook Pro? charlespine 3 109 Yesterday, 06:17 AM
Last Post: jiyong
  Pinebook Pro sleep issue (hinge?) pciman 1 124 Yesterday, 12:48 AM
Last Post: MtnSk8
  Orange light won't boot>>>PineBook Pro user1gokou 4 119 07-10-2020, 03:04 PM
Last Post: KC9UDX
  Pinebook Pro availability. MHT719 5 334 07-07-2020, 09:43 PM
Last Post: GeoIratus
Shocked PineBook Pro Powering Down Instead of sleeping conor.murphy99 3 207 07-07-2020, 04:09 PM
Last Post: xmixahlx

Forum Jump:


Users browsing this thread: 1 Guest(s)