PCI Express x4 Device Support
#1
Is there any chance either of these would work?

LSI Logic 9211-4i SAS RAID Controller

or 

Intel EXPI9404PTL PRO/1000 PT Quad Port
#2
Sorry, I should have posted my progress on these boards earlier.
 
I have two variations of the LSI Logic 9211-4i SAS RAID Controller working in two systems with Rockpro64's. 
 
One is the stock LSI 3/4 length board which is available on Amazon, eBay, etc.  This is a 4x board with a SAS connector out.

https://www.amazon.com/LSI-Logic-9211-4i...B005UO2I4M

I'm using this board's SAS out port to the SAS in on an Intel RES2SV240 RAID 24 port SAS Expander Card.  

https://www.ebay.com/itm/153474385994?it...fresh=true  

From the expander I can address up to 20 sata drives or more SAS expanders.  I have this working in IT mode with Ayufan's recent (last month) Openmedia vault build. Thank you - Ayufan.  This is running in a re-claimed mini tower case with the re-claimed 300 watt power supply. I have tested and accessed twelve (12) drives through Linux and OpenMedia Vault with this build.
 
The second system is using a 1/2 length variation from Crossfield - same LSI 9211-4i chipset re-designed for 1/2 length.

https://www.ebay.com/itm/New-LSI-9211-4i...4902.l9144
 
I have this in a custom 4 drive NAS enclosure using 3d printed & MakerBeam components
.jpg   20190813_212245.jpg (Size: 202.96 KB / Downloads: 494)  also running Ayufan's Openmedia vault in IT mode. Thanks again - Ayufan. It is running off an external power supply (Meanwell 160w) to a matching internal pico-power supply. That cleans up and distributes sufficient power to the drives, boards and fans while being ~90% efficient so the system idles around 22watts.  All these boards, 9211, SAS Expander, & RockPro have heatsinks that require air flow to be effective.  I have two in push-pull on the NAS and a couple in the mini-tower.


Both cards booted directly with the Openmedia vault builds. There are "oh-by-the-ways" however which are probably a function of my super-limited linux knowledge.  

While these versions of Linux recognize and effectively support the boards, I cannot get any version of the SAS2Flash, SAS2IRCU or LSIUtil to run from the command line.  MPT3SAS and MPT2SAS (drivers?) both load at bootup but I can't re-flash the boards while installed in the RockPro64 nor can I load any BIOS/firmware app to configure the boards in IR (integrated Raid) mode.  IT mode is working fine with OpenMedia vault but I would like to benchmark and experiment with the IR mode.  
 
Any suggestions or workarounds would be appreciated.
#3
Have you had any further success with these cards?  I too was looking to use them in the NAS Enclosure for a Ceph on arm64 build using Ayufan's buster image.  

-Nate
(09-19-2019, 09:33 AM)iops/watt Wrote: Sorry, I should have posted my progress on these boards earlier.
 
I have two variations of the LSI Logic 9211-4i SAS RAID Controller working in two systems with Rockpro64's. 
 
One is the stock LSI 3/4 length board which is available on Amazon, eBay, etc.  This is a 4x board with a SAS connector out.

https://www.amazon.com/LSI-Logic-9211-4i...B005UO2I4M

I'm using this board's SAS out port to the SAS in on an Intel RES2SV240 RAID 24 port SAS Expander Card.  

https://www.ebay.com/itm/153474385994?it...fresh=true  

From the expander I can address up to 20 sata drives or more SAS expanders.  I have this working in IT mode with Ayufan's recent (last month) Openmedia vault build. Thank you - Ayufan.  This is running in a re-claimed mini tower case with the re-claimed 300 watt power supply. I have tested and accessed twelve (12) drives through Linux and OpenMedia Vault with this build.
 
The second system is using a 1/2 length variation from Crossfield - same LSI 9211-4i chipset re-designed for 1/2 length.

https://www.ebay.com/itm/New-LSI-9211-4i...4902.l9144
 
I have this in a custom 4 drive NAS enclosure using 3d printed & MakerBeam components  also running Ayufan's Openmedia vault in IT mode. Thanks again - Ayufan. It is running off an external power supply (Meanwell 160w) to a matching internal pico-power supply. That cleans up and distributes sufficient power to the drives, boards and fans while being ~90% efficient so the system idles around 22watts.  All these boards, 9211, SAS Expander, & RockPro have heatsinks that require air flow to be effective.  I have two in push-pull on the NAS and a couple in the mini-tower.

Both cards booted directly with the Openmedia vault builds. There are "oh-by-the-ways" however which are probably a function of my super-limited linux knowledge.  

While these versions of Linux recognize and effectively support the boards, I cannot get any version of the SAS2Flash, SAS2IRCU or LSIUtil to run from the command line.  MPT3SAS and MPT2SAS (drivers?) both load at bootup but I can't re-flash the boards while installed in the RockPro64 nor can I load any BIOS/firmware app to configure the boards in IR (integrated Raid) mode.  IT mode is working fine with OpenMedia vault but I would like to benchmark and experiment with the IR mode.  
 
Any suggestions or workarounds would be appreciated.
#4
(07-07-2020, 10:26 PM)revoman Wrote: Have you had any further success with these cards?  I too was looking to use them in the NAS Enclosure for a Ceph on arm64 build using Ayufan's buster image.  

-Nate
(09-19-2019, 09:33 AM)iops/watt Wrote: Sorry, I should have posted my progress on these boards earlier.
 
I have two variations of the LSI Logic 9211-4i SAS RAID Controller working in two systems with Rockpro64's. 
 
One is the stock LSI 3/4 length board which is available on Amazon, eBay, etc.  This is a 4x board with a SAS connector out.

https://www.amazon.com/LSI-Logic-9211-4i...B005UO2I4M

I'm using this board's SAS out port to the SAS in on an Intel RES2SV240 RAID 24 port SAS Expander Card.  

https://www.ebay.com/itm/153474385994?it...fresh=true  

From the expander I can address up to 20 sata drives or more SAS expanders.  I have this working in IT mode with Ayufan's recent (last month) Openmedia vault build. Thank you - Ayufan.  This is running in a re-claimed mini tower case with the re-claimed 300 watt power supply. I have tested and accessed twelve (12) drives through Linux and OpenMedia Vault with this build.
 
The second system is using a 1/2 length variation from Crossfield - same LSI 9211-4i chipset re-designed for 1/2 length.

https://www.ebay.com/itm/New-LSI-9211-4i...4902.l9144
 
I have this in a custom 4 drive NAS enclosure using 3d printed & MakerBeam components  also running Ayufan's Openmedia vault in IT mode. Thanks again - Ayufan. It is running off an external power supply (Meanwell 160w) to a matching internal pico-power supply. That cleans up and distributes sufficient power to the drives, boards and fans while being ~90% efficient so the system idles around 22watts.  All these boards, 9211, SAS Expander, & RockPro have heatsinks that require air flow to be effective.  I have two in push-pull on the NAS and a couple in the mini-tower.

Both cards booted directly with the Openmedia vault builds. There are "oh-by-the-ways" however which are probably a function of my super-limited linux knowledge.  

While these versions of Linux recognize and effectively support the boards, I cannot get any version of the SAS2Flash, SAS2IRCU or LSIUtil to run from the command line.  MPT3SAS and MPT2SAS (drivers?) both load at bootup but I can't re-flash the boards while installed in the RockPro64 nor can I load any BIOS/firmware app to configure the boards in IR (integrated Raid) mode.  IT mode is working fine with OpenMedia vault but I would like to benchmark and experiment with the IR mode.  
 
Any suggestions or workarounds would be appreciated.

I recently got a rockpro64 with an LSI 9211-8i. I got the card working with ayufan's 5.6 kernel minimal debian build; but u-boot doesn't have drivers for SAS cards so you'll need eMMC or an SD card to store a /boot partition if you want to run root on a device off the card. If this is your goal, you should have few if any problems but have a serial cable handy.

I couldn't get the card to boot with Arch or Manjaro (~5.7 kernel) which is my preferred environment. The boot process and serial console seems to hang once u-boot tries to load the kernel. Many u-boot builds floating around crash when trying to query the card. I gave up and ordered a SATA card (JMB585 chipset) which works well with u-boot and the Arch kernel. I'm now happily booting off an SSD with an HDD array running my NAS workloads.
#5
(09-19-2019, 09:33 AM)iops/watt Wrote: While these versions of Linux recognize and effectively support the boards, I cannot get any version of the SAS2Flash, SAS2IRCU or LSIUtil to run from the command line.  MPT3SAS and MPT2SAS (drivers?) both load at bootup but I can't re-flash the boards while installed in the RockPro64 nor can I load any BIOS/firmware app to configure the boards in IR (integrated Raid) mode.  IT mode is working fine with OpenMedia vault but I would like to benchmark and experiment with the IR mode.  
 
Any suggestions or workarounds would be appreciated.

From the looks of things SAS2Flash and SAS2IRCU both require *native* EFI firmware support.
While it is possible to get U-Boot to emulate EFI for the purpose of booting Linux, it doesn't support the low level functions those programs need to run.
It may be possible to get it to run on an enterprise ARM64 board that has native EFI support.

LSIutil appears to be x86_64 only.
You may have luck running qemu-x86_64-static LSIUtil, but I do not have a LSI card to test this and it too may require EFI support for some or all functions.


Possibly Related Threads…
Thread Author Replies Views Last Post
  Support for Refresh rates Above 60 publiclewdness 0 483 01-01-2022, 11:40 PM
Last Post: publiclewdness
  PCI-E X4 to M.2/NGFF NVMe SSD - support? AndyOfLinux 22 20,361 12-13-2021, 11:04 AM
Last Post: Cerberus
  Rockpro64 PCI-Express Issue. t4_4t 27 22,403 12-27-2020, 05:11 PM
Last Post: dsimic
  PCI-E Express card with SIM card slot for rockpro running android 8 seaurchin 3 3,342 07-21-2020, 07:58 AM
Last Post: pgwipeout
  Problems with maskrom OTG USB in Linux - Device not responding to setup address nutilius 0 1,276 08-31-2019, 11:40 AM
Last Post: nutilius
  Need to add various Wifi chipset support slappymcphee 6 5,546 08-15-2019, 05:26 PM
Last Post: evilbunny
  JMicron cipset SATA PCI-E card support Yroth 2 2,768 07-27-2019, 08:52 PM
Last Post: stuartiannaylor
  USB fails to power device? BackWoodsTech 12 9,165 12-13-2018, 07:26 AM
Last Post: BackWoodsTech
  Marvel 9215 Sata controller support MisterA 6 7,662 09-26-2018, 11:41 AM
Last Post: MisterA
  eMMC support themyshop 2 3,331 09-24-2018, 06:20 AM
Last Post: themyshop

Forum Jump:


Users browsing this thread: 1 Guest(s)