USB fails to power device?
#1
I have a small USB router. It has a USB powerc cable wirh an AC power adapter. It works just fine when using like one of those outlets that just has a usb port, but when I attempt to power the device off the rock pro USB it boots then shutsdown..boots, shutsdown repeat.

Is the USB port insufficient to power peripherals?
  Reply
#2
(12-08-2018, 03:09 PM)BackWoodsTech Wrote: I have a small USB router. It has a USB powerc cable wirh an AC power adapter. It works just fine when using like one of those outlets that just has a usb port, but when I attempt to power the device off the rock pro USB it boots then shutsdown..boots, shutsdown repeat.

Is the USB port insufficient to power peripherals?


The rp64 is only designed to be powered from the 12v socket, this was intentionally designed this way so hdd's would have power from the board
  Reply
#3
Let me clarify: the rockpro is powered off an outlet. But the USB Fails to power the small router
  Reply
#4
(12-09-2018, 06:49 AM)BackWoodsTech Wrote: Let me clarify: the rockpro is powered off an outlet. But the USB Fails to power the small router


No, that's not normal and you should contact [email protected]
  Reply
#5
Update
I did open a support ticket but not too confident I'll see a response.

Just to cover my bases: i tested both USB 2.0 ports and still the same behavior.
Using the USB 3.0 port however and the device worked as expected.

Does this offer any insight?
  Reply
#6
(12-10-2018, 07:17 PM)BackWoodsTech Wrote: I did open a support ticket but not too confident I'll see a response.

They do respond, but responses can take time, depending what else is going on.

Quote:Just to cover my bases: i tested both USB 2.0 ports and still the same behavior.
Using the USB 3.0 port however and the device worked as expected.


For the sake of completeness what power supply do you use?
  Reply
#7
(12-10-2018, 07:47 PM)evilbunny Wrote:
(12-10-2018, 07:17 PM)BackWoodsTech Wrote: I did open a support ticket but not too confident I'll see a response.

They do respond, but responses can take time, depending what else is going on.

Quote:Just to cover my bases: i tested both USB 2.0 ports and still the same behavior.
Using the USB 3.0 port however and the device worked as expected.


For the sake of completeness what power supply do you use?

The 5A powersupply which was recommended for the board. I think I surced everything drof Ameridroid
  Reply
#8
(12-10-2018, 07:17 PM)BackWoodsTech Wrote: Just to cover my bases: i tested both USB 2.0 ports and still the same behavior.
Using the USB 3.0 port however and the device worked as expected.

Does this offer any insight?

How about the RockPro64 properly implements USB2.0 and limits the power to 500mA. Whereas USB3.0 allows more (I am no expert, 1 quick answer from Prof Duck indicates 900mA). And your router needs >500mA @ 5V?
* ROCKPro64 v2.1 2GB, 16Gb eMMC for rootfs, SX8200Pro 512GB NVMe for /home, HDMI video & sound, Bluetooth keyboard & mouse. Started Bionic minimal - now eoan, Openbox desktop for general purpose daily PC.
* PinePhone BraveHeart :-)
  Reply
#9
(12-11-2018, 01:23 PM)dukla2000 Wrote:
(12-10-2018, 07:17 PM)BackWoodsTech Wrote: Just to cover my bases: i tested both USB 2.0 ports and still the same behavior.
Using the USB 3.0 port however and the device worked as expected.

Does this offer any insight?

How about the RockPro64 properly implements USB2.0 and limits the power to 500mA. Whereas USB3.0 allows more (I am no expert, 1 quick answer from Prof Duck indicates 900mA). And your router needs >500mA @ 5V?

that's an interesting thought. IIRC when I ran the device via a Kill A Watt meter it was only using like 2 Watts (~0.5Amps).
I'd sure hate to have to occupy the sole USB 3.0 port on this just because of a problem with the USB 2.0

One thing I am wondering is if there's a default setting for the USB 2.0 that's trying to mount the device rather than charge it? I guess that makes no sense.

FWIW this is on OMV 4.x (Debian Stretch).

UPDATE: the device does say 5v 2A.
  Reply
#10
(12-11-2018, 02:42 PM)BackWoodsTech Wrote: One thing I am wondering is if there's a default setting for the USB 2.0 that's trying to mount the device rather than charge it? I guess that makes no sense.

Could be - but you should see noise in the system log then if the "presented" USB device is changing (dmesg or journalctl).

(12-11-2018, 02:42 PM)BackWoodsTech Wrote: UPDATE: the device does say 5v 2A.

Most likely an absolute max that is theoretical and never reached. But does indicate >500mA very likely, and thinking back to your OP (boot, shutdown, repeat) does tend to say it is almost OK, gets to a point where it cant get enough power so shuts down ...

lsusb -v reports what power a USB device is limited to: I am sure a very crude measure on USB 2 ports but if you run the router on the USB 3 port then it may be a bit more useful. (My DVB stick in a USB2 port says 500mA - it is a USB2 device and so is clearly happy running somewhere under 500mA but no idea how much under. My Bluetooth dongle only asks for 100mA.)

But bottom line I figure you should use the power adapter.
* ROCKPro64 v2.1 2GB, 16Gb eMMC for rootfs, SX8200Pro 512GB NVMe for /home, HDMI video & sound, Bluetooth keyboard & mouse. Started Bionic minimal - now eoan, Openbox desktop for general purpose daily PC.
* PinePhone BraveHeart :-)
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  PCI Express x4 Device Support machinevault 1 507 09-19-2019, 09:33 AM
Last Post: iops/watt
  Problems with maskrom OTG USB in Linux - Device not responding to setup address nutilius 0 127 08-31-2019, 11:40 AM
Last Post: nutilius
  12V 3A power supply and NVMe - PCIe kaylios 3 284 08-25-2019, 03:31 AM
Last Post: kaylios
  Sata power cable sputnik13 1 195 08-15-2019, 06:32 PM
Last Post: tllim
  Sometimes no power to SATA PCIe controller rble 4 380 06-16-2019, 11:03 PM
Last Post: rble
Sad connect power in reverse :( nhzgroup 6 374 05-24-2019, 02:04 AM
Last Post: pfeerick
Question sufficient power supply? skipper 2 323 04-14-2019, 04:28 AM
Last Post: skipper
Question ROCKPro64 - power cable? skipper 2 300 04-13-2019, 06:26 AM
Last Post: skipper
  [Solved]Need Help with Power Supply Spec: Has Pico Cluster completely screwed me up ? axelf 2 259 03-11-2019, 11:19 AM
Last Post: axelf
  Rockpro death: USB3 does not supply power for a 2.5 HDD zillevdr 0 298 12-06-2018, 10:45 AM
Last Post: zillevdr

Forum Jump:


Users browsing this thread: 1 Guest(s)