RockPro64 not booting
#1
Hey all,

Posting here in hopes that I can get some guidance on where to turn next. Wanted a second opinion before I go ahead and attempt to get a replacement board, since the last one took close to a month to ship. 

Essentially, my RockPro64 just refuses to boot. I'm using the 64GB SD Card purchased from the Pine store, and have tried burning multiple distros to the card using multiple devices (a mac, PC, and linux machine) but no dice. When I plug in power, the lights on the Ethernet port light up, as well as the power light next to the DC input, but it looks like the USB ports get no power as my KB and mouse do not light up and I get no signal from HDMI. 

I then purchased a serial adapter CH340G to attempt to check the boot process of the board, however I can't seem to get any serial output from the board either (My steps for that detailed in a post here)

Apparently it is common that the SD Card slot on the boards ships broken, does it sound like that is the case? It looks like the board itself is getting power according to the lights on the ethernet port. 

Additionally, does it make sense that I would get no serial output even if the SD Card slot was broken? Will the board only begin outputting to the serial terminal if it has a functioning boot device? I was hoping even if the sd card slot was bad, I would at least see some errors in the serial console as it tried to boot.

Just looking for advice on what to do next/if it's worth debugging further or if I should begin the returns process?
  Reply
#2
Hi,

I'm curious whether you pressed the power button?

Kind Regards
M
  Reply
#3
(04-20-2019, 03:01 PM)jekohk Wrote: Additionally, does it make sense that I would get no serial output even if the SD Card slot was broken? Will the board only begin outputting to the serial terminal if it has a functioning boot device? I was hoping even if the sd card slot was bad, I would at least see some errors in the serial console as it tried to boot.

Just looking for advice on what to do next/if it's worth debugging further or if I should begin the returns process?

Yes, when sd-card don't boot up you will have no output on serial terminal. Do you have another sd-card to test??
Sorry for any mistakes. English is not my native language

1. RP64 v2.0 / PCIe NVMe as root / sd-card as boot / 2,5 Zoll HDD 1TB (USB3) using as Webserver .... (Kernel 4.4.167-1140-rockchip-ayufan-g6f266fb5d677)
2. RP64 v2.1 / PCIe SATA Marvell 88SE9230 Chipsatz / sd-card / 2 * 2,5 Zoll 2TB HDD (raid1) / using as NAS / Kernel 5.0.0-1101-ayufan-g41eeb7cd789e
3. RP64 v2.1 / testing.....testing....testing

https://forum.frank-mankel.org/category/14/rockpro64



  Reply
#4
I am in the same situation here I believe only I am using the 32gb version sd card. It was working a couple of days ago, but today nothing is working it won't start. Before that I had problems with login in to the webgui for OMV. Are these things they sell that low quality?
  Reply
#5
(04-21-2019, 12:13 AM)Bullet64 Wrote:
(04-20-2019, 03:01 PM)jekohk Wrote: Additionally, does it make sense that I would get no serial output even if the SD Card slot was broken? Will the board only begin outputting to the serial terminal if it has a functioning boot device? I was hoping even if the sd card slot was bad, I would at least see some errors in the serial console as it tried to boot.

Just looking for advice on what to do next/if it's worth debugging further or if I should begin the returns process?

Yes, when sd-card don't boot up you will have no output on serial terminal. Do you have another sd-card to test??

No I don't have another SD Card on hand. Can the RockPro64 boot from USB? I have some spare flash drives lying around I could potentially test with
  Reply
#6
Yes, RP64 can boot from usb. But unfortunately only when you flash u-boot into spi. And now you need an working sd-card.
Sorry for any mistakes. English is not my native language

1. RP64 v2.0 / PCIe NVMe as root / sd-card as boot / 2,5 Zoll HDD 1TB (USB3) using as Webserver .... (Kernel 4.4.167-1140-rockchip-ayufan-g6f266fb5d677)
2. RP64 v2.1 / PCIe SATA Marvell 88SE9230 Chipsatz / sd-card / 2 * 2,5 Zoll 2TB HDD (raid1) / using as NAS / Kernel 5.0.0-1101-ayufan-g41eeb7cd789e
3. RP64 v2.1 / testing.....testing....testing

https://forum.frank-mankel.org/category/14/rockpro64



  Reply
#7
Dear All


Same problem as well !!

No indication on the screen
Not booting from EMMC
Not Booting from several micro sd Card

Just green led meaninh power is on

I sended an email to sale management ... hope to find a solution to this issue
  Reply
#8
I received my RockPro64 October 2018, and due to Disabilities issues I was just now this week able to unpackage and try to get it running.

I also was having issue with EMMC 64GB only to boot.  I had light at power input and Ethernet.
Documentation says it can take up to 4 iminutes for first boot.  I waited 15minutes.  Then I pressed the "power" button just in case that was needed...... after 15minutes of nothing again, I turned off power to SBC.




I used Etcher.  I was told to try and use "7" app to unzip download contents then use Etcher to image onto EMMC.  I did and that did not work either.  ( waited and followed other steps mentioned above yet again and no response).

I then took "new" 128GB MICROsdxc I had for another SBC and used Etcher to image it.

I removed 6GB EMMC, put in sdxc imaged and within a delay of 3-4 minutes the RockPro64 booted!! 

However, DELAY/LATENCY in launching FireFox Browser is beyond terrible.  Also it causes the entire monitor screen to go black then delay and re-appear.  (EVEN THOUGH I AM USING RECOMMENDED "sdxc" type/formt.))

Being a FireFox fan/user, I opened Settings of browser to set it up for best protection while browsing internet, (EVERY CHANGE CAUSED ENTIRE SCREEN TO GO BLACK AND DELAY/SLOWED RECOVERY TO THE NEXT VIEW OF SCREEN).

I HAVE NO IDEA WHAT WOULD CAUSE THE ENTIRE SCREEN TO GO BLACK.  (The RockPro64 performance so far off the sdxc card reminds me of the performance of a RASPBERRY PI ZERO) HONESTLY.

NETTED:

Either motherboard for the EMMC when EMMC is loaded has conflict / denies running or even perhaps a defective EMMC card.
(Could mine be from Older Firmware since I received my delivery October 2018?

I am NOT an expert.  I leave that to you.

I have faith in the RockPro64.  I know the performance as a robust "desktop" is achievable!

i WANT THIS ROCKPRO64 TO BECOME MY ALPHA-DOG COMPUTER! CONTROL AND RUN EVERYTHING NETWORK... EVENTUALLY.

ALSO I NEED LIBRE OFFICE.  IT ONLY HAS DICTIONARY AND WORD READER AND CALCULATOR.

I TYPE 50 or more business letters a day.  I use SpreadSheets/macros daily.  those two items are worth gold to me.



IF I can get the RockPro64 up and running as my Alpha Dog desktop, I NEED 5 MORE COMPLETE CONFIGURATIONS INCLUDING NAS HARDWARE as I need 5 NAS on my network.  I need to run Raid - 5 / need redundancy total backup.  (I will be working with 120+ Terabytes of active DATA per department on a start up business.

3rd phase will be install much larger cluster of RockPro64 NAS archived library.

My technical level is limited but dangerously sharp and intuitive.  I will reach these goals.

Can you assist in helping me "IRON OUT THE KINKS" I currently have?

Most Humble Appreciation.

Alton D Davis Jr

[email protected]

USA  770-651-7009 (I can call anywhere in USA and CANADA FOR FREE.)
  Reply
#9
Hi,

I have similar issue. When i unplug and plug in the power i have to push the power button because the board won't start automatically. Is there something wrong with my board?

Cheers!
  Reply
#10
You Don't mention it, but which version of Linux are you using? I have found that Armbian 5.75 will install and allow the system to boot from a 64GB eMMC drive, but none of the alternatives installed using a straight dd or Etcher will boot regardless of uncompressing the img file before hand..
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  the 24/48 rockpro64 cluster LMM 7 692 5 hours ago
Last Post: fentavius
Question How to automatically reboot rockpro64 in case it shutdown abruptly ? seaurchin 2 70 11-25-2019, 08:46 AM
Last Post: tophneal
  RockPro64 Fan Pins TheUnknownMuncher 7 458 11-14-2019, 04:06 AM
Last Post: vecnar
  rockpro64 turn on with pine 64 remote vecnar 0 72 10-31-2019, 11:53 PM
Last Post: vecnar
Photo RockPro64 Case 2x3.5" HDDs and 2x2.5 HDDs Luke 48 19,212 10-17-2019, 11:58 AM
Last Post: Tim Jones
  rockPro64 vs Odroid-N2 kardanadm 4 1,104 10-16-2019, 10:29 AM
Last Post: buzzmarshall
  RockPro64 & Roshambo Case Gouki 0 129 10-13-2019, 01:16 PM
Last Post: Gouki
  The leds and fan of RockPro64 xlx 0 114 10-10-2019, 12:19 PM
Last Post: xlx
  Number of Rockpro64 boards sold/made fentavius 1 322 09-16-2019, 10:53 AM
Last Post: tllim
  Vulkan support with rockpro64 rahulsharma 2 337 08-21-2019, 10:34 PM
Last Post: rahulsharma

Forum Jump:


Users browsing this thread: 1 Guest(s)