No WiFi
#1
Hello,

I have plugged in the optional WiFi/BT module but no joy. It is completely ignored by the system (Ubuntu Bionic from http://wiki.pine64.org/index.php/ROCKPro....04_Bionic):

Code:
uname -a
Linux rockpro64 4.4.132-1075-rockchip-ayufan-ga83beded8524 #1 SMP Thu Jul 26 08:22:22 UTC 2018 aarch64 aarch64 aarch64 GNU/Linux

networkctl
IDX LINK             TYPE               OPERATIONAL SETUP     
  1 lo               loopback           carrier     unmanaged 
  2 eth0             ether              routable    configured

sudo lshw -c network
  *-network                 
       description: Ethernet interface
       physical id: 7
       logical name: eth0
       serial: 32:cb:11:5d:df:5e
       size: 100Mbit/s
       capacity: 1Gbit/s
       capabilities: ethernet physical tp aui bnc mii fibre 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=st_gmac driverversion=March_2013 duplex=full ip=192.168.1.34 link=yes multicast=yes port=MII speed=100Mbit/


Can you please advise?

Brgds, Edouard.
#2
The BT/wifi module is currently disabled in Linux because it conflicts with PCIe. This problem will eventually be fixed and will find its way into ayufan's images.
You can find me on IRC, Discord and Twitter


#3
conflict from PCI-E directly or only from booting from PCI-E NVMe devices?
When using the image 0.7.7-1057 booting from eMMC and the kernel to version 4.4.132-1068 will work?
(with PCI-E SATA-II adapter and BT/Wi-Fi module, without NVMe devices and without booting from PCI-E devices)
because sdio0 was disabled starting with the version of the kernel 4.4.132-1070
_____________________________________________________________________________________________________________________________________________
my SOHO NAS RockPro64 4GB v2.1 / eMMC 32GB / PCIe -> 4*SATA Marvell 88SE9235 / SD-card 64 GB / NAS Casing / image Debian Stretch Minimal / Kernel 4.4.xxx ayufan
my Multimedia desktops: ASUS H310T G5500, ODROIDs -XU4, -XU3, -C2, -C1;
my trash BananaPi; RPi B, B+; ODROID-W
#4
i had ubuntu running on the pinebook pro last night, but i mada a mistake and deleted the emmc content on the emmc disc. now i can only boot ubuntu from the micro sd card. It will boot the os, but importent things like the network device is gone "network device not available" How can i restore the network device? I am kinda stuck and cant move forward. Please let me know what i should do?


Possibly Related Threads…
Thread Author Replies Views Last Post
  Pine Wifi Module williamdieter 2 640 07-20-2022, 03:31 AM
Last Post: imianz
  AW-CM256SM wifi card mtek 0 280 05-10-2022, 10:32 PM
Last Post: mtek
  U.FL plug on the Wifi/BT module? domih 7 8,868 09-23-2021, 09:27 AM
Last Post: dml-pc
  To Wifi or To Bluetooth, That is the Question WarpLover 0 980 07-06-2021, 08:45 PM
Last Post: WarpLover
  RP64 TV box case with wifi Wizzard 2 2,028 03-10-2021, 12:23 AM
Last Post: Wizzard
  OpenWRT + Intel I350-T4 + 1x1 Dual Band WIFI pi64 0 1,398 11-17-2020, 04:25 AM
Last Post: pi64
  new WIFI/BT module not working with android 8.1 Firesped 0 1,410 05-12-2020, 10:33 PM
Last Post: Firesped
  Questions about the ROCKPro64 1x1 Dual Band WIFI module thelabratrules 0 1,441 04-04-2020, 03:29 PM
Last Post: thelabratrules
  Best location for adhesive wifi antennas with NAS case callegar 1 2,096 02-17-2020, 12:40 PM
Last Post: tllim
  Need to add various Wifi chipset support slappymcphee 6 5,342 08-15-2019, 05:26 PM
Last Post: evilbunny

Forum Jump:


Users browsing this thread: 1 Guest(s)