[Jan 14] KDE Neon (20190113-1500) - Pinebook1080P / Pinebook |[Jan 14] Q4OS (2.7-r1) - Pinebook1080P / Pinebook | [Dec 07] DietPi(v6.18) - Pinebook / Manjaro KDE (preview3) / Manjaro LXQT (preview3) - Pinebook |[Dec 06] Armbian Debian Stretch (5.67) / Armbian Ubuntu 18.04 Bionic Desktop (5.67) - RockPro64 |[Dec 05] DietPi(v6.18) - 1080P Pinebook

Project Inspiration | Get Started | IRC Logs | Forum Rules/Policy


Arch Linux on RockPro64
#21
(12-03-2018, 09:59 AM)fosf0r Wrote: No available images are properly set up for acceleration from the jump, but that can be fixed.


If you install libmali-rk-midgard-t86x-r14p0-gbm and then build and install fbturbo, you can have accelerated X11.
https://github.com/ssvb/xf86-video-fbturbo

Reminder: rockpro64 cannot do hardware GL, but GLES2 will be accelerated.
Software GL and hardware acceleration conflict, so you can't have MESA GL (software) plus accelerated GLES (libmali-rk) at the same time (that I know of. I've been trying, so if I'm wrong, please correct!)

xscreensavers will be unaccelerated, for example, but you can run Kodi if build for GBM+GLES.
But Kodi is better without X11 at all, when run from framebuffer in GBM mode.
It suffers performance a lot if you launch from within X11.


If you use fbturbo, and your window manager supports compositing and/or some form of acceleration, TURN IT ALL OFF.
For example, XFCE has software compositing, but that is unaccelerated by fbturbo, so things actually go faster once you disable it.
Counter-intuitively, if any programs (example: SMplayer) ask you what surface to render to, choose "x11 slow", NOT any of the options that would seem like they have acceleration.
(Also, "drm" and "GBM" can be appropriate choices as well depending on the context of the question and the program that is asking.)
If you go this route you may also want to disable all hardware acceleration inside of your web browser (Chromium, Firefox, etc) as well, since those are counter-intuitive as well. When I disabled as much hardware accel as I could in Chromium, it started functioning even more responsively.




If you want Wayland and Weston, you must install libmali-rk-midgard-t86x-r14p0-wayland
Weston on Wayland with this driver is 100% accelerated and composited.
I'm not 100% sure if having the libmali-rk-*-wayland package is allowed at the same time as the GBM one, I have not tried using both systems at the same time before (X11 and Wayland).

Thank you! I'll try it.
Reply
#22
(11-24-2018, 04:09 AM)mmatyas Wrote: When you look into his PKGBUILD in his sources, you can find the link to the linux kernel resources he used to get the kernel sources from.

...

Finally got around to trying my hand at compiling a kernel and installing it. This worked, but (after an afternoon of trying) I never got the kernel to work.

What I did was the following:
- clone your repo (https://github.com/matyas1995/linux-aarch64-rockpro64),
- update the 'PKGBUILD' and 'linux-rockpro64.install' files to fetch and build the latest release (4.20.0-1083, commit),
- run 'makepkg', answer 'y' and 'n' to the inclusion of some modules (following the suggested answers mostly) and wait for approx 1h for the compiling to finish (also applied your tip of setting MAKEFLAGS to "-j7"),
- install the newly made package ('pacman -U linux-rockpro64-4.20.0-1083-aarch64.pkg.tar.xz'),
- and finally, change '/boot/extlinux/extlinux.conf' to:
Code:
cat /boot/extlinux/extlinux.conf.new
timeout 10
default arch
menu title select kernel

label arch
   kernel /boot/Image
   initrd /boot/initramfs-linux.img
   devicetreedir /boot/dtbs
   append rw panic=10 init=/sbin/init coherent_pool=1M ethaddr=${ethaddr} eth1addr=${eth1addr} serial=${serial#} cgroup_enable=cpuset cgroup_memory=1 cgroup_enable=memory swapaccount=1 root=LABEL=linux-root rootwait rootfstype=ext4

After that I rebooted the system. Sadly it did not come up anymore. To see what was happening I attached the rockpro directly to my laptop through GPIO>USB with a serial console and watched the startup messages scroll by. I think the following bit is interesting:
Code:
...
...
[    2.973624] RAMDISK: Couldn't find valid RAM disk image starting at 0.
[    2.974239] Waiting for root device LABEL=linux-root...
... end then it basically stops.

It complains that it can't find the RAMDISK. This is odd, because in the beginning of the startup progress, before attempting to start the kernel, it states this:
Code:
switch to partitions #0, OK
mmc0(part 0) is current device
Scanning mmc 0:7...
Found /boot/extlinux/extlinux.conf
Retrieving file: /boot/extlinux/extlinux.conf
379 bytes read in 112 ms (2.9 KiB/s)
select kernel
1:      arch
Enter choice: 1:        arch
Retrieving file: /boot/initramfs-linux.img
5685385 bytes read in 303 ms (17.9 MiB/s)
Retrieving file: /boot/Image
32614912 bytes read in 1484 ms (21 MiB/s)
append: rw panic=10 init=/sbin/init coherent_pool=1M ethaddr=xxx eth1addr= serial=xxx cgroup_enable=cpuset cgroup_memory=1 cgroup_enable=memory swapaccount=1 root=LABEL=linux-root rootwait rootfstype=ext4
Retrieving file: /boot/dtbs/rockchip/rk3399-rockpro64.dtb
55324 bytes read in 269 ms (200.2 KiB/s)
## Flattened Device Tree blob at 01f00000
   Booting using the fdt blob at 0x1f00000
   Loading Ramdisk to f5997000, end f5f03089 ... OK
   Loading Device Tree to 00000000f5986000, end 00000000f599681b ... OK

Also, the message right after, Waiting for root device LABEL=linux-root..., is odd because this is still partition 6, which still has the right label (I double checked by running 'blkid').

So it seems as if it correctly finds and reads the extlinux config, finds the images, and loads them into memory; and then seems to forget about it later during the actual booting of the kernel.

Does anyone have any idea what I'm doing wrong?
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  RETRO-GAMING: ANNOUNCING BETA RELEASE OF RECALBOX FOR THE ROCKPRO64 Mrfixit2001 9 262 01-14-2019, 07:27 PM
Last Post: Mrfixit2001
Big Grin ANNOUNCING RECALBOX FOR THE ROCKPRO64 - ALPHA RELEASE Mrfixit2001 20 2,643 01-10-2019, 11:42 AM
Last Post: Luke
  Is PCIE x4 bootable for NVMe SSD under Linux jzhang18 48 4,064 12-25-2018, 03:05 PM
Last Post: Atch
  First Lakka image for ROCKPro64 Ntemis 11 1,923 12-19-2018, 06:52 PM
Last Post: Rafius
  Rockpro64 Ubuntu 18.04 minimal 64 bit - shutdown command whitehat 2 393 12-15-2018, 12:27 PM
Last Post: Martronic
Star 0.7.9 Linux release from ayufan Luke 47 10,816 12-12-2018, 04:53 PM
Last Post: Deathcrow
Question rockpro64: Enable sdio0, disable pcie, on ayufan 4.4.132 ? fosf0r 3 321 12-12-2018, 04:33 PM
Last Post: Luke
  slarm64 (unofficial slackware) ROCKPro64 RK3399 (aarch64) mara 10 1,097 12-12-2018, 01:07 PM
Last Post: mara
  WiFi support on RockPro64 tagyro 4 408 12-11-2018, 02:43 PM
Last Post: fosf0r
  [SOLVED] No sound from phone-jack via "es8316" on rockpro64 t4_4t 14 1,405 11-28-2018, 04:32 PM
Last Post: dukla2000

Forum Jump:


Users browsing this thread: 1 Guest(s)