Rock64 Xenial Mate Community Build Image [microSD to eMMC] [0.5.15-136]
#1
Hi Everyone,

Okay so I a bit of a noob here and If I'm on the wrong board I apologize, Okay that being said I've purchased the rock64-4G+64gbSSD (Which I've found to be a fantastic sbc) however I'm having a few issues with the "Xenial Mate Community Build Image [microSD to eMMC] [0.5.15-136]" image I've managed to install it on my SSD which was easy (Thanks to ayufan' build),  Now going through MATE I've tried to add users and use the network function but every time I try to use it all I get is "The Configuration could not be loaded, an unknown error occured"  when trying to add users via the terminal (sudo users-admin)  I get "There was an unknown error communicating with the backends: failed to execute program org.freedesktop.SystemToolsBackends: Permission denied" is there a reason for this,  is there some sort of policy setup on this image?  Does anyone know what this means as I've said I'm a noob to this environment and starting a long learning curve.

Thanks  Big Grin
  Reply
#2
you might want to check if user-admin permissions is set to execute.
  Reply
#3
Hey, since you wan't to use a desktop environment I'd like to suggest you read this thread and use the latest 0.6.X image instead because it offers a much better desktop experience. Although 0.6.X isn't a stable image I have seen very few reports of issues with it and you'll be able to easily update to stable in the future.
You can find me on IRC, Discord and Twitter


  Reply
#4
I'm using the 4.4.77-rockchip-ayufan-136 Xenial build, and I also have trouble with various UI elements.  Trying to run the Users and Groups from the System>Administration menu gives:

The configuration could not be loaded
An unknown error occurred.

Running "sudo users-admin" from the command line gives the same error as Gold:

Liboobs-WARNING **: There was an unknown error communicating with the backends: Failed to execute program org.freedesktop.systemtoolsbackends permission denied

This suggests that the default rock64 account is not a member of a needed group, but I don't know what.  I know someone else that is seeing the same problem.  Luke, moving to 0.6.x isn't an option (I tried and my rock stops responding after about 1/2 hour).

Any thoughts on what group might be needed, or permissions set?
  Reply
#5
"Failed to execute program org.freedesktop.systemtoolsbackends permission denied."
I confirmed about.

The environment is the state where all "UpDate" as of today are applied to the following images.
https://github.com/ayufan-rock64/linux-b...tag/0.5.15
xenial-mate-rock64-0.5.15-136-arm64.img.xz

I did not want to destroy the environment of eMMC, so confirmed with microSD
Although slightly different from the main theme [microSD to eMMC]
Since the same error came out, I think that the essential problem has not changed.
"System -> Administration -> users - admin",
"System -> Administration -> Network",
"System -> Administration -> Time and Date"
These errors have disappeared

[Code]
# ls -la /usr/lib/dbus-1.0/dbus-daemon-launch-helper
-rwsr-xr - 1 root netdev 38824 Jan 12 2017 /usr/lib/dbus-1.0/dbus-daemon-launch-helper

# chown root:messagebus /usr/lib/dbus-1.0/dbus-daemon-launch-helper
# chmod u+s /usr/lib/dbus-1.0/dbus-daemon-launch-helper
# ls -la /usr/lib/dbus-1.0/dbus-daemon-launch-helper
-rwsr-xr - 1 root messagebus 38824 Jan 12 2017 /usr/lib/dbus-1.0/dbus-daemon-launch-helper

Information source is ↓.
dialog with error
"org.freedesktop.DBus.Error.Spawn.ExecFailed: Failed to execute program org.blueman.Mechanism: Permission denied"
displayed after login
https://bugs.launchpad.net/ubuntu/+sourc...ug/1542723

However, "Stikky-Bit" will come off when you do this street operation.
I think that the reverse order is better
  Reply
#6
(03-14-2018, 04:14 AM)t4_4t Wrote: "Failed to execute program org.freedesktop.systemtoolsbackends permission denied."
I confirmed about.

The environment is the state where all "UpDate" as of today are applied to the following images.
https://github.com/ayufan-rock64/linux-b...tag/0.5.15
xenial-mate-rock64-0.5.15-136-arm64.img.xz

I did not want to destroy the environment of eMMC, so confirmed with microSD
Although slightly different from the main theme [microSD to eMMC]
Since the same error came out, I think that the essential problem has not changed.
"System -> Administration -> users - admin",
"System -> Administration -> Network",
"System -> Administration -> Time and Date"
These errors have disappeared

[Code]
# ls -la /usr/lib/dbus-1.0/dbus-daemon-launch-helper
-rwsr-xr - 1 root netdev 38824 Jan 12 2017 /usr/lib/dbus-1.0/dbus-daemon-launch-helper

# chown root:messagebus /usr/lib/dbus-1.0/dbus-daemon-launch-helper
# chmod u+s /usr/lib/dbus-1.0/dbus-daemon-launch-helper
# ls -la /usr/lib/dbus-1.0/dbus-daemon-launch-helper
-rwsr-xr - 1 root messagebus 38824 Jan 12 2017 /usr/lib/dbus-1.0/dbus-daemon-launch-helper

Information source is ↓.
dialog with error
"org.freedesktop.DBus.Error.Spawn.ExecFailed: Failed to execute program org.blueman.Mechanism: Permission denied"
displayed after login
https://bugs.launchpad.net/ubuntu/+sourc...ug/1542723

However, "Stikky-Bit" will come off when you do this street operation.
I think that the reverse order is better

Thanks to t4_4t for this.Cool  I tried this out and it's now working, I can access the admin and network function on MATE.
  Reply
#7
I can confirm that the two commands together are necessary:
sudo chown root:messagebus /usr/lib/dbus-1.0/dbus-daemon-launch-helper
sudo chmod u+s /usr/lib/dbus-1.0/dbus-daemon-launch-helper

Seems to work now. Thanks!
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Rock64 won't boot dstallmo 0 197 12-27-2023, 10:34 AM
Last Post: dstallmo
  HDMI doesn't work on rock64 Noung1991 1 453 11-21-2023, 08:33 AM
Last Post: as365n4
  Rock64 + Klipper + KlipperScreen Instructions godzilla62 0 439 10-22-2023, 01:52 AM
Last Post: godzilla62
  Rock64 Debian 11 (Bullseye) install problem jbize 15 7,679 10-12-2023, 05:14 PM
Last Post: tpaul
  slarm64 (unofficial slackware) Rock64 RK3328 (aarch64) mara 133 184,580 10-09-2023, 03:31 AM
Last Post: mara
  arch rock64 does not boot nemnob 0 466 07-09-2023, 03:28 AM
Last Post: nemnob
  RXDP from Win10 to Armbian on Rock64 Transportsicherung 0 515 05-27-2023, 06:11 AM
Last Post: Transportsicherung
  DietPi OS for ROCK64 MichaIng 41 30,940 12-07-2022, 08:22 PM
Last Post: luminosity7
  Using multiple UART's on Rock64. ramprasad 0 857 08-29-2022, 01:22 PM
Last Post: ramprasad
  Using multiple UART's on Rock64. sachineswar 0 838 08-29-2022, 12:31 PM
Last Post: sachineswar

Forum Jump:


Users browsing this thread: 1 Guest(s)