[June 06] Bionic LXDE (0.6.44-239) ROCK64 | [June 06] Bionic Minimal (0.6.44-239) ROCK64 | [June 06] Debian Stretch Minimal (0.6.44-239) ROCK64 | [June 06] Jessie OpenMediaVault (0.6.44-239) ROCK64 | [May 21] Slackware (20180508) ROCK64 | [May 18] NextCloudPi (2018_05_10) ROCK64 | [April 06] Volumio (2.390-2018-03-27) ROCK64 | [April 06] Q4OS (2.4-r3) PINE A64(+) Pinebook

Project Inspiration | Get Started | IRC Logs | Forum Rules/Policy

NIC not visible after kernel update

Long-time lurker, first time poster.  I have been doing some work with my Pine64 2GB and came across the kernel-update.sh script and as I was having issues (and was hoping some missing kernel modules would be in the later release), I ran the script which determined that there was an update and it duly installed it.

Upon rebooting the Pine, everything came back but the network!  It doesn't appear to see the NIC at all now.
I had been previously forcing eth0 to 100MB F/D due to the gigabit issues, so I don't think it's related as even with the network connected, it doesn't even flash the connectivity LED any more to acknowledge a cable connected.

Is this a known problem?

I'll try again with a new memory card and the original image to rule out a hardware issue, but is there a way I can wind back the new kernel to the one which I was previously running before the script? Does it back up the original kernel folder?

It's difficult to use the Pine via the HDMI as it oversizes so badly that you can't read what you are typing at the bottom of the screen, so I've only done limited investigation at this stage so I'm not even sure exactly which version of kernel it has installed (whatever the latest is as of today I guess)

Thanks in advance.
Not sure what happened, but after looking through pine64_update_kernel.sh and checking what files it had updated to get to 3.10.104-1 and reversing those files back to eth0 is now working again.

Stranger still, since going back to the previous kernel, the NIC fails to work if I leave my line in /etc/network/interfaces which was working before to force the NIC to 100Mb !!

Now, I have to wait for it to fail 1000Mb, then use ethtool via SSH to fix to 100Mb for that boot session.

Possibly Related Threads...
Thread Author Replies Views Last Post
  (ARCHIVED) Debian Jessie Images (3.10.102 BSP Kernel) New Release lenny.raposo-pine64.pro 260 81,046 05-21-2018, 06:30 AM
Last Post: Luke
  how to set kernel parameter 'fsck.mode=force' marcelser 6 161 05-09-2018, 09:07 PM
Last Post: pfeerick
Question Debian Jessie with 4.x.y kernel and complete hardware support? Spark 2 1,203 04-24-2017, 09:56 PM
Last Post: Spark
  Adding a missing kernel module spz2k 8 961 01-10-2017, 06:22 AM
Last Post: xalius
  [SOLVED]Problem Compiling modules: Recipe | kernel-headers not found acenos 0 451 12-14-2016, 09:11 AM
Last Post: acenos
  After update - won't power up with HDMI connected UnixOutlaw 6 695 09-09-2016, 01:43 PM
Last Post: janeku
  Debian Jessie (4.7.0-rc1 Kernel) Images fire219 4 3,314 07-20-2016, 02:36 PM
Last Post: umiddelb
  i2c-bus kernel modules robertvaldimarsson 15 1,250 06-07-2016, 01:48 PM
Last Post: robertvaldimarsson
  Debian kernel upgrade question jl_678 2 740 04-18-2016, 05:54 PM
Last Post: jl_678

Forum Jump:

Users browsing this thread: 1 Guest(s)