Unable to Boot anything (emmc or SDcard)
Yesterday, I did my normal Manjaro update, and was told there was a new version of u-boot and to run the two dd commands (Not the first time i've done this). I ran the two commands, but upon reboot, I saw a new u-boot screen (I've never seen this one before), then the screen would show a bunch of junk, then go blank.

It appeared that something was failing during the boot process. I was not able to switch to a terminal (ctrl-alt-f2), nor ssh/ping the machine.

Unfortunately, my keyboard did not seem to be active during the boot process, so I couldn't interrupt or inspect u-boot before it started booting manjaro.

I assumed my best option was to revert uboot, and followed the 'Flashing u-boot to SPI Flash' from the NOOB page.

It wasn't booting from the SDcard by default, so I flipped the switch to disable my emmc.

When I turned on the power, with the SDcard with the u-boot-flash-spi-pinebookpro.img.xz image written to it, the power light went amber, and the display stayed off. I let it sit there for about 5 minutes, but nothing happened. No blinking lights as expected.

I turned it off, removed the SDcard, and re-enabled the emmc switch.

Upon a reboot, the power light starts off amber, and then goes green. However, the display never turns on. I hooked up an external monitor through usb-c-> hdmi, and it never gets a signal either.

I seem to be in an un-bootable state, and get no feedback since the display never turns on.

With emmc enabled, the power light is amber, then goes to green and stays green. Display is off, external display doesn't work. No indication that it has booted. No network.

With emmc disabled and a bootable SDcard (Manjaro), the power light stays amber and the display stays off. No indication that anything booted.

What are my options for fixing this?

The NOOB page has steered you badly wrong, if you used the ayufan image,,,
it is for ROCK64... this is a COMPLETELY different cpu,, A64,,with a rather different uboot
(rockpro64 has rk3399)
One hopes that it locked up BEFORE writing to SPI
I hope you have a bootable SD, do a 'hard reset" (long press, 20+s or internal button)
and disabled emmc. Then blank SPI
If it has written SPI, then it is harder, use recovery button (shorts SPI pwr, hold 2-3s at&before pwr-on)
You should be EXTREMELY wary about updating a WORKING uboot
(a working uboot will boot from SD, make sure you have a recovery, 1st 16M of old + usb dongle or do switch dance)
Manjaro has put out more than 1 bad uboots
long pressing the power button didn't do anything, nor did pressing the internal reset button.

I also tried holding the recovery button down before and while powering on.

I have emmc disabled, have a bootable manjaro SD card, and still just get an amber/orange light.

I am at a loss on what to try next.
Have you tried with another SD card?
Try the Debian Installer? Or another OS != Manjaro?
FYI, I believe that reset and 20s press are equal
After an attempt to boot an A64 uboot, you always need to do a hard reset,,
because you get a led probably the SPI was NOT written
In my experience, with a A64 boot attempt you get NO leds, it seems dead, nothing will boot
If you have a usb dongle (->emmc) write another uboot to emmc
both of those uboots are BSP style,,, for your convenience
OR try another, different OS on SD and do switch dance
I have experienced the exact same issue as described by @line72
Copied the uboot files like last time and now I can't even launch from SD card. Even the keyboard doesn't work.
I'm going to try to boot something from USB but don't hold much hope.

Possibly Related Threads…
Thread Author Replies Views Last Post
Tongue Yet another Pinebook Pro won't boot thread pinemouth 5 457 05-20-2023, 01:02 AM
Last Post: jackwilson
  I'm booting from NVME but I want to switch back to eMMC acruhl 4 311 04-23-2023, 06:58 AM
Last Post: acruhl
  New Pinebook pro won’t boot Generaltuxenburg 2 355 03-25-2023, 12:56 PM
Last Post: Generaltuxenburg
  U-Boot, video console, and visual artifacts dsimic 21 14,372 03-16-2023, 07:30 AM
Last Post: Tazdevl
  Pinebook Pro won't boot Whisk 6 1,628 03-14-2023, 11:54 AM
Last Post: KC9UDX
  Doesn’t power on after flashing emmc badguru 3 442 02-25-2023, 09:00 PM
Last Post: badguru
  eMMC problem with Tow-Boot/u-boot on SPI repa 3 832 02-21-2023, 01:49 AM
Last Post: repa
  Partial boot after installing Manjaro on emmc regivanx 11 1,240 02-06-2023, 09:11 AM
Last Post: wdt
  how to make a bootable USB linux sine pinebook will not boot up River 14 2,273 12-11-2022, 11:12 PM
Last Post: wdt
  What OS have you recently flashed onto PBP eMMC? jcun4128 6 1,192 11-26-2022, 09:39 AM
Last Post: KC9UDX

Forum Jump:

Users browsing this thread: 1 Guest(s)