Pine Phone Pro audio on phone calls: discussion, support and tips
#41
2023 Dec 11 - Danctnix Arch with Phosh [SOVLED]

I did an update "sudo pacman -Syu" and people told me my phone calls sound like I am on a freight train.

BEFORE update 
 /usr/share/alsa/ucm2/PinePhonePro/VoiceCall.conf
  cset "name='ADC Capture Volume' 160"
  cset "name='Mono ADC Capture Volume' 160"

AFTER update to fix voice calls
 /usr/share/alsa/ucm2/PinePhonePro/VoiceCall.conf
  cset "name='ADC Capture Volume' 0"
  cset "name='Mono ADC Capture Volume' 0"


*I use the internal speaker, not the "speaker" button*
  Reply
#42
Yes after megis 6.5something things have changed and audio is routing differently.

What mikehenson wrote is correct answer for a super dirty nearly usable workaround. It is still best option what you can do easily...

Fun thing is that when you set:
cset "name='ADC Capture Volume' 0"
(in /usr/share/alsa/ucm2/PinePhonePro/VoiceCall.conf)
You are settings the microphone to 0 - so it should be completely silent.
While it sill too loud (you can use it yes but the receiver will definately hear you because it really is loud)

For eveyrones information this does not actually do anything:
  cset "name='Mono ADC Capture Volume' 0"
You can put any value you want there but it does not do anything in voice calls Big Grin
  Reply
#43
I have recently installed the newest (12/22) edge version of pmOS and the mic is no longer working on phone calls. Calls were working fine for roughly the last year. I am wondering what has changed. It would be nice to know how megi's new kernel has changed the audio routing. My audio does not sound like a freight train. It is simply quiet. Sounds like this is different from what is being described by mikehenson.

edit: My ADC Capture Volume is set to 160 in /usr/share/alsa/ucm2/PinePhonePro/VoiceCall.conf.
  Reply
#44
I outlined my experience in a different thread as I thought I was doing something wrong.

The TL;DR is that on Danctnix Arch linux-megi-6.7.7 with GNOME Calls, I couldn't seem to adjust any of the values to make the mic not sound overblown, everything on 0.
  Reply
#45
running kali, no sound phone or media unless i send to bluetooth earpieces, but no sound from phone even through the headset. Havent had time to reallydig into it, but saw an article suggesting uninstall & purge pulse-audio install alsa, then reinstall just the pulse-audio apt package. will see if i can find thst again
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
Question Calls: ALSA UCM config not making a difference with volume lightwo 6 419 05-17-2024, 04:23 AM
Last Post: lightwo
  Battery life thread: discussion, support and tips apink 7 2,291 05-14-2024, 12:53 PM
Last Post: Rednoise
  bookworm vs trixie discussion for mobian in pinephone pro. zetabeta 16 2,572 04-28-2024, 01:52 AM
Last Post: diederik
  Guide to Suitable Phone State Borealid 19 11,250 09-18-2023, 07:00 AM
Last Post: robocone
  Phone Attitude(Device orientation) lurkadillian 2 1,131 06-22-2023, 08:12 PM
Last Post: lurkadillian
  Any tips to improve the audio quality of calls on the PinePhone Pro? tux_life 2 1,626 05-12-2023, 12:58 PM
Last Post: alaraajavamma
  Mobian has new separate packages to support the PinePhone Pro mburns 22 7,901 04-10-2023, 12:02 PM
Last Post: mburns
  Pine Phone won't boot into recovery mode ninjapig26@gmail.com 3 1,916 02-18-2023, 06:14 PM
Last Post: fxc
  [Mobian] No return from locked phone arno_nuehm 1 1,097 02-06-2023, 07:57 AM
Last Post: arno_nuehm
  Making and receiving calls via command line Zotax 0 873 01-28-2023, 12:19 PM
Last Post: Zotax

Forum Jump:


Users browsing this thread: 2 Guest(s)