Pine Phone Pro audio on phone calls: discussion, support and tips
#1
This is an invitation for people to report on their experience getting audio to work on the pine phone pro during phone calls.   Please let us know the following:

  1.  Are you able to get audio to work during phone calls?
  2.  If not, what are the specific problems you are having?
  3.  If so:
         a.  what operating system are you using?
         b.  what updates/tweeks need to take place after installing the OS in order for audio to work?
  Reply
#2
Over the last week I have run both pmOS with sxmo  and the most recent mobian.  With both I am able to hear audio from the incoming call reasonably. 

With mobian (mobian-phosh-20221204) I am able to get outgoing sound to work if I use a headset with a microphone.  When I use  mobian without a headset, the sound level from the ppp mic is not high enough for outgoing sound even though the level in settings for the microphone under "phone mode" is at 100%.

With pmOS (20221125-1409-postmarketOS-edge-sxmo-de-sway) the outgoing sound is dominated by white-noise-ish static.  This is the case for me both with a headset microphone and with the ppp microphone.  The mics will pick up some signal from voice, but it is not usable for communication.

I have the community-developed modem firmware installed.
  Reply
#3
How nice!  Just loaded arch-plasma (for the first time).  After upgrading, audio on a call just worked without an earphone headset.  I have tried arch-phosh before with no luck, but this worked.

The latest (12/8) edge release of pmOS with sxmo is working now for me also. I think I'm ready to daily drive the ppp.
  Reply
#4
Thanks for this post! I am going to give Arch a try. I appreciate the thread
  Reply
#5
Using sxmo with pmOS I currently need to just get a phone call going, then get to the audio menu within the call and cut the input volume from 100% down to about 35%. At 100% the mic is way too hot, causing lots of static-y noise.
  Reply
#6
1/ My 1st experience was - issue with calls on 4G / Lte . -> I forced phone to 3G only -> this has helped for connection to be established
2/ i noticed voice was low on regular call , but switching to loudspeaker mode and then switching off loudspeaker mode was fixing normal call audio
3/ Then for the quality of the audio (low internal mic sensitivity/gain , low internal speaker, low loudspeaker sound ) you can modify some mic gain , volume parameters in following files (i suggest to make a backup of originals Smile
/usr/share/alsa/ucm2/PinePhonePro/ HiFi.conf [media playback profile settings]
/usr/share/alsa/ucm2/PinePhonePro/VoiceCall.conf [phone call profile setting]
microphone volume setting:
# Set capture volume to 0dB so modem audio doesn't overdrive the ADC
cset "name='ADC Capture Volume' 60"
cset "name='Mono ADC Capture Volume' 99"
speaker volume setting
# Limit amplification factor of earpiece amplifier so sound stays clear
cset "name='Class D SPK Ratio Control' 2.20x"
with above setting Phone call in normal mode works fine for me , but loudspeaker mode is not usable .
  Reply
#7
When installed for first time February 2nd,the telephone worked well to talk in 
Both directions but today, after several updates I can
here the other end but they do not receive them
What can I do to solve it?
  Reply
#8
(02-20-2023, 03:42 AM)Emilio Wrote: When installed for first time February 2nd,the telephone worked well to talk in 
Both directions but today, after several updates I can
here the other end but they do not receive them
What can I do to solve it?

Hello!

I just received my PPP so I learning while using.
I have tried now latest images from PMOS Edge (Phosh), Manjaro (Phosh), Arch (Phosh) and Mobian (Phosh)

What I have noticed so far?
With every distro Pulseaudio is suspending like a maniac. When I am on phone call Pulseaudio suspends like in 5 seconds.
I need to disable Pulseaudio suspend on every distro to get even somehow working audio
How? edit this file: /etc/pulse/default.pa and search line which says something like "suspend-on-idle" and put # before that line

With PMOS, Manjaro and Arch microphone is REALLY quiet. You literally have to shout at it to hear anything at all.
Mobians mic did work BUT after upgrade it became similar to the others.
What I have seen and read I think this is coming from newer kernel. I don't have my PPP right here with me but I think on kernel 5.19 mic and callaudio works somehow and after upgrade to newer one there are problems.

Are there someone who can confirm?
  Reply
#9
I removed Pulseaudio and set Pipewire. Sounds work well but the phone
Receive well but with my voice to the other telephone sends a strong noise
Can this be corrected and how?. It is curious that when purge Pulseaudio
automatically loads pipewire.Mobian latest. Gnome-sound-recorder is also spoiled
  Reply
#10
I'm surprised. After the last Mobian update I have done an autoremove and it has removed quite a bit and: my phone runs clean both ways on both emmc and sd!
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
Question Calls: ALSA UCM config not making a difference with volume lightwo 6 322 05-17-2024, 04:23 AM
Last Post: lightwo
  Battery life thread: discussion, support and tips apink 7 2,231 05-14-2024, 12:53 PM
Last Post: Rednoise
  bookworm vs trixie discussion for mobian in pinephone pro. zetabeta 16 2,456 04-28-2024, 01:52 AM
Last Post: diederik
  Guide to Suitable Phone State Borealid 19 11,142 09-18-2023, 07:00 AM
Last Post: robocone
  Phone Attitude(Device orientation) lurkadillian 2 1,112 06-22-2023, 08:12 PM
Last Post: lurkadillian
  Any tips to improve the audio quality of calls on the PinePhone Pro? tux_life 2 1,605 05-12-2023, 12:58 PM
Last Post: alaraajavamma
  Mobian has new separate packages to support the PinePhone Pro mburns 22 7,773 04-10-2023, 12:02 PM
Last Post: mburns
  Pine Phone won't boot into recovery mode ninjapig26@gmail.com 3 1,891 02-18-2023, 06:14 PM
Last Post: fxc
  [Mobian] No return from locked phone arno_nuehm 1 1,080 02-06-2023, 07:57 AM
Last Post: arno_nuehm
  Making and receiving calls via command line Zotax 0 861 01-28-2023, 12:19 PM
Last Post: Zotax

Forum Jump:


Users browsing this thread: 1 Guest(s)