No volume control after latest updates
#1
Last week I updated Mobian and found that the up/down volume buttons no longer worked either when using the phone's internal earphone or an external wired headset. This evening I updated to the latest, including dist-upgrade which pulled in mobian-base, mobian-phone-base, and gnome-calendar.

After this update not only are the volume controls not working but when I went to test phone operation I received a popup from the contact list saying something like "Cannot find primary phone book". However after using the cancel option in the popup the expected contents were listed and the error message has not been repeated even after rebooting.

Anyone else seeing these issues? The lack of volume control doesn't make the phone unusable and is just an annoyance, but if it comes down to it I have a full image backup made just before the most recent updates. However I'll probably wait and see if the next round of updates fixes this.
  Reply
#2
Another data point, I just noticed that the volume controls are non-functional only during phone calls. (The slider popup comes up and moves appropriately but the sound level does not change.) However, the volume control works fine when playing media files locally on the phone.

I just did another round of updates and the problem persists. Don't know what to make of this, it's not a deal breaker but definitely an annoyance. Hopefully it will be fixed soon...
  Reply
#3
initially when i tested this was the case, volume buttons do not work for calls. but i tested again and it now works, i did not update anything in between. however, volume seems to be little logarithmic, on the higher side, difference is very small. on the lower side is audible.

i don't rule out some issues with audio routing though.
  Reply
#4
Yeah, it's a bizarre problem and annoying. (For now I have to "adjust" the volume by moving the phone closer or further away, or on my wired headset by pulling the earbud partway out.) It's not bad enough though that I want to blow it away by restoring a backup image.
  Reply
#5
Just brought Mobian up to date today and still no volume controls during calls. Very annoying. Did some web searches but haven't found any fixes for the problem yet.
  Reply
#6
(11-05-2022, 12:49 PM)Zebulon Walton Wrote: Just brought Mobian up to date today and still no volume controls during calls. Very annoying. Did some web searches but haven't found any fixes for the problem yet.

I had this same with Pulseaudio.
With Pipewire && pipewire-media-session && pipewire-pulse it works Smile

Don't know does it help but worth mentioning
  Reply
#7
(11-05-2022, 01:32 PM)alaraajavamma Wrote:
(11-05-2022, 12:49 PM)Zebulon Walton Wrote: Just brought Mobian up to date today and still no volume controls during calls. Very annoying. Did some web searches but haven't found any fixes for the problem yet.

I had this same with Pulseaudio.
With Pipewire && pipewire-media-session && pipewire-pulse it works Smile

Don't know does it help but worth mentioning

Thanks, I checked and pipewire plus pipewire-media-session were already installed and starting automatically. However pipewire-pulse was not installed. I installed that and rebooted, all three programs started automatically. However that resulted in no sound at all and no response to volume control buttons, not even the on-screen display.  Sad

So I removed pipewire-pulse and rebooted, and fortunately it's back to the way it was - audio works but no volume control during calls.
  Reply
#8
An up-to-date bookworm should have pipewire, pipewire-pulse, and wireplumber with all 3 services enabled and running. pulseaudio servie should be disabled.  pipewire-media-session should have been removed by the upgrade.

https://wiki.debian.org/PipeWire#Debian_...2FUnstable
  Reply
#9
(11-07-2022, 02:36 PM)treebeard Wrote: An up-to-date bookworm should have pipewire, pipewire-pulse, and wireplumber with all 3 services enabled and running. pulseaudio servie should be disabled.  pipewire-media-session should have been removed by the upgrade.

https://wiki.debian.org/PipeWire#Debian_...2FUnstable

Thanks, I'll give that configuration a try and see how it works out.
  Reply
#10
kinda late here, but I've been doin this:


Quote:systemctl --user restart pulseaudio


it seems to fix the audio issues until you restart the device or power it on after shuttin down. I reinstalled to the September 25th image for the time bein.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
Exclamation The latest update of eg25-manager seems to cause frequent disconnections anonymous 12 1,182 11-28-2022, 03:30 PM
Last Post: anonymous
  [Fixed] Phosh crashes frequently after latest updates arno_nuehm 20 3,469 10-14-2022, 05:38 PM
Last Post: Krafter
  Latest Reliable Mobian Build Confirmation Thread Katsujinken 5 1,035 09-27-2022, 08:41 AM
Last Post: Katsujinken
  Wifi issue since last update and held back updates goku499 11 1,640 09-21-2022, 02:39 PM
Last Post: Katsujinken
  Loving latest Mobian Update drh 11 1,924 08-22-2022, 12:19 PM
Last Post: biketool
  Pinephone incoming call / SMS notification no ringing / notification volume dcinoz 3 1,616 06-02-2022, 07:16 AM
Last Post: arkadione
  volume button bug vusra 2 896 05-18-2022, 04:07 AM
Last Post: vusra
  Glacially slow system updates on Mobian - waiting on boot 20m - 1h bujiraso 5 1,844 03-01-2022, 10:06 AM
Last Post: bujiraso
  No updates after upgrade? jojuma 3 1,816 08-26-2021, 08:53 PM
Last Post: bcnaz
  Disabling Volume Rocker? jfenn2199 0 805 07-15-2021, 02:25 PM
Last Post: jfenn2199

Forum Jump:


Users browsing this thread: 1 Guest(s)