PBP booting but stops at flashing power led
#11
Sorry, I guess I was unclear
ALL compression programs have a test parameter,,,,,zip -T some.zip
Because a flipped bit makes the zip useless
(or gzip -t some.gz)
OR,, you could try balenera etcher OR another image OR dd
(rather than gnome disks,, actually sounds more like an error with gnome disks)
-----
Thinking a little more, probably etcher wouldn't work since I think it only does whole disk writes, not partition writes
  Reply
#12
Partitions on the eMMC: 32M | 480M | 4,5G

I copied several large zip files to the third partition and verified them using "zip -T <file name>". They were all fine.

I ran "fsck /dev/sda1" and "fsck /dev/sda2" to check the second and third partition on the eMMC. There were failures shown on both and they were fixed. Booting the PBP again resulted in blinking orange-green power LED.

I flashed Manjaro ARM xfce for PBP using dd command "dd if=<manjaro> of=/dev/sda bs=4M status=progress" and checked the second and third partition with fsck which did not show any failures. PBP booted to orange-green power LED.

It looks like the uboot runs fine and then the Linux OS booting process stops. Is there anything else you can think of to verify that the eMMC has a defect?
  Reply
#13
fsck should (if errors are found) be run twice or more (fsck -f (force)),,
until it returns no errors at all
Maybe, just to verify the emmc,,,,, dd old-emmc -> new-emmc
I think you said old emmc boots ? just no wiFi
  Reply
#14
It took me some time but now I did another intense session to get the PBP going.

I tried to save and copy the old eMMC data to the new eMMC. But this always ends in an io error. I also executed fsck before and after flashing the new eMMC and did try many different ARM distros for the PBP. To me, it looks like the eMMC is somehow damaged.

In addition, booting the PBP from SD card sometimes works and sometimes doesn't - with the identical SD card and linux installation on it. It makes the PBP hard to debug...
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Increasing the maximum power draw dsimic 15 13,227 11-21-2022, 03:36 AM
Last Post: bircoph
  Alternative Power supply options gallomimia 13 13,216 11-13-2022, 06:10 PM
Last Post: pineymousepad
  128GB Module not booting on 2022 Pinebook Pro batch JessicaQ 0 398 08-12-2022, 06:41 AM
Last Post: JessicaQ
  Blinking red light for charger, no power-on bifo 11 8,493 11-30-2021, 01:37 PM
Last Post: wdt
  power on PBP if your keyboard is dead? stozi 0 816 11-29-2021, 01:55 PM
Last Post: stozi
  pinebook pro trackpad randomly stops working chewie 5 4,055 08-10-2021, 04:33 PM
Last Post: chewie
  Motherboard malfunction - a possible warning about power supplies mjc 8 4,384 07-28-2021, 01:04 PM
Last Post: mjc
Question Battery stops charging and NVMe and other media disconnect randomly Eey0zu6O 4 2,985 07-09-2021, 08:45 PM
Last Post: moonwalkers
Question UK Power Supply Feakster 11 13,279 02-09-2021, 12:30 PM
Last Post: dieselnutjob
  Pinebook Pro Dock Power Requirements calinb 9 8,655 12-16-2020, 09:24 AM
Last Post: dsimic

Forum Jump:


Users browsing this thread: 1 Guest(s)