PBP booting but stops at flashing power led - Printable Version

+- PINE64 (
+-- Forum: Pinebook Pro (
+--- Forum: Pinebook Pro Hardware and Accessories (
+--- Thread: PBP booting but stops at flashing power led (/showthread.php?tid=17147)

Pages: 1 2

PBP booting but stops at flashing power led - jonasd - 08-14-2022

I just received my new pinebook pro in 08/2022. After installing the ARM Manjaro Gnome desktop OS to eMMC booting from Manjaro SD card, the PBP started with the new OS. After a couple of system starts, the PBP booted showing the u-boot screen, then showed a blinking cursor in the upper left corner and just stopped with a green-orange-blinking power LED. This has not changed since then. The following paragraphs describe my attempts to fix the problem.

I tried booting from SD card (the same card that worked before) but it doesn't work anymore. I tried different Linux distros to create a bootable SD card using Balena Etcher, e.g. Manjaro Gnome/xfce/KDE and Armbian (new and older versions).

After that, I opened the back cover to check the eMMC switch (no. 24 regarding the PBP wiki). But the new PBP does not have the switch as described. There is another switch (turned by 90 degrees to the original one) which is covered/sealed by a transparent material. I compared the switch to my other PBP (2020 model) and it looks different in my new PBP.

Using a USB eMMC adapter, I flashed several Manjaro and Armbian linux distros on the eMMC and inserted it back into the PBP. My PBP does not boot anymore: not with the eMMC and not with a bootable SD card.

When I insert the eMMC of my old PBP, the PBP boots to an older Manjaro KDE plasma. Keeping the old eMMC in the PBP, I tried to boot from SD card to flash a newer distro to the old eMMC. But it did not work. The PBP only starts from the old eMMC and not from any inserted bootable SD card. The problem with the old eMMC is that wifi is not working (not showing any networks). I do not dare flashing the old eMMC using the USB eMMC adapter...

Is it possible that the new eMMC has a failure and how can I check?

I read a lot of threads in the forum, on reddit and other web sources but all described steps and tips did not work for me. Is there a better way to flash a linux distro with u-boot etc. to eMMC? I also read that it is possible to boot the PBP without eMMC. That does not work with my PBP. Has this changed with the new model? I highly appreciate any tips and hints on how to proceed with my new PBP.

RE: PBP booting but stops at flashing power led - wdt - 08-14-2022

>the PBP booted showing the u-boot screen
Maybe you mean the login screen? Most (nearly all) uboots only display over serial
>I also read that it is possible to boot the PBP without eMMC. That does not work with my PBP.
I think you need a "hard reset", the button inside OR hold pwr button for 20+ seconds
(since pbp has a battery, if it gets into a 'bad state' it can remember that state)
Maybe the uboot on emmc (which has priority) is defective OR maybe some video mismatch
The blinking leds suggest a uboot problem
I suggest leaving emmc out until you get a reliable boot, then you always have a 'fall back"
wifi firmware,, since it seemed to work OK, I am still on the 1st firmware version, that is, I pinned it
(late 2019) For some reason, when the update in 2020 came out, it only helped some people, not all
Not clear what is right or wrong

RE: PBP booting but stops at flashing power led - jonasd - 08-14-2022

Thank you for your immediate response and help!

May be, I used the wrong "name" for the boot info screen. Here is a photo of the screen before it goes black with the blinking cursor and then flashing orange-green power LED.

I pressed the internal reset button many times and also pressed the power button for 20+ seconds. That did not change the PBP behavior.

I share your assumption that the uboot on the eMMC is the problem. Unfortunately, after removing the eMMC the PBP does not even boot. THe power LED stays off during boot without eMMC. In one thread I read that the LED is switched on via software (not hard-wired) during uboot. From this, I assume that the SD card's uboot is not executed when the eMMC is removed. Does removing the eMMC require to switch off the eMMC card using the switch no. 24? If yes, then please help me withe the new board layout. It changed compared to the PBP version in 2020. With the new PBP, the switch is not available as described in the wiki tutorials.

Regarding the wifi: running the 2022 PBP with the old eMMC, does not detect/recognize the wifi card. There are no settings for wifi available. Thus, it seems that the old Manjaro KDE Plasma OS does not detect wifi at all in the new PBP. I will try to update the old eMMC to the latest Manjaro KDE Plasma using the old PBP. Unfortunately, my old PBP freezes after 10-15 minutes of using it. I could never fix this issue with the 2020 PBP. My hope was to have a new working PBP and then replacing parts step-by-step to identify the problem with my old PBP. If the PBP does not freeze too early, the old eMMC will be updated and I can use the newest distro to run in the new PBP. May this solves the wifi issue.

Still, I like your suggestion to first get the new PBP running without eMMC. Do you know any steps to follow? Right now, the PBP does not event switch on the power LED when I remove the eMMC.

RE: PBP booting but stops at flashing power led - wdt - 08-15-2022

You are right, that is a uboot screen
Why it won't boot from SD seems very strange, if there is no uboot at all no led will turn on,
but since you have tried a few images on SD this can't be right
(nearly always an image also has a uboot in 1st 16M)
Try mrfixit image, that has a BSP style uboot
If it doesn't work on SD (with emmc out), try it on emmc
Since you know old emmc has an OK uboot copy the 1st 16M to say usb stick
(dd if=/dev/emmc of=/mnt/usb/1st-16 bs=1M count=16)
Then, with new emmc in adapter copy mbr (1st sector,,count=1 bs=512) somewhere
write 1st-16 (from usb) to new emmc, then saved mbr.. Then new emmc should boot
Also,, there are, not so expensive, usb ->ethernet dongles.. usb2 =<$10, usb3 =$15-25
On occasion quite usefull

RE: PBP booting but stops at flashing power led - jonasd - 08-16-2022

Thanks for the different options. I will execute all of them as soon as possible and report the results.

RE: PBP booting but stops at flashing power led - jonasd - 08-20-2022

This is what I did and the results:

Booting from SD card

  1. Flashed Manjaro ARM xfce 22.06 image to SD card using Balena Etcher
  2. Flashed idbloader, uboot und trust images (from Github) using the "dd" commands given in the MrFixit2001 update script
  3. Reomved the eMMC
  4. Success - the PBP booted from SD card

Booting from eMMC
  1. Saved the first 16M from the old eMMC
  2. Saved the first 512B from the new eMMC (the mbr)
  3. Flashed the first 16M to the new eMMC
  4. Flashed the mbr back to the new eMMC
  5. Booted the PBP and got the same result: power LED flashing green-orange

Thus, I can boot from SD card (but not with eMMC inserted - only without eMMC) but not from eMMC. Before I posted my issue, I also tried to backup the old eMMC and flash the image to the new eMMC. During the flash process I got an error that the size does not fit.

Is there something else I can do to properly flash the new eMMC?

I also tried the following:

a) Flashing Manjaro ARM xfce 22.06 image to eMMC

b) Same as a) and updating idbloader, uboot and trust with MrFixit

c) all steps from a) and b) and flashing the mbr

Unfortunately, the result is the same as described before: boot screen => blinking cursor => power LED flashing green-orange.

RE: PBP booting but stops at flashing power led - wdt - 08-20-2022

My guess is that uboot is finishing, the OS (manjaro xfce ??) has a bad dtb (or maybe initrd)
To really know you have to see a serial output from uboot
Use gparted to shrink old emmc a few GB, whatever appropriate
With unallocated space it doesn't matter if there is a slight size mismatch

RE: PBP booting but stops at flashing power led - jonasd - 08-20-2022

When I shrink the linux os partition and flash the stored image from the old PBP emmc, I get the following error mesage:
Error writing 1048576 bytes to offset 27577548800: Input/output error (g-io-error-quark, 0)

Actually, I get the same error message (with different nos) whenever I try to flash to this partition on the new eMMC.

RE: PBP booting but stops at flashing power led - wdt - 08-20-2022

That error suggest to me that the flash is bad
If the offset is bytes, that is 25.68 GB
So, as an experiment, partition the emmc with a partition at 24 GB, 4GB long
see if this can be written to and read, fat 32 fs, copy a big enough zip, then test it
(zips are very sensitive to errors)

RE: PBP booting but stops at flashing power led - jonasd - 08-21-2022

I did as you suggested: copied zip files to a partition around 24-26GB. No errors were thrown.

After that, I again flashed Manjaro ARM xfce 22.06 for PBP to the eMMC using Gnome Disks. Then, I flashed the previously saved partition 2 of the old working eMMC to partition 2 of the new eMMC. The saved .img file has 50.3 GB and partition 2 of the new eMMC has 62 GB.

I did this five times and every time the flash process stopped with the following error:
Error writing 1048576 bytes to offset x: Input/output error (g-io-error-quark, 0)

attempt 1: offset = 39154876416
attempt 2: offset = 37957402262
attempt 3: offset = 33597423616
attempt 4: offset = 32544653312
attempt 5: offset = 32437698560

Thus, flashing the partition 2 image of the old (working) eMMC is somehow not possible. But copying zip files is working fine.