Won't boot, black screen
#5
(07-03-2022, 03:09 AM)mdk Wrote: Solved my issue. Since yesterday I was wondering how u-boot passed arguments to the kernel, as I was not seeing them in extlinux.conf, it looked like:

Code:
label l0
    menu label Debian GNU/Linux bookworm/sid 5.15-sunxi64
    linux /vmlinuz-5.15-sunxi64
    initrd /initrd.img-5.15-sunxi64

    append root=/dev/mapper/calamares_crypt ro quiet

I was like "OK 'append' but where are the others"?

Doodling around the u-boot documentation and things, I spotted:


Code:
root@seraph:/# apt-cache policy u-boot-menu

u-boot-menu:
  Installed: 4.1.0
  Candidate: 4.1.0
  Version table:
*** 4.1.0 990
        990 http://deb.debian.org/debian bookworm/main arm64 Packages
        100 /var/lib/dpkg/status
    4.0.4mobian1 990
        990 http://repo.mobian-project.org bookworm/main arm64 Packages

So I promptly ran:
Code:
apt install u-boot-menu=4.0.4mobian1
u-boot-update

Rebooted, and boom, solved.


In case someone needs to do it too, I'm doing it over USB mass storage, (hold volume up in tow-boot until the 2nd vibration, or via Jump Drive), I installed

Code:
apt install qemu-user-static binfmt-support

So I can run binaries via qemu, and then just run:
Code:
mount --bind /dev /media/mdk/root/dev/
mount --bind /sys /media/mdk/root/sys/
mount --bind /proc /media/mdk/root/proc/
mount --bind /media/mdk/boot /media/mdk/root/boot/
chroot /media/mdk/root/

to chroot myself in my phone.


So, let's go read /var/log/apt/history.log:

Code:
Start-Date: 2022-06-25  08:23:26
Commandline: apt full-upgrade
Requested-By: mobian (1000)
Upgrade: gstreamer1.0-plugins-ugly:arm64 (1.20.2-1+b1, 1.20.3-1), gsasl-common:arm64 (1.11.3-3, 2.0.0-1), libinput10:arm64 (1.20.1-1, 1.21.0-1), u-boot-menu:arm64 (4.0.4mobian1, 4.1.0), libgsasl18:arm64 (1.11.3-
3, 2.0.0-1), libgstreamer-plugins-bad1.0-0:arm64 (1.20.2-1+b1, 1.20.3-1), gir1.2-gst-plugins-bad-1.0:arm64 (1.20.2-1+b1, 1.20.3-1), libgnutls30:arm64 (3.7.4-2, 3.7.6-2), gstreamer1.0-plugins-bad:arm64 (1.20.2-1+
b1, 1.20.3-1), libgnutls-dane0:arm64 (3.7.4-2, 3.7.6-2), libinput-bin:arm64 (1.20.1-1, 1.21.0-1)
End-Date: 2022-06-25  08:25:38

and here we are, u-boot-menu upgraded from 4.0.4 (mobian side) to 4.1.0 (debian side).

Congrats on solving it. This is a good thread to keep around as someone else might find this useful. Just the other day I flashed Tow-boot to boot sector  on my PP and this is great. No more jump drive although jump drive was like a must have in the beginning.
  Reply


Messages In This Thread
Won't boot, black screen - by mdk - 07-02-2022, 05:25 PM
RE: Won't boot, black screen - by Chief - 07-02-2022, 07:34 PM
RE: Won't boot, black screen - by mdk - 07-03-2022, 01:22 AM
RE: Won't boot, black screen - by mdk - 07-03-2022, 03:09 AM
RE: Won't boot, black screen - by Chief - 07-03-2022, 06:38 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Screen auto-rotation sensitivity mdk 0 176 12-26-2023, 06:08 AM
Last Post: mdk
  mobian installed to eMMC - how to install tow-boot grump_fiddle_reinstall 6 1,507 11-22-2023, 11:46 AM
Last Post: aLoop100o
  How to check if tow-boot is installed? jojuma 3 737 09-29-2023, 11:29 PM
Last Post: tllim
  Mobian boot failed with zstd message after upgrade. Mahgue 0 550 09-01-2023, 11:29 AM
Last Post: Mahgue
  Screen stay black unless power key pressed short freelectro 0 572 06-24-2023, 01:55 PM
Last Post: freelectro
  Unsuspend → Black screen mdk 15 4,563 06-22-2023, 11:20 AM
Last Post: Melechtna
  4G data on default startup / boot dcinoz 1 746 04-29-2023, 11:24 PM
Last Post: dcinoz
  PinePhone won't boot after software update jb2000 2 1,198 03-17-2023, 07:26 AM
Last Post: Zebulon Walton
  Boot log analyses -> GPU no regulator (mali) found freelectro 0 863 03-06-2023, 12:06 PM
Last Post: freelectro
  boot gets stuck shortly after disk decryption vortex 8 3,669 02-13-2023, 02:11 AM
Last Post: sharase

Forum Jump:


Users browsing this thread: 1 Guest(s)