4G data on default startup / boot
#1
Hi,

I recently turned my Pinephone back on with a SIM inserted - it had been last used in 4G mode only for VoLTE test purposes with mobile data off.
This time mobile data was on - I had to disable the still incorrect aeroplane mode - this turned on bluetooth - and I could then access the mobile data setting to turn it off.

I ran updates and rebooted and the same thing happened, the phone restarted with 4G data back on whereas data had been turned off before restarting it.

How come this has changed? How do I disable data at startup? Why are the settings prior to restart / reboot not preserved?

Can't believe the aeroplane mode bug is still present too....

I could find nothing on https://salsa.debian.org/groups/Mobian-team/-/issues
or https://source.puri.sm/Librem5/phosh/-/issues

Curious as to whether or not anyone else has noticed this.

Thanks for your help / feedback.
Pinephone v1.2 UBports CE. Adelaide, Australia using Amaysim SIM (Optus network, VoLTE enabled) with Mobian SD card. VoLTE working also with Felix / Vodafone AU and Aldimobile / Telstra AU.
Manjaro Plasma Mobile on EMMC.
  Reply
#2
Deleting all mobile related files in /etc/NetworkManager/system-connections/ has fixed it.
Mobile data is no longer enabled at boot.
Pinephone v1.2 UBports CE. Adelaide, Australia using Amaysim SIM (Optus network, VoLTE enabled) with Mobian SD card. VoLTE working also with Felix / Vodafone AU and Aldimobile / Telstra AU.
Manjaro Plasma Mobile on EMMC.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  mobian installed to eMMC - how to install tow-boot grump_fiddle_reinstall 6 2,137 11-22-2023, 11:46 AM
Last Post: aLoop100o
  How to check if tow-boot is installed? jojuma 3 1,039 09-29-2023, 11:29 PM
Last Post: tllim
  gnome-control-center: segmentation fault on startup jojuma 4 1,210 09-12-2023, 08:49 AM
Last Post: jojuma
  Mobian boot failed with zstd message after upgrade. Mahgue 0 668 09-01-2023, 11:29 AM
Last Post: Mahgue
  Is that a Multiboot selection on startup? jojuma 0 545 07-09-2023, 03:09 AM
Last Post: jojuma
  PinePhone won't boot after software update jb2000 2 1,396 03-17-2023, 07:26 AM
Last Post: Zebulon Walton
  Boot log analyses -> GPU no regulator (mali) found freelectro 0 1,006 03-06-2023, 12:06 PM
Last Post: freelectro
  Bogus default gateway keeps appearing Zebulon Walton 7 2,363 02-25-2023, 09:48 PM
Last Post: Zebulon Walton
  boot gets stuck shortly after disk decryption vortex 8 4,157 02-13-2023, 02:11 AM
Last Post: sharase
  [solved] Black screen at boot time mdk 0 1,041 01-13-2023, 03:33 AM
Last Post: mdk

Forum Jump:


Users browsing this thread: 1 Guest(s)