Struggle to install LibreOffice on the PinePhone
#1
I am struggeling to install Libre Office on the PinePhone.

Martijn Braam showed that it runs on Postmarket OS:

https://www.youtube.com/watch?v=yBeza4UNOm8

It runs on Fedora:

https://www.youtube.com/watch?v=D2ZyZo1r5KY&t=326s

I tried to install it manually:

https://www.youtube.com/watch?v=Wrekoy__DLg

but I gave up due to complicated file formats.

Sudo apt install libreoffice as in this instruction failed in PostmarkedOS:

https://linuxhint.com/install-libreoffic...inux-mint/

LibreOffice should work on the M10 with Ubports:

https://forums.ubports.com/topic/3199/so...-on-m10/22

but new files can only be created by the file manager, but not by LibreOffice.

I tried to install LibreOffice on Ubports PinePhone, but I get an error message:

https://forums.ubports.com/topic/7727/li...1860526898

Does someone use LibreOffice on the PinePhone or Ubports? If someone buts a«buggy» LibreOffice in the App store. I would be very happy with a buggy solution. It would save a lot of time.
  Reply
#2
You used the wrong package manager for PostmarketOS - they use apk not apt. LibreOffice seems to be available in the upstream Alpine, so it may be as simple as something like:
sudo apk add libreoffice
  Reply
#3
Thanks, Wibble, very helpful. Martijn Braam demonstrated on his Youtube channel, that it is possible to run LibreOffice on the PinePhone:

https://youtu.be/1NIWh2cX3nQ

but he didn't tell his installation method to install LibreOffice. It remains his secret. Therefore I trust in you.
  Reply
#4
Wibble, it was a simple as that. I executed your command line, and LibreOffice was installed. I installed it on a Multi boot SD card Postmarket OS with GNOME desktop. I received the message:

48 errors

1273 MiB in 628 packages.

LibreOffice is NOT listed in the application list, and also nowhere else I could see it  Angry .

Another trial:


The command

sudo apt install libreoffice

worked on Ubuntu Touch installed on the internal SD card.

I received the error message:

packed libreoffice not available, but is referred to by another packet…

Also this installation trail failed Angry .
  Reply
#5
In PmOS are you showing all apps, or just the mobile-friendly ones? Did you try starting from terminal?

On mobian it installs with 'sudo apt install libreoffice', and the launcher icons appear if you scroll to the bottom of the phosh launcher and pick 'Show All Apps' but there is some display issue resulting in a blank display on the phone when you start it. If I ssh in with X forwarding I can start libreoffice with everything appearing on my desktop, so it can run. My guess is there's a detection issue similar to https://bugs.documentfoundation.org/show...?id=121275 and that it would work with the right options.
  Reply
#6
Thank you very much for your help, Wibble. My installation was faulty:

https://forum.pine64.org/showthread.php?tid=16614

I installed PostMarketOS Posh on my internal SD card now, and I could start it. Then I immediately connected the phone to a WIFI network. Then I run a terminal with the command:

sudo apk add libreoffice

the installation finished fine. There where all the LibreOffice icons on the desktop. Then I restarted the phone. I had to login with default user «user» and pincode «147147». But then, only the PostmarkedOS promt appeared, but the graphical user interface did not start.

I reinstalled postmarket OS. Then I rebooted PostmarketOS, PIN code 147147. I connected the phone to wifi and tested it, everything fine.

Another reboot, as above, everyting worked fine.

Then I installed once more libreOffice as described above, everything worked as above. Then I rebootet the phone once more.

The same problem appeared. I had to login with default user «user» and pincode «147147». But then, only the PostmarkedOS promt appeared, but the graphical user interface did not start.

What is wrong Angry .
  Reply
#7
I've not used PmOS in a long time, so can't really help with that. Perhaps ask in the PmOS section here, or one of their community areas?
https://wiki.postmarketos.org/wiki/Category:Community
  Reply
#8
Thanks, Wibble.

I first installed Ubuntu Touch on my second hand PinePhone which could not start according to the following instruction:

https://www.youtube.com/watch?v=Zf0zwq6jI30&t=363s

After some attempts, I changed to PostmarketOS.

Martijn Braam shows two examples where he installed LibreOffice on a PinePhone (Braveheart):

I suppose he used PostmarketOS:

https://www.youtube.com/watch?v=yBeza4UNOm8

https://www.youtube.com/watch?v=1NIWh2cX3nQ

I could not reproduce Martijn Braams LibreOffice installation. Martijn Braams did not comment it on his Youtube channel.

Wibble suggested to install LibreOffice on mobian as described above. I flashed mobian on my PinePhone, but it did not start.

Then I saw that tow-Boot is required to be able to boot the mobian images:

https://wiki.pine64.org/wiki/PinePhone_S...ownload_10

I tried the PinePhone multi-distro demo image:

https://xnux.eu/p-boot-demo/

but mobian does not start on the multi-distro demo image, an is stuck on the boot screen Angry .
  Reply
#9
I can confirm the detection issue I suspected on Mobian/Phosh - I can get it to start on the phone from the terminal if I force the desktop selection with an environment variable:
OOO_FORCE_DESKTOP=gnome-wayland libreoffice

It turns out libreoffice tries to detect different desktop environments and behave accordingly, but Phosh isn't one it knows about and its fallback doesn't work with phosh on wayland. If you're using a different desktop it could do something different. If phosh used to be detected as gnome it may have 'just worked' in the past. I assume this is a cross-distro problem, but perhaps they have patches or something different in the desktop environment to make it work.
https://git.libreoffice.org/core/+/HEAD/...tector.cxx
https://bugs.documentfoundation.org/show...?id=121275 (an old detection bug with similar symptoms)

You'll need a pointing device as it's not touch friendly, at least by default. I don't know whether there are any optional packages or settings that could improve it. I don't know if I just couldn't touch things accurately enough, or if it's something else like touch generating different events to mouse, but with only the touchscreen I couldn't get it to do much. If you've got a working USB dock and can use a mouse and keyboard it may be fine in landscape. Mine is a BraveHeart without the USB fix so that's not an option. I don't have a bluetooth mouse, and haven't tried the bluetooth keyboard.
  Reply
#10
Thank you very much for your extended discussion, your confirmation of LibreOffice problems, and further suggestions.

Matthew Higgins confirmed on his Youtube channel that it is possible to edit documents in LibreOffice Writer and LibreOffice Calc. He had Fedora installed on the PinePhone.

I have chosen the PinePhone phosh keyboard img from 2021-Aug-10 00:38 . I already have the PinePhone keyboard which would be great for LibreOffice. I don t know whether the other or older PostmarketOS distro already support the PinePhone keyboard. But I could connect a Bluetooth keyboard and a mouse to some distros.

I installed Ubuntu Touch once more on the Pinephone. The last attempt to install LibreOffice in a Libertine container ended up with an error message after about 100 operation details lines:

E: Couldn t downlaod packages: passwd perl-base systemd sysv-rc sysvinit-utils tar tzada ubuntu-keyring util-linux zib 1g

After a fresh install, installation of LibreOffice took much longer. The Libertine container showed the «ready» status. Then I reveived a message that the memory of the internal SD card is low. I did a fresh install of all, already low memory on the Internal 16GB eMMC after LibreOffice installation?

Unfortunately, also after the second trial to install LibreOffice on Ubuntu Touch, no LibreOffice icons where visible on the Ubuntu Touch desktop Angry .
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Article: Build a PinePhone App with Zig and zgt lupyuen 2 58 06-26-2022, 02:20 AM
Last Post: lupyuen
  Distro for writers, k & m, LibreOffice, PostmarketOS? Peter Gamma 13 616 06-20-2022, 03:06 AM
Last Post: wibble
  Boxes at startup of LibreOffice cannot be executed Peter Gamma 0 37 06-12-2022, 03:02 AM
Last Post: Peter Gamma
  Trouble building pinephone-keyboard tools 64_Tesseract 1 149 06-11-2022, 03:17 PM
Last Post: carterza
  Jami on Pinephone [ IM and VOIP ] p1trson 14 4,086 06-09-2022, 01:13 AM
Last Post: AndyM
  Pinephone: Is there a frugal distro? orbital 2 264 05-27-2022, 09:34 PM
Last Post: orbital
  Pinephone: OpenGL support? orbital 1 162 05-24-2022, 10:02 AM
Last Post: fire219
  openSUSE for Pinephone Alefnode 71 63,494 05-15-2022, 10:44 AM
Last Post: flembcke
  Latest firmware for PinePhone modem! Subsentient 105 73,140 05-14-2022, 08:56 PM
Last Post: kk22
  Slack on PinePhone Adam Seline 2 1,253 05-01-2022, 04:04 AM
Last Post: nickolas

Forum Jump:


Users browsing this thread: 1 Guest(s)