rock64-debian-mrfixit-190531.img.xz : missing /usr/lib/dri/rockchip_dri.so
#1
Hello !

I have a V3 Rock64. No PSU or HDMI issues : i have XU4, RPI-1, RPI-2, BPI-M5 without problems.

- rock64-debian-mrfixit-190531.img.xz >> SD Card  :  it lags very much, when moving windows with LXDE.
- rock64-debian-mrfixit-190531.img.xz >> mmc Card (Foresee 16 Go) : i can't start X, xorg doesn't find /usr/lib/dri/rockchip_dri.so. Can't find this file on my disk.

- Armbian >> black lines on screen when moving windows in XFCE.
- Armbian >> dashboard moving up an down quickly when i move some windows (ex : PCManFM, but not galculator (?))

- Slackware XFCE : works great, but no dependencies supported by this OS (?).

- Ubuntu : i don't want.

- FreeBSD .img for Rock64 doesn't boot.

What distros work on your V3 board, please ?

Undecided
  Reply
#2
(07-30-2021, 05:20 PM)popi Wrote: Hello !

I have a V3 Rock64. No PSU or HDMI issues : i have XU4, RPI-1, RPI-2, BPI-M5 without problems.

- rock64-debian-mrfixit-190531.img.xz >> SD Card  :  it lags very much, when moving windows with LXDE.
- rock64-debian-mrfixit-190531.img.xz >> mmc Card (Foresee 16 Go) : i can't start X, xorg doesn't find /usr/lib/dri/rockchip_dri.so. Can't find this file on my disk.

- Armbian >> black lines on screen when moving windows in XFCE.
- Armbian >> dashboard moving up an down quickly when i move some windows (ex : PCManFM, but not galculator (?))

Try use this https://github.com/armbian/build/blob/ma.../xfwm4.xml settings for WM. Copy over in your home directory config/xfce4/xfconf/xfce-perchannel-xml/xfwm4.xml and try again. Or build image from sources.
  Reply
#3
(07-31-2021, 04:23 AM)igorp Wrote: Try use this https://github.com/armbian/build/blob/ma.../xfwm4.xml settings for WM. Copy over in your home directory config/xfce4/xfconf/xfce-perchannel-xml/xfwm4.xml and try again. Or build image from sources.

Thank you Igorp for your help  Blush

No luck, the black lines are still here, even after having changed the xfwm4.xml file.
This makes windows moving without showing inside, but those black lines..are still here  Angry coming from GPU/or driver (?).
No hope for this board : i have tested DietPi : it shows me on boot "5v error from gpio" messages.
Only slackware XFCE works good... for the moment.
  Reply
#4
Oups ! The Slackware doesn't boot from mmc, than i bought specialy for it  Dodgy

Cool : i have "NO OS" working for my Rock64 V3. Happy.

Undecided
  Reply
#5
How have you confirmed that you have no physical HDMI issues. I assume you have quality HDMI cables and no shorting at the HDMI headers on the board. I bought 5 Rock64 v2 boards and have confirmed that 2 of them have faulty ethernet sockets and 1 has a faulty USB2 socket possibly down to poor soldering. If you have any warranty left on the board I'd return it now.
  Reply
#6
I am pretty sure Armbian works on Rock64, even there is no official support. But you have to build it from sources - there were some important fixed added lately.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  DietPi OS for ROCK64 MichaIng 19 5,028 09-17-2021, 02:38 PM
Last Post: MichaIng
  slarm64 (unofficial slackware) Rock64 RK3328 (aarch64) mara 117 72,958 09-10-2021, 03:01 PM
Last Post: mara
  openwrt for the rock64 wilsonYan 15 7,393 06-28-2021, 09:50 PM
Last Post: wilsonYan
  Centos 8 Stream on Rock64 ayoungdukie 1 521 06-07-2021, 11:50 AM
Last Post: zer0sig
  Talos on ROCK64 cjyar 2 580 06-04-2021, 11:50 AM
Last Post: cjyar
  CentOS 7 for Rock64 pineadmin 3 3,565 05-30-2021, 08:20 AM
Last Post: ayoungdukie
  Rock64 CRUX-ARM (aarch64) mara 0 412 05-27-2021, 02:22 PM
Last Post: mara
  RETRO-GAMING: UPDATED RELEASE OF RECALBOX FOR THE ROCK64 Mrfixit2001 32 27,422 05-22-2021, 07:01 AM
Last Post: fartadeadrian
  Debian build from mrfixit2001 Luke 18 12,741 05-17-2021, 02:35 AM
Last Post: Wizzard
  Armbian for Rock64 pineadmin 31 24,835 05-08-2021, 09:35 AM
Last Post: Wizzard

Forum Jump:


Users browsing this thread: 1 Guest(s)