Is my VoLTE working?
#1
Hi, I followed all the instructions I could find to get VoLTE working. My carrier "Consumer Cellular" uses AT&T network which is soon totally disabling 3G so I must get VoLTE working. However I'm not sure if it is working. I need help understanding it.

I have Manjaro CE with Phosh.

I reached the carrier support and they succesfuly detected the modem model and enabled something on their end to allow VoLTE.

I followed the VoLTE steps on the main PinePhone wiki page.

Code:
AT+QCFG="ims"
+QCFG: "ims",1,1

OK

The 4G indicator shows in the UI. To test, I called my wife.

Code:
#Start call to my wife:

[root@manjaro-arm ~]# echo 'AT+CLCC' | atinout - /dev/EG25.AT -
+CLCC: 2,1,0,1,0,"",128
+CLCC: 1,1,0,1,0,"",128
+CLCC: 3,0,0,0,0,"4436179824",129,"Andrea"
+CLCC: 4,1,0,1,0,"",128

OK

#Hang up:

[root@manjaro-arm ~]# echo 'AT+CLCC' | atinout - /dev/EG25.AT -
+CLCC: 2,1,0,1,0,"",128
+CLCC: 1,1,0,1,0,"",128

OK

[root@manjaro-arm ~]# echo 'AT+QNWINFO' | atinout - /dev/EG25.AT -
+QNWINFO: "FDD LTE","310410","LTE BAND 2",700

OK



Elsewhere I have read that the fourth value of AT+CLCC tells you whether the voice is carried by VoLTE. The Quectel AT command reference says ony this about it:

<mode>Bearer/tele service
0: Voice
1: Data
2: FAX

However the line with my wife's phone number has a 0 in that position. Still I wonder, with all the other symptoms lining up??
  Reply
#2
This example would suggest so https://forum.pine64.org/showthread.php?...7#pid86137

You're also registered on IMS.

If your phone stays on 4G then yes, it's VoLTE for sure, if it drops to 3G (or 2G) for the call, then no.



You can also check whether or not you're on 4G during the call (rather than after) using

Code:
mmcli -m any --command='AT+QNWINFO'

You might add this to the other thread if it's confirmed.
Pinephone v1.2 UBports CE. Adelaide, Australia using Aldimobile SIM with Mobian SD card.
Manjaro Plasma Mobile on EMMC.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  JumpDrive not working due to device busy cnxsoft 3 253 08-08-2021, 12:18 AM
Last Post: mouffa
  Still trying, SMS not working Nutmeg 17 641 07-28-2021, 08:10 PM
Last Post: bcnaz
  For those of us that need a working daily driver Nutmeg 6 736 07-13-2021, 03:33 PM
Last Post: Nutmeg
  4G VoLTE calls confirmed working with carrier x dcinoz 6 2,898 07-08-2021, 04:34 AM
Last Post: zetabeta
  VoLTE calls with o2 (Germany) arno_nuehm 6 1,556 07-06-2021, 02:38 AM
Last Post: arno_nuehm
  After flashing UT on eMMC Convergence package not working anymore dfjdw8 0 322 06-11-2021, 12:28 AM
Last Post: dfjdw8
  Data downloading not working with SIM IMSAI8080 4 1,220 03-15-2021, 08:39 AM
Last Post: IMSAI8080
  Working modem? Barugon 34 6,200 03-05-2021, 07:07 PM
Last Post: Barugon
  VoLTE / Sprint fm'latghor 3 1,892 02-19-2021, 04:19 PM
Last Post: camsonne
  Modem stops working after CRUST Trbl 3 1,408 11-26-2020, 10:28 AM
Last Post: Ph42oN

Forum Jump:


Users browsing this thread: 1 Guest(s)