Booting my RockPro64 from NVMe drive
#5
(05-02-2021, 01:56 AM)LMM Wrote: my boot sequence :

Code:
U-Boot 2021.01-09768-gc762ab29b8 (Mar 20 2021 - 13:48:40 +0000)

SoC: Rockchip rk3399
Reset cause: POR
Model: Pine64 RockPro64 v2.1
DRAM:  3.9 GiB
PMIC:  RK808
MMC:   mmc@fe310000: 2, mmc@fe320000: 1, sdhci@fe330000: 0
Loading Environment from SPIFlash... SF: Detected gd25q128 with page size 256 Bytes, erase size 4 KiB, total 16 MiB
*** Warning - bad CRC, using default environment

In:    serial
Out:   serial
Err:   serial
Model: Pine64 RockPro64 v2.1
Net:   eth0: ethernet@fe300000
Hit any key to stop autoboot:  0
Card did not respond to voltage select! : -110
Card did not respond to voltage select! : -110

Device 0: Vendor: 0x1987 Rev: CS303320 Prod: PNY4720003194010479F
            Type: Hard Disk
            Capacity: 238475.1 MB = 232.8 GB (488397168 x 512)
... is nowScanning nvme 0:1...
Found U-Boot script /boot/boot.scr
3185 bytes read in 2 ms (1.5 MiB/s)
## Executing script at 00500000
Boot script loaded from nvme 0
166 bytes read in 2 ms (81.1 KiB/s)
15335962 bytes read in 32 ms (457 MiB/s)
28582400 bytes read in 55 ms (495.6 MiB/s)
75809 bytes read in 4 ms (18.1 MiB/s)
2698 bytes read in 3 ms (877.9 KiB/s)
Applying kernel provided DT fixup script (rockchip-fixup.scr)
## Executing script at 09000000
Moving Image from 0x2080000 to 0x2200000, end=3de0000
## Loading init Ramdisk from Legacy Image at 06000000 ...
   Image Name:   uInitrd
   Image Type:   AArch64 Linux RAMDisk Image (gzip compressed)
   Data SizAddress: 00000000
   Entry Point:  00000000
   Verifying CheckOK
## Flattened Device Tree blob at 01f00000
   Booting using the fdt blob at 0x1f00000
   Loading Ramdisk to f1066000, end fOK
   Loading Device Tree to 00000000f0feb000, end 00000000f1065fff ... OK

Starting kernel ...

[    8.210542] OF: graph: no port node found in /i2c@ff3d0000/typec-portc@22
[   10.094840] systemd[1]: Failed to start Raise network interfaces.
[   10.688541] Bluetooth: hci0: command 0x0c03 tx timeout
[   18.912586] Bluetooth: hci0: BCM: Reset failed (-110)

Armbian 21.02.3 Focal ttyS2

I have not activated much log (verbosity =2 in armbianEnv.txt)

Code:
incorrect device type in 1
Perhaps due to your second partition nvme0n1p2 ?

Sorry peeps I completely missed these messages.
I even forgot I had account here!

I need to come here more often!

I don't even remember why I came here about the messages. Probably just out of curiosity.
I'm using Debian Buster for this architecture, if this matters!
  Reply


Messages In This Thread
RE: Booting my RockPro64 from NVMe drive - by LMM - 05-01-2021, 02:14 PM
RE: Booting my RockPro64 from NVMe drive - by LMM - 05-02-2021, 01:56 AM
RE: Booting my RockPro64 from NVMe drive - by PsySc0rpi0n - 05-11-2022, 02:35 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Installing Wifi drive for the RockPro64 John45595 0 304 02-10-2024, 11:32 PM
Last Post: John45595
  Mainline U-Boot with SPI, NVMe and SATA boot support sigmaris 108 119,253 09-25-2023, 12:46 AM
Last Post: ChriChri
Wink You don't sell case and fan for "ROCKPro64 4GB Single Board Computer"? Clea 1 749 09-17-2023, 12:00 AM
Last Post: tllim
  Want to check maximum toggle speed in Rockpro64 board. kundanjha 0 681 08-14-2023, 07:55 AM
Last Post: kundanjha
  Unable to boot Armbian on new RockPro64 mooseball 5 4,240 07-14-2023, 08:59 AM
Last Post: rockjonn
  Hardware fix for software sound problem on Rockpro64 Ricks Rockpro 0 885 04-06-2023, 03:59 PM
Last Post: Ricks Rockpro
  No sound on Rockpro64 with OpenWrt Patrice 1 1,317 04-06-2023, 02:46 PM
Last Post: Ricks Rockpro
  Cant get rockpro64 working brasilikum 3 1,815 03-19-2023, 06:22 AM
Last Post: runyor
  RockPro64 Stopped working WarpLover 5 2,640 02-06-2023, 10:10 AM
Last Post: diizzy
Lightbulb ROCKPro64 + SSD case model for 3D print Spater 0 1,017 01-27-2023, 07:43 PM
Last Post: Spater

Forum Jump:


Users browsing this thread: 1 Guest(s)